Topics

FLDIGI not shifting modes from flmsg

John KC4LZN
 

I've included a link to the video, quality isn't that great and my first feeble attempt to record my desktop. It is split screen showing two Raspberry Pi's desktops.

I've been testing back and forth, have two Raspberry Pi's 3 Model B, with fldigi and flmsg, trying to learn the ins and outs with these two programs. Both Pi's fldigi programs are set in RxID and TxID on. 

I started out with both fldigi's in Olivia 8/500 mode. Opened flmsg, created a test message and sent it in Olivia 8/500 from the drop down menu in flmsg. Receiving Pi got it, deciphered it with no issues. I then dropped the box down in flmsg and changed the mode to MT63-2KL and transmitted. The receiving Pi window shows it expanded to "see" that mode but in the text box, it said it was still in Olivia 8/500. I re-transmitted the message again with no changes and the receiving Pi correctly identified the mode and received the message with no errors.

Without going in the great detail about ALL of the settings, is there an area I need to look at in the settings to ensure that the RxID changes to the proper mode? 

Again, the link below to see the video. There is no audio. Hope it makes sense and will field questions best as I can.

https://youtu.be/j9uxG-rCO9U

73
John
KC4LZN

Dave
 

Make sure  you are not overdriving the Rx unit.  Try sending a TUNE signal and looking at the SIG view of (WF/FFT/SIG).  The peak-to-peak value of the signal should not exceed the uper and lower grey lines.

Test the RsID performance just using the fldigi programs without flmsg (one less failure point).  Make sure that TxID is and RxID is enabled on all of the modes you will be testing.  From the IDs/RsID configuration dialog, select "Receive modes" and "Transmit modes"; check every mode that you want to both TX and RX the RsID signal.  To test RsID simply select the Tx mode and press the T/R button on fldigi.

David

On 2/26/20 9:34 AM, John KC4LZN wrote:
I've included a link to the video, quality isn't that great and my first feeble attempt to record my desktop. It is split screen showing two Raspberry Pi's desktops.

I've been testing back and forth, have two Raspberry Pi's 3 Model B, with fldigi and flmsg, trying to learn the ins and outs with these two programs. Both Pi's fldigi programs are set in RxID and TxID on. 

I started out with both fldigi's in Olivia 8/500 mode. Opened flmsg, created a test message and sent it in Olivia 8/500 from the drop down menu in flmsg. Receiving Pi got it, deciphered it with no issues. I then dropped the box down in flmsg and changed the mode to MT63-2KL and transmitted. The receiving Pi window shows it expanded to "see" that mode but in the text box, it said it was still in Olivia 8/500. I re-transmitted the message again with no changes and the receiving Pi correctly identified the mode and received the message with no errors.

Without going in the great detail about ALL of the settings, is there an area I need to look at in the settings to ensure that the RxID changes to the proper mode? 

Again, the link below to see the video. There is no audio. Hope it makes sense and will field questions best as I can.

https://youtu.be/j9uxG-rCO9U

73
John
KC4LZN

John KC4LZN
 

I did check the signal input as well as what the output was and may lay the issue to the cheap USB soundcards I am using to interface the two Pi's. I will test again over the air when I can get them lined up with two transceivers with legitimate interfaces that have better sound cards 

When I did initially check, because I aired on the side of caution when I set the audio up on these. The transmit sound (speaker) was set well too low and adjusted where the sound was just below the two grey lines but the same results were received. 

I'll do some more testing and looking into digging into the audio side again and see if there was something I overlooked. 

Thanks for the tips on the waterfall settings and audio adjustments. I'm sure OTA testing will prove to be very good.

73
John




On Wed, Feb 26, 2020 at 11:15 AM Dave <w1hkj@...> wrote:

Make sure  you are not overdriving the Rx unit.  Try sending a TUNE signal and looking at the SIG view of (WF/FFT/SIG).  The peak-to-peak value of the signal should not exceed the uper and lower grey lines.

Test the RsID performance just using the fldigi programs without flmsg (one less failure point).  Make sure that TxID is and RxID is enabled on all of the modes you will be testing.  From the IDs/RsID configuration dialog, select "Receive modes" and "Transmit modes"; check every mode that you want to both TX and RX the RsID signal.  To test RsID simply select the Tx mode and press the T/R button on fldigi.

David

On 2/26/20 9:34 AM, John KC4LZN wrote:
I've included a link to the video, quality isn't that great and my first feeble attempt to record my desktop. It is split screen showing two Raspberry Pi's desktops.

I've been testing back and forth, have two Raspberry Pi's 3 Model B, with fldigi and flmsg, trying to learn the ins and outs with these two programs. Both Pi's fldigi programs are set in RxID and TxID on. 

I started out with both fldigi's in Olivia 8/500 mode. Opened flmsg, created a test message and sent it in Olivia 8/500 from the drop down menu in flmsg. Receiving Pi got it, deciphered it with no issues. I then dropped the box down in flmsg and changed the mode to MT63-2KL and transmitted. The receiving Pi window shows it expanded to "see" that mode but in the text box, it said it was still in Olivia 8/500. I re-transmitted the message again with no changes and the receiving Pi correctly identified the mode and received the message with no errors.

Without going in the great detail about ALL of the settings, is there an area I need to look at in the settings to ensure that the RxID changes to the proper mode? 

Again, the link below to see the video. There is no audio. Hope it makes sense and will field questions best as I can.

https://youtu.be/j9uxG-rCO9U

73
John
KC4LZN

Bill Turner, wb4alm
 

This may be a dumb suggestion, but verify that your usb sound cards are sampling at 48000.

/s/ Bill Turner, wb4alm


On 2/26/20 12:23 PM, John KC4LZN wrote:
I did check the signal input as well as what the output was and may lay the issue to the cheap USB soundcards I am using to interface the two Pi's. I will test again over the air when I can get them lined up with two transceivers with legitimate interfaces that have better sound cards 

When I did initially check, because I aired on the side of caution when I set the audio up on these. The transmit sound (speaker) was set well too low and adjusted where the sound was just below the two grey lines but the same results were received. 

I'll do some more testing and looking into digging into the audio side again and see if there was something I overlooked. 

Thanks for the tips on the waterfall settings and audio adjustments. I'm sure OTA testing will prove to be very good.

73
John




On Wed, Feb 26, 2020 at 11:15 AM Dave <w1hkj@...> wrote:

Make sure  you are not overdriving the Rx unit.  Try sending a TUNE signal and looking at the SIG view of (WF/FFT/SIG).  The peak-to-peak value of the signal should not exceed the uper and lower grey lines.

Test the RsID performance just using the fldigi programs without flmsg (one less failure point).  Make sure that TxID is and RxID is enabled on all of the modes you will be testing.  From the IDs/RsID configuration dialog, select "Receive modes" and "Transmit modes"; check every mode that you want to both TX and RX the RsID signal.  To test RsID simply select the Tx mode and press the T/R button on fldigi.

David

On 2/26/20 9:34 AM, John KC4LZN wrote:
I've included a link to the video, quality isn't that great and my first feeble attempt to record my desktop. It is split screen showing two Raspberry Pi's desktops.

I've been testing back and forth, have two Raspberry Pi's 3 Model B, with fldigi and flmsg, trying to learn the ins and outs with these two programs. Both Pi's fldigi programs are set in RxID and TxID on. 

I started out with both fldigi's in Olivia 8/500 mode. Opened flmsg, created a test message and sent it in Olivia 8/500 from the drop down menu in flmsg. Receiving Pi got it, deciphered it with no issues. I then dropped the box down in flmsg and changed the mode to MT63-2KL and transmitted. The receiving Pi window shows it expanded to "see" that mode but in the text box, it said it was still in Olivia 8/500. I re-transmitted the message again with no changes and the receiving Pi correctly identified the mode and received the message with no errors.

Without going in the great detail about ALL of the settings, is there an area I need to look at in the settings to ensure that the RxID changes to the proper mode? 

Again, the link below to see the video. There is no audio. Hope it makes sense and will field questions best as I can.

https://youtu.be/j9uxG-rCO9U

73
John
KC4LZN

John KC4LZN
 

I actually tried at both sampling rates. 48000 and 44100. I've added another video, and it's a bit more visible than the other one. Note, the initial transmit, it does change to the proper width and even notates it in the lower left hand corner but the description isn't correct when it does happen. I've set the audio on both units to where they are strong enough but not overdriven. I may be over thinking this and haven't tried it on air yet and that may prove to be worthy but connected between two USB sound cards and two raspberry pi's model 3B, it doesn't seem to want to play. I'm trying to set this up for demonstration and don't want it to NOT work.

Do I need to put in an attenuator or actually use an interface to ensure the signal is good and clean?



https://youtu.be/46yTScTZ8Bg

73 John



On Wed, Feb 26, 2020 at 1:23 PM Bill Turner, wb4alm <mailsvc@...> wrote:
This may be a dumb suggestion, but verify that your usb sound cards are sampling at 48000.

/s/ Bill Turner, wb4alm


On 2/26/20 12:23 PM, John KC4LZN wrote:
I did check the signal input as well as what the output was and may lay the issue to the cheap USB soundcards I am using to interface the two Pi's. I will test again over the air when I can get them lined up with two transceivers with legitimate interfaces that have better sound cards 

When I did initially check, because I aired on the side of caution when I set the audio up on these. The transmit sound (speaker) was set well too low and adjusted where the sound was just below the two grey lines but the same results were received. 

I'll do some more testing and looking into digging into the audio side again and see if there was something I overlooked. 

Thanks for the tips on the waterfall settings and audio adjustments. I'm sure OTA testing will prove to be very good.

73
John




On Wed, Feb 26, 2020 at 11:15 AM Dave <w1hkj@...> wrote:

Make sure  you are not overdriving the Rx unit.  Try sending a TUNE signal and looking at the SIG view of (WF/FFT/SIG).  The peak-to-peak value of the signal should not exceed the uper and lower grey lines.

Test the RsID performance just using the fldigi programs without flmsg (one less failure point).  Make sure that TxID is and RxID is enabled on all of the modes you will be testing.  From the IDs/RsID configuration dialog, select "Receive modes" and "Transmit modes"; check every mode that you want to both TX and RX the RsID signal.  To test RsID simply select the Tx mode and press the T/R button on fldigi.

David

On 2/26/20 9:34 AM, John KC4LZN wrote:
I've included a link to the video, quality isn't that great and my first feeble attempt to record my desktop. It is split screen showing two Raspberry Pi's desktops.

I've been testing back and forth, have two Raspberry Pi's 3 Model B, with fldigi and flmsg, trying to learn the ins and outs with these two programs. Both Pi's fldigi programs are set in RxID and TxID on. 

I started out with both fldigi's in Olivia 8/500 mode. Opened flmsg, created a test message and sent it in Olivia 8/500 from the drop down menu in flmsg. Receiving Pi got it, deciphered it with no issues. I then dropped the box down in flmsg and changed the mode to MT63-2KL and transmitted. The receiving Pi window shows it expanded to "see" that mode but in the text box, it said it was still in Olivia 8/500. I re-transmitted the message again with no changes and the receiving Pi correctly identified the mode and received the message with no errors.

Without going in the great detail about ALL of the settings, is there an area I need to look at in the settings to ensure that the RxID changes to the proper mode? 

Again, the link below to see the video. There is no audio. Hope it makes sense and will field questions best as I can.

https://youtu.be/j9uxG-rCO9U

73
John
KC4LZN