Topics

Fldigi and flrigi won’t talk

777driver@...
 

  Hello, First the setup. Icom 7100 using the internal soundcard with usb to the laptop running windows 10.                                                          The setup worked fine for a day then when the laptop was restarted the problem started. Fldigi will not communicate to flrig. Flrig still has full radio control including the frequencies and transmit/recieve functions.
  I have uninstalled  fldigi using an uninstaller including cleaning up all the old files then did a new install of fldigi.
That did not solve the issue. Fldigi and flrig will still not talk to each other. I’ve been trying to solve this for some time and am quite frustrated. Any help would be much appreciated. Thanks, Jeff

KC9SGV
 

Use Winlink with VARA.
Works better than CPDLC.
I gave up on Fldigi years ago.

Bernie,
KC9SGV


On Dec 30, 2019, at 8:29 PM, 777driver@... wrote:

  Hello, First the setup. Icom 7100 using the internal soundcard with usb to the laptop running windows 10.                                                          The setup worked fine for a day then when the laptop was restarted the problem started. Fldigi will not communicate to flrig. Flrig still has full radio control including the frequencies and transmit/recieve functions.
  I have uninstalled  fldigi using an uninstaller including cleaning up all the old files then did a new install of fldigi.
That did not solve the issue. Fldigi and flrig will still not talk to each other. I’ve been trying to solve this for some time and am quite frustrated. Any help would be much appreciated. Thanks, Jeff

Kevin
 

Tried em all under linux; Hamlib, rigcat and FLRig.
FLRig wins hands down!
Best and most complete control of rig features and the only way to run multiple applications (FLDigi, JS8Call and ARDOP/gARIM) simultaneously and cooperatively sharing the same rig.

Not to insult but, in FLDigi / Configure/ Rig control / flrig tab, do you have "Enable flrig xcvr control with fldigi as client" checked ?
also if uncheck "Flrig PTT keys modem" if running multiple applications through FLRig.

73, Kevin K3TL

777driver@...
 

Greetings Kevin, Yes the enable flrig control is checked and the PTT is unchecked. 73s Jeff

K4IVE
 

Howdy Again,
 
The software communicates via a TCP/IP loopback network connection.  When you first install the fldigi suite of applications, there is a popup dialog window that asks you if this software has permission to access the internal and external networks on your computer.  As long as it is approved by checking the box and clicking OK, it should communicate.
 
Sometimes removing and re-installing the application completely will bring up this dialog box.  I'm not sure where to find those settings in Windows, but it should be somewhere in the network settings.  If you have Win10 Home edition, it is easier that the Pro or Enterprise versions.
 
There is a setting in the "Internet Settings" section of the Network Center that might be pertinent.  Also, the Windows Firewall is probably where all this stuff is hidden...
 
I wish i could help more, but I am away from home, stuck on my work computer and can't access those settings...
 
Make sure your loopback (127.0.0.1) is running and check those firewall settings.  The re-install usually works, too...
 
Good luck!
 
Kevin
K4IVE
 
p.s. I notice by your email address you are most likely a pilot.  I am IK04 on Pilots Of America, in case you go there...

 
 
Sent: Tuesday, December 31, 2019 at 12:56 PM
From: 777driver@...
To: nbems@groups.io
Subject: Re: [nbems] Fldigi and flrigi won’t talk
Greetings Kevin, Yes the enable flrig control is checked and the PTT is unchecked. 73s Jeff

777driver@...
 

  I just did a clean install with the firewall turned off to make sure it wasn’t preventing something from going in properly. No luck. While flrig will talk to the radio just fine, fldigi and flrig still wont communicate.