Topics

Receiving computer detects and changes operating modem to match incoming message?

Sarah
 

A couple of weeks ago I inadvertently transmitted a message during an NBEMS net with the operating modem set to one of the MFSK protocols instead of MT63-2KL.   Three or four people received that transmission and they all had the same experience:  their computers apparently recognized the incoming modem protocol and “automatically” changed from MT63 to MFSK.  We chalked it up to good experience but weren’t sure why it happened.  A ham with a lot more experience than me later explained that FLDIDI will automatically make this adjustment – i.e., it will change to match the operating modem of an incoming message when the and TxID buttons [top, right corner of the FLDIGI screen] are both clicked on. 

 

I tested this explanation and could not duplicate an “automatic” change by FLDIGI.  [Testing method explained below.]  Therefore I suspect there is some other configuration setting at work.  Any ideas or explanations would be appreciated!

 

Test set up:  Two laptop computers – one running Windows 7 Professional, one running Windows 7 Home Premium.  For these test I am not transmitting NBEMS over radio; just accoustic sound transfer between the two computers set across from each other on a table. Both computers running FLDIGI version 4.0.11 and FLMSG version 4.0.3.

Jim Jones
 

When you have both of the boxes (RxID and TxID) ticked marked, then when you
transmit, the TxID will send a code of what mode your using. The receiving station
would need to have there RxID ticked on and then if they are not on the same mode
it will automatically change to the mode your sending in.  The same would happen to
your station, if you have the RxID ticked and the sending station has his TxID ticked and
is sending in a different mode to you, your FLdigi will change to the correct mode and
you will copy the traffic.  I use them all the time.
73
Jim N9DIX



On 2/18/2018 20:44, Sarah wrote:

A couple of weeks ago I inadvertently transmitted a message during an NBEMS net with the operating modem set to one of the MFSK protocols instead of MT63-2KL.   Three or four people received that transmission and they all had the same experience:  their computers apparently recognized the incoming modem protocol and “automatically” changed from MT63 to MFSK.  We chalked it up to good experience but weren’t sure why it happened.  A ham with a lot more experience than me later explained that FLDIDI will automatically make this adjustment – i.e., it will change to match the operating modem of an incoming message when the and TxID buttons [top, right corner of the FLDIGI screen] are both clicked on. 


<snip>

Sarah
 

Hi Jim --  thanks for writing back.  Your explanation is exactly what I was told and it makes sense.  And I do understand why that feature exists.  I was just puzzled that I couldn't duplicate it in tests. 

I don't think the fact that I was just sending messages back and forth between two laptops on a table without doing actual radio transmissions would have had any effect.  After all the computer doesn't know whether the sound entering its microphone comes from a radio speaker or another computer speaker or me just whistling ....   I'll have to try the tests again. 

73, Sarah N6OPE


On 2/18/2018 7:04 PM, Jim Jones wrote:
When you have both of the boxes (RxID and TxID) ticked marked, then when you
transmit, the TxID will send a code of what mode your using. The receiving station
would need to have there RxID ticked on and then if they are not on the same mode
it will automatically change to the mode your sending in.  The same would happen to
your station, if you have the RxID ticked and the sending station has his TxID ticked and
is sending in a different mode to you, your FLdigi will change to the correct mode and
you will copy the traffic.  I use them all the time.
73
Jim N9DIX



On 2/18/2018 20:44, Sarah wrote:

A couple of weeks ago I inadvertently transmitted a message during an NBEMS net with the operating modem set to one of the MFSK protocols instead of MT63-2KL.   Three or four people received that transmission and they all had the same experience:  their computers apparently recognized the incoming modem protocol and “automatically” changed from MT63 to MFSK.  We chalked it up to good experience but weren’t sure why it happened.  A ham with a lot more experience than me later explained that FLDIDI will automatically make this adjustment – i.e., it will change to match the operating modem of an incoming message when the and TxID buttons [top, right corner of the FLDIGI screen] are both clicked on. 


<snip>

Greg Depew
 

I believe you also have to have Configure>ID>receive modes and transmit modes all checked.   Even then our group still has trouble with modes always shifting like they are supposed to. 



Greg KB3KBR Sent from my Verizon, Samsung Galaxy smartphone


-------- Original message --------
From: Sarah <n6ope@...>
Date: 2/18/18 22:23 (GMT-05:00)
To: nbems@groups.io
Subject: Re: [nbems] Receiving computer detects and changes operating modem to match incoming message?

Hi Jim --  thanks for writing back.  Your explanation is exactly what I was told and it makes sense.  And I do understand why that feature exists.  I was just puzzled that I couldn't duplicate it in tests. 

I don't think the fact that I was just sending messages back and forth between two laptops on a table without doing actual radio transmissions would have had any effect.  After all the computer doesn't know whether the sound entering its microphone comes from a radio speaker or another computer speaker or me just whistling ....   I'll have to try the tests again. 

73, Sarah N6OPE


On 2/18/2018 7:04 PM, Jim Jones wrote:
When you have both of the boxes (RxID and TxID) ticked marked, then when you
transmit, the TxID will send a code of what mode your using. The receiving station
would need to have there RxID ticked on and then if they are not on the same mode
it will automatically change to the mode your sending in.  The same would happen to
your station, if you have the RxID ticked and the sending station has his TxID ticked and
is sending in a different mode to you, your FLdigi will change to the correct mode and
you will copy the traffic.  I use them all the time.
73
Jim N9DIX



On 2/18/2018 20:44, Sarah wrote:

A couple of weeks ago I inadvertently transmitted a message during an NBEMS net with the operating modem set to one of the MFSK protocols instead of MT63-2KL.   Three or four people received that transmission and they all had the same experience:  their computers apparently recognized the incoming modem protocol and “automatically” changed from MT63 to MFSK.  We chalked it up to good experience but weren’t sure why it happened.  A ham with a lot more experience than me later explained that FLDIDI will automatically make this adjustment – i.e., it will change to match the operating modem of an incoming message when the and TxID buttons [top, right corner of the FLDIGI screen] are both clicked on. 


<snip>

Charles Hargrove
 

A very simple rule is to turn on the receive and transmit ID for all
modes except SSB, CW, null and WWV. Limit all of your connections to
1500 Hz by permanently setting it and leave RxID/TxID on at all times.

On 2/18/2018 10:48 PM, Greg Depew wrote:
I believe you also have to have Configure>ID>receive modes and transmit modes all checked.   Even then our group still has trouble with modes always shifting like they are supposed to.
--
Charles J. Hargrove - N2NOV
NYC-ARECS/RACES Citywide Radio Officer/Skywarn Coord.

NYC-ARECS/RACES Nets 449.025/123.0 PL
ARnewsline Broadcast Mon. @ 8:00PM
NYC-ARECS Weekly Net Mon. @ 8:30PM
http://www.nyc-arecs.org

NY-NBEMS Net Saturdays @ 10AM & USeast-NBEMS Net Wednesdays @ 7PM
on 7.036 Mhz USB (alt 3.536)/1500 hz waterfall spot; MFSK-16 or 32

"Information is the oxygen of the modern age. It seeps through the walls topped
by barbed wire, it wafts across the electrified borders." - Ronald Reagan

"The more corrupt the state, the more it legislates." - Tacitus

"Molann an obair an fear" - Irish Saying
(The work praises the man.)

"No matter how big and powerful government gets, and the many services it
provides, it can never take the place of volunteers." - Ronald Reagan

Larry Levesque
 

Another thing that get's overlooked is if your transmitted signal moves when you switch modes to outside of where thew receiving station would normally expect to see it with the RsID on.

In these cases, setting the "Searches passband" check box would look in the entire audio passband for the signal.
Also if you have the "Disables detector" check box set, it will disable the RsID after each successful decode and you will need to manually enable it again.

On Sun, Feb 18, 2018 at 10:53:18PM -0500, Charles Hargrove wrote:
A very simple rule is to turn on the receive and transmit ID for all
modes except SSB, CW, null and WWV. Limit all of your connections to
1500 Hz by permanently setting it and leave RxID/TxID on at all times.

On 2/18/2018 10:48 PM, Greg Depew wrote:
I believe you also have to have Configure>ID>receive modes and transmit
modes all checked.   Even then our group still has trouble with modes
always shifting like they are supposed to.
--
Charles J. Hargrove - N2NOV
NYC-ARECS/RACES Citywide Radio Officer/Skywarn Coord.

NYC-ARECS/RACES Nets 449.025/123.0 PL
ARnewsline Broadcast Mon. @ 8:00PM
NYC-ARECS Weekly Net Mon. @ 8:30PM
http://www.nyc-arecs.org

NY-NBEMS Net Saturdays @ 10AM & USeast-NBEMS Net Wednesdays @ 7PM
on 7.036 Mhz USB (alt 3.536)/1500 hz waterfall spot; MFSK-16 or 32

"Information is the oxygen of the modern age. It seeps through the walls
topped
by barbed wire, it wafts across the electrified borders." - Ronald Reagan

"The more corrupt the state, the more it legislates." - Tacitus

"Molann an obair an fear" - Irish Saying
(The work praises the man.)

"No matter how big and powerful government gets, and the many services it
provides, it can never take the place of volunteers." - Ronald Reagan


--
Larry Levesque
KA1VGM

Sarah
 

Larry - I believe what you're saying (forgive me, I'm still relatively new to NBEMS) is that the  sweet spot and the high and low brackets on either side of it at 1500 for MT63-2KL   adjust when the modem changes -- is that correct?  (The High / Low brackets being the red, vertical lines on the waterfall.)

Assuming so  - Yes - we experienced that in the situation I mentioned at the start of this topic.  Both for the folks who received and me as the person who sent a transmission with the wrong modem setting.  In fact when I corrected the modem to the right setting to retransmit the message I had to manually go in and reset the sweet spot back to 1500. 

Our group decided the moral of the story was this:  if an NBEMS message is accidentally transmitted on the wrong modem then everyone needs to double check their modem and sweet spot settings and set them back to MT63-2KL and 1500 before new traffic proceeds.  

73, Sarah N6OPE


On 2/19/2018 3:43 AM, Larry Levesque wrote:
Another thing that get's overlooked is if your transmitted signal moves when you switch modes to outside of where thew receiving station would normally expect to see it with the RsID on.

In these cases, setting the "Searches passband" check box would look in the entire audio passband for the signal.
Also if you have the "Disables detector" check box set, it will disable the RsID after each successful decode and you will need to manually enable it again.



On Sun, Feb 18, 2018 at 10:53:18PM -0500, Charles Hargrove wrote:
A very simple rule is to turn on the receive and transmit ID for all
modes except SSB, CW, null and WWV.  Limit all of your connections to
1500 Hz by permanently setting it and leave RxID/TxID on at all times.

On 2/18/2018 10:48 PM, Greg Depew wrote:
I believe you also have to have Configure>ID>receive modes and transmit
modes all checked.   Even then our group still has trouble with modes
always shifting like they are supposed to.
-- 
Charles J. Hargrove - N2NOV
NYC-ARECS/RACES Citywide Radio Officer/Skywarn Coord.

NYC-ARECS/RACES Nets 449.025/123.0 PL
ARnewsline Broadcast Mon. @ 8:00PM
NYC-ARECS Weekly Net Mon. @ 8:30PM
http://www.nyc-arecs.org

NY-NBEMS Net Saturdays @ 10AM & USeast-NBEMS Net Wednesdays @ 7PM
on 7.036 Mhz USB (alt 3.536)/1500 hz waterfall spot; MFSK-16 or 32

"Information is the oxygen of the modern age. It seeps through the walls
topped
by barbed wire, it wafts across the electrified borders." - Ronald Reagan

"The more corrupt the state, the more it legislates." - Tacitus

"Molann an obair an fear" - Irish Saying
(The work praises the man.)

"No matter how big and powerful government gets, and the many services it
provides, it can never take the place of volunteers." - Ronald Reagan




    

Larry Levesque
 

That is exactly what I am was trying to say.
Of course setting the "Searches entire passband" has it's own issues.
If another station appears well away from your conversation, and sends an TxID, your receiver could lock onto that signal and you could miss the message you were waiting for.

On Mon, Feb 19, 2018 at 07:04:49PM -0800, Sarah wrote:
Larry - I believe what you're saying (forgive me, I'm still relatively new
to NBEMS) is that the  sweet spot and the high and low brackets on either
side of it at 1500 for MT63-2KL   adjust when the modem changes -- is that
correct? (The High / Low brackets being the red, vertical lines on the
waterfall.)

Assuming so  - Yes - we experienced that in the situation I mentioned at the
start of this topic.  Both for the folks who received and me as the person
who sent a transmission with the wrong modem setting.  In fact when I
corrected the modem to the right setting to retransmit the message I had to
manually go in and reset the sweet spot back to 1500.

Our group decided the moral of the story was this:  if an NBEMS message is
accidentally transmitted on the wrong modem then everyone needs to double
check their modem and sweet spot settings and set them back to MT63-2KL and
1500 before new traffic proceeds.

73, Sarah N6OPE


On 2/19/2018 3:43 AM, Larry Levesque wrote:
Another thing that get's overlooked is if your transmitted signal moves when you switch modes to outside of where thew receiving station would normally expect to see it with the RsID on.

In these cases, setting the "Searches passband" check box would look in the entire audio passband for the signal.
Also if you have the "Disables detector" check box set, it will disable the RsID after each successful decode and you will need to manually enable it again.



On Sun, Feb 18, 2018 at 10:53:18PM -0500, Charles Hargrove wrote:
A very simple rule is to turn on the receive and transmit ID for all
modes except SSB, CW, null and WWV. Limit all of your connections to
1500 Hz by permanently setting it and leave RxID/TxID on at all times.

On 2/18/2018 10:48 PM, Greg Depew wrote:
I believe you also have to have Configure>ID>receive modes and transmit
modes all checked.   Even then our group still has trouble with modes
always shifting like they are supposed to.
--
Charles J. Hargrove - N2NOV
NYC-ARECS/RACES Citywide Radio Officer/Skywarn Coord.

NYC-ARECS/RACES Nets 449.025/123.0 PL
ARnewsline Broadcast Mon. @ 8:00PM
NYC-ARECS Weekly Net Mon. @ 8:30PM
http://www.nyc-arecs.org

NY-NBEMS Net Saturdays @ 10AM & USeast-NBEMS Net Wednesdays @ 7PM
on 7.036 Mhz USB (alt 3.536)/1500 hz waterfall spot; MFSK-16 or 32

"Information is the oxygen of the modern age. It seeps through the walls
topped
by barbed wire, it wafts across the electrified borders." - Ronald Reagan

"The more corrupt the state, the more it legislates." - Tacitus

"Molann an obair an fear" - Irish Saying
(The work praises the man.)

"No matter how big and powerful government gets, and the many services it
provides, it can never take the place of volunteers." - Ronald Reagan


--
Larry Levesque
KA1VGM