Date   
Re: Problem with Mac OSX, FLDigi, and flmsg

Gil Gibbs
 

Dave,  I have a lot to learn about Linux, Ubuntu, so I'll heed your advice.

Thanks, 73

Gil

On 8/4/19 6:58 PM, david flad wrote:
Gil,

Dave makes source available, and it’s been compiled under various Linux distros, as well as for a Rasberry Pi.

Just need to pay attention to the dependencies.

Regards,

David Flad. /. KB3YCK
Emergency Coordinator 
Chester County ARES/RACES

On Aug 4, 2019, at 18:20, Gil Gibbs <WA5YKK@...> wrote:

Dave,

I don't want to be a bother, but has anyone developed a Linux Ubuntu version of this control program? I'm cured of Winders, especially 10, the "upgrades" wiped out my Internet browser, email Mozilla programs.

73

Gil WA5YKK

On 8/2/19 3:55 PM, Dave wrote:
I was able to replicate all of the reported problems, both on 10.13.6 and 10.14.5.  I will be posting a an alpha update to both flmsg and fldigi shortly.

David

On 8/2/19 10:41 AM, Rick Shuster wrote:

Dave,

I Upgraded the the following:

flmsg 4.0.13

fldigi 4.1.06

flame 2.2.05

Testing afterwards I was not able to "AutoSend" from flmsg.  Also, I experience an "Unexpected Quit" system message for flmsg once.

When I downgraded only flmsg from flmsg 4.0.13 to version 4.0.8 "AutoSend" worked as expected.

As before my system is :

MacBook Air (Mid 2013)

1.3 GHz Intel Core i5

Mac OS Mojave 10.14.5

Thanks for your help and support in this matter.

73 - Rick, WD8SAB


Re: Problem with Mac OSX, FLDigi, and flmsg

KB3YCK
 

Gil,

Dave makes source available, and it’s been compiled under various Linux distros, as well as for a Rasberry Pi.

Just need to pay attention to the dependencies.

Regards,

David Flad. /. KB3YCK
Emergency Coordinator 
Chester County ARES/RACES

On Aug 4, 2019, at 18:20, Gil Gibbs <WA5YKK@...> wrote:

Dave,

I don't want to be a bother, but has anyone developed a Linux Ubuntu version of this control program? I'm cured of Winders, especially 10, the "upgrades" wiped out my Internet browser, email Mozilla programs.

73

Gil WA5YKK

On 8/2/19 3:55 PM, Dave wrote:
I was able to replicate all of the reported problems, both on 10.13.6 and 10.14.5.  I will be posting a an alpha update to both flmsg and fldigi shortly.

David

On 8/2/19 10:41 AM, Rick Shuster wrote:

Dave,

I Upgraded the the following:

flmsg 4.0.13

fldigi 4.1.06

flame 2.2.05

Testing afterwards I was not able to "AutoSend" from flmsg.  Also, I experience an "Unexpected Quit" system message for flmsg once.

When I downgraded only flmsg from flmsg 4.0.13 to version 4.0.8 "AutoSend" worked as expected.

As before my system is :

MacBook Air (Mid 2013)

1.3 GHz Intel Core i5

Mac OS Mojave 10.14.5

Thanks for your help and support in this matter.

73 - Rick, WD8SAB


Re: Problem with Mac OSX, FLDigi, and flmsg

Gil Gibbs
 

Dave,

I don't want to be a bother, but has anyone developed a Linux Ubuntu version of this control program? I'm cured of Winders, especially 10, the "upgrades" wiped out my Internet browser, email Mozilla programs.

73

Gil WA5YKK

On 8/2/19 3:55 PM, Dave wrote:
I was able to replicate all of the reported problems, both on 10.13.6 and 10.14.5.  I will be posting a an alpha update to both flmsg and fldigi shortly.

David

On 8/2/19 10:41 AM, Rick Shuster wrote:

Dave,

I Upgraded the the following:

flmsg 4.0.13

fldigi 4.1.06

flame 2.2.05

Testing afterwards I was not able to "AutoSend" from flmsg.  Also, I experience an "Unexpected Quit" system message for flmsg once.

When I downgraded only flmsg from flmsg 4.0.13 to version 4.0.8 "AutoSend" worked as expected.

As before my system is :

MacBook Air (Mid 2013)

1.3 GHz Intel Core i5

Mac OS Mojave 10.14.5

Thanks for your help and support in this matter.

73 - Rick, WD8SAB


Kenwood TS2000 Beta vs Stable

Dennis
 

I download the latest version and in config it states Kenwood TS2000 (stable) and it won’t key up.  However the version I was using had in the config Kenwood TS2000 (Beta) and it worked fine.  Any ideas why stable doesn’t work and beta does?  Maybe my overall configuration is not correct.  Thanks in advance for any ideas.

Dennis Wyman
KA6GDT

flrig 1.3.46.02 alpha posted

Dave
 

At http://www.w1hkj.com/alpha/flrig/
  IC7600/IC7851
    * Correct mode reads
      - contributed by Johan Maes, ON4QZ

  FTdx101D
    * update iaw recent changes to xcvr firmware

73, David, W1HKJ

fldigi / flmsg alpha postings

Dave
 

On http://www.w1hkj.com/alpha/
fldigi:
    FL_LOCK
      * Remove deprecated code
    wf mods

flmsg:
    xmlrpc thread isolation
      * provide thread isolation on x86_64 OS-X

Please test as a matched pair.

73, David, W1HKJ

Re: Problem with Mac OSX, FLDigi, and flmsg

Brad Biedermann
 

Bruno,

What version of the mac OS do you have?

 

From: nbems@groups.io <nbems@groups.io> On Behalf Of Dave
Sent: Friday, August 2, 2019 2:56 PM
To: nbems@groups.io
Subject: Re: [nbems] Problem with Mac OSX, FLDigi, and flmsg

 

I was able to replicate all of the reported problems, both on 10.13.6 and 10.14.5.  I will be posting a an alpha update to both flmsg and fldigi shortly.

David

On 8/2/19 10:41 AM, Rick Shuster wrote:

Dave,

I Upgraded the the following:

flmsg 4.0.13

fldigi 4.1.06

flame 2.2.05

Testing afterwards I was not able to "AutoSend" from flmsg.  Also, I experience an "Unexpected Quit" system message for flmsg once.

When I downgraded only flmsg from flmsg 4.0.13 to version 4.0.8 "AutoSend" worked as expected.

As before my system is :

MacBook Air (Mid 2013)

1.3 GHz Intel Core i5

Mac OS Mojave 10.14.5

Thanks for your help and support in this matter.

73 - Rick, WD8SAB

 

Re: Problem with Mac OSX, FLDigi, and flmsg

Dave
 

I was able to replicate all of the reported problems, both on 10.13.6 and 10.14.5.  I will be posting a an alpha update to both flmsg and fldigi shortly.

David

On 8/2/19 10:41 AM, Rick Shuster wrote:

Dave,

I Upgraded the the following:

flmsg 4.0.13

fldigi 4.1.06

flame 2.2.05

Testing afterwards I was not able to "AutoSend" from flmsg.  Also, I experience an "Unexpected Quit" system message for flmsg once.

When I downgraded only flmsg from flmsg 4.0.13 to version 4.0.8 "AutoSend" worked as expected.

As before my system is :

MacBook Air (Mid 2013)

1.3 GHz Intel Core i5

Mac OS Mojave 10.14.5

Thanks for your help and support in this matter.

73 - Rick, WD8SAB


Re: AndFlmsg version 1.3.5 is a GPS Battery HOG

John (vk2eta)
 

Also, I would install the new version (1.3.7) that was released to fix the notification icon issue. 

73, John

Re: Problem with Mac OSX, FLDigi, and flmsg

Dave
 

Thanks Rick,  I am testing on 10.13.6 this morning.

Dave

On 8/2/19 10:41 AM, Rick Shuster wrote:

Dave,

I Upgraded the the following:

flmsg 4.0.13

fldigi 4.1.06

flame 2.2.05

Testing afterwards I was not able to "AutoSend" from flmsg.  Also, I experience an "Unexpected Quit" system message for flmsg once.

When I downgraded only flmsg from flmsg 4.0.13 to version 4.0.8 "AutoSend" worked as expected.

As before my system is :

MacBook Air (Mid 2013)

1.3 GHz Intel Core i5

Mac OS Mojave 10.14.5

Thanks for your help and support in this matter.

73 - Rick, WD8SAB


Re: Problem with Mac OSX, FLDigi, and flmsg

Rick Shuster
 

Dave,

I Upgraded the the following:

flmsg 4.0.13

fldigi 4.1.06

flame 2.2.05

Testing afterwards I was not able to "AutoSend" from flmsg.  Also, I experience an "Unexpected Quit" system message for flmsg once.

When I downgraded only flmsg from flmsg 4.0.13 to version 4.0.8 "AutoSend" worked as expected.

As before my system is :

MacBook Air (Mid 2013)

1.3 GHz Intel Core i5

Mac OS Mojave 10.14.5

Thanks for your help and support in this matter.

73 - Rick, WD8SAB

flmsg 4.0.13 posted

Dave
 

To http://www.w1hkj.com/files/flmsg/

and to Source Forge.

Version 4.0.13 * Maintenance release

  flmsg online
    * change keep alive interval processing
      - fldigi will timeout after 500 msec
      - send flmsg_online xmlrpc method every 400 ms

Version 4.0.12 * Maintenance release (not posted for public download)

  Revert "fldigi online"
    * This reverts commit 1d5cdd2e84295068f1c8271e71a0ce0c6ab8885c.
    * Caused intermittent AutoSend failure on Windows platforms

73, David, W1HKJ

Re: AndFlmsg version 1.3.5 is a GPS Battery HOG

John (vk2eta)
 

Hi Dave,

Glad it's working ok now.

Thanks for the detailed reply.

I had to handle the app navigation differently to other apps due to the way Android handles apps when shifted to the background. The modem has to be kept running in case we navigate away from it temporarily.

Google is waging a fight against high battery usage apps which is fine in itself but has to be managed for specific cases like our software modems.

Based on your experience I will make sure the default at install time if off for the GPS time option.

73, John (VK2ETA)

Re: AndFlmsg version 1.3.5 posted

Kevin
 

John,

Confirmed problem on my end.
Had to delete NBEMS.files directory, then from manage apps, clear cache, and clear data, then uninstall.
Reinstalled V1.3.7 and all working FB.

Android 6

Thanks

73, Kevin

Re: AndFlmsg version 1.3.5 is a GPS Battery HOG

David Aitcheson KB3EFS <kb3efs.dave@...>
 

John,

Reply items interlaced below...

On 8/1/19 1:14 AM, John (vk2eta) wrote:
David,

Further information on the subject as this is not the behavior on my devices.

That is good, I am using a "Samsung Galaxy J3 Orbit" that was running Andriod version 8 at the time including the checks you requested. Once I figure out all the changes that Android 9 has introduced I'll check the app out again.

I also double checked the code and the GPS updates are switched off when the app is exited.

Are you sure you exited the app by using the menu (three dots at the top), then exit as this is the only way the app is terminated?

Well... I am now but I had missed that at first as ALL other apps that I have just close down totally using the "Close All" function button.

Merely going back to the main screen by pressing the home button does NOT stop the app as it is designed to work in the background decoding digital data (and using the GPS if selected in the settings).

I have no problem with the app running in foreground or background, it was the leaving the GPS up and the draining of the battery by the GPS that caught me off guard.

Letting the app run, especially a CPU demanding mode, will increase consumption significantly as described in the manual.

You are notified that the modem is running by the presence an icon in the notifications at the top of the device. The icon looks like a grey or yellow antenna icon. The icon is removed if either the modem is stopped within the app OR the app is fully exited.

I never saw that "antenna" just the GPS indicator, and the phone management app "screaming" at me that an app was killing my battery about a minute before the phone died; which was about an hour after I first looked at the app right after I installed it.

As an aside, the power consumption of the modem decoders is normally far superior to the GPS consumption as GPS reads, when enabled, are scheduled for a few seconds every minute, so they should have minimal battery impact.

That is to be expected and I would most likely be running with an external power source feeding the phone for a "belt & suspenders" approach.

Please let us know what you find.

73, John
_._,_._,_


73
Dave
KB3EFS

Re: Autosend in FLMSG Problem With 4.0.11

David Piersall
 

I just installed the new version and Autosend is now working again with the original ARQ menu settings.

Thanks,

Dave, N6ORB

Re: AndFlmsg version 1.3.5 is a GPS Battery HOG

David Aitcheson KB3EFS <kb3efs.dave@...>
 

John,

App re-installed. Set and unset "Use GPS Time" then exiting app both with the "close all button" and from the "3 dot" menu. GPS indicator (and battery hogging) go off with menu based exit.

More in response to next email...

Dave


On 7/31/19 11:41 PM, John (vk2eta) wrote:
David,

Have you tried going to the settings/GPS TIME and deselect "Use GPS Time"?

Just to make sure, follow the above by an app exit and relaunch for a complete reset of the GPS use.

73, John

Re: Autosend in FLMSG Problem With 4.0.11

Dave
 

Please test with current version of fldigi:

73, David, W1HKJ


Re: AndFlmsg version 1.3.5 is a GPS Battery HOG

John (vk2eta)
 

David,

Further information on the subject as this is not the behavior on my devices.

I also double checked the code and the GPS updates are switched off when the app is exited.

Are you sure you exited the app by using the menu (three dots at the top), then exit as this is the only way the app is terminated? Merely going back to the main screen by pressing the home button does NOT stop the app as it is designed to work in the background decoding digital data (and using the GPS if selected in the settings). Letting the app run, especially a CPU demanding mode, will increase consumption significantly as described in the manual.

You are notified that the modem is running by the presence an icon in the notifications at the top of the device. The icon looks like a grey or yellow antenna icon. The icon is removed if either the modem is stopped within the app OR the app is fully exited.

As an aside, the power consumption of the modem decoders is normally far superior to the GPS consumption as GPS reads, when enabled, are scheduled for a few seconds every minute, so they should have minimal battery impact.

Please let us know what you find.

73, John

Re: AndFlmsg version 1.3.5 is a GPS Battery HOG

John (vk2eta)
 

David,

Have you tried going to the settings/GPS TIME and deselect "Use GPS Time"?

Just to make sure, follow the above by an app exit and relaunch for a complete reset of the GPS use.

73, John