Topics

SDRPlay and Multipsk

Joe
 

Appologies if this has been discussed previous but when I try to launch SDRplay from within MultiPSK I receive the message "Failure of the TCP/IP connection, the SDRplay receiver is probably not connected.Disconnecting error. Socket Error n°10053 : Software caused the connection to abort. A connection that has been made was aborted, usually due to connection or protocol error.TCP" Does anyone have any recommendations on how to get the SDR to work?

Fred Albertson
 

HI Joe,

Close MultiPSK.

Make sure that SDRUno, or any other program using the RSP,
is closed.

Go to the SDRPlay/SDRUno subdirectory, and run the program "rsp_tcp.exe".

Reopen MultiPSK, and click the RSP button.  It should work.

Hope this helps,

Fred

Patrick Lindecker
 

Hello Joe,

 

With RSP1 it works always well (as far as I know). If your SDRplay is a RSP2 (is it?) it seems that some problem occurs in the connection from time to time. For a RSP2, the solution is the one suggested by Fred.

 

73
Patrick

 

De : multipsk@groups.io [mailto:multipsk@groups.io] De la part de Joe
Envoyé : samedi 7 décembre 2019 22:13
À : multips
k@groups.io
Objet : [multipsk] SDRPlay and Multipsk

 

Appologies if this has been discussed previous but when I try to launch SDRplay from within MultiPSK I receive the message "Failure of the TCP/IP connection, the SDRplay receiver is probably not connected.Disconnecting error. Socket Error n°10053 : Software caused the connection to abort. A connection that has been made was aborted, usually due to connection or protocol error.TCP" Does anyone have any recommendations on how to get the SDR to work?

Joe
 

Thanks to everyone for the helpful information. I tried to run "rsp_tcp.exe" from within the SDRuno folder, however the file is not there. Do I need to download from somewhere?

Paul Gulliver
 

Joe,

I think you'll find it here, you may have to scroll down a bit - I don't have it in my SDRUno folder either.


Paul


On 10/12/2019 at 12:50, Joe <jga747@...> wrote:
Thanks to everyone for the helpful information. I tried to run "rsp_tcp.exe" from within the SDRuno folder, however the file is not there. Do I need to download from somewhere?

Joe
 

Thanks Paul! Appreciate it! Thanks to everyone for the helpful information!

Patrick Lindecker
 

Hello Joe,

 

rsp_tcp.exe is part of the Multipsk package (at least the last one). So it is located in your Multipsk folder.

 

73

Patrick

 

De : multipsk@groups.io [mailto:multipsk@groups.io] De la part de Joe
Envoyé : mardi 10 décembre 2019 13:51
À : multipsk@groups.io
Objet : Re: [multipsk] SDRPlay and Multipsk

 

Thanks to everyone for the helpful information. I tried to run "rsp_tcp.exe" from within the SDRuno folder, however the file is not there. Do I need to download from somewhere?

Joe
 

Thanks to everyone for the help, I've tried the steps mentioned but still getting the TCP error. Just wanted to make sure I wasn't missing something obvious? I upgraded to RSPdx, not sure if that could be the issue?

Patrick Lindecker
 

Hello Joe,

 

Did you apply the Fred instructions? Did you work with the last version (V.4.41) of Multipsk, installed in a directory as C:\Multipsk (i.e not under Program files)?

 

If so,  a direct interface with Multipsk is not possible and you must pass through a SdR program and a VAC (Virtual Audio cable).

 

73

Patrick

 

 

De : multipsk@groups.io [mailto:multipsk@groups.io] De la part de Joe
Envoyé : lundi 30 décembre 2019 14:46
À : multipsk@groups.io
Objet : Re: [multipsk] SDRPlay and Multipsk

 

Thanks to everyone for the help, I've tried the steps mentioned but still getting the TCP error. Just wanted to make sure I wasn't missing something obvious? I upgraded to RSPdx, not sure if that could be the issue?

Christian, OE60200755
 

Hello Joe!

Multipsk and TCP / IP interface with SDRPlay RSP2.
I start the rsp_tcp in extended mode (-E). And I can add at startup which antenna port
(-P0 = PORT A, -P1 = PORT B, -P2 = HIz) should be used for Multipsk.

I start the program in the following order:

1. start rsp_tcp.exe -E -P1 (from the Multipsk folder)
2. start Multipsk RX Screen
3. press SDRplay + Direct via the sound card + Speaker
4. press RX/TX Screen
Multipsk with SDR I / O + Antennport B running now with the SDRPlay RSP2
This configuration runs grealty and stable with Multipsk 4.41 for me. 

73 de Christian

Fred Albertson
 

Hi Patrick and Christian,

That approach might help in getting MultiPSK to send
commands to the RSP.  I have never used the -E parameter
when I start rsp_tcp.exe manually with my RSP2Pro or Duo.

Patrick, when we push the SDRplay button from the configuration
screen, do you use the -E?  What actually happens?

Happy New Year,

Fred

Patrick Lindecker
 

Hello Fred and Christian,

 

>screen, do you use the -E?

 

Not at all. I consider and use the SDRplay as a basic TNT dongle. Yes, there are extended functions with SDRplay but it would need to change much code to match them…

 

Happy new year

 

73

Patrick

 

 

 

De : multipsk@groups.io [mailto:multipsk@groups.io] De la part de Fred Albertson
Envoyé : mardi 31 décembre 2019 18:13
À : multipsk@groups.io
Objet : Re: [multipsk] SDRPlay and Multipsk

 

Hi Patrick and Christian,

That approach might help in getting MultiPSK to send
commands to the RSP.  I have never used the -E parameter
when I start rsp_tcp.exe manually with my RSP2Pro or Duo.

Patrick, when we push the SDRplay button from the configuration
screen, do you use the -E?  What actually happens?

Happy New Year,

Fred

Christian, OE60200755
 

Hello Patrick and Fred!

When i do not use -E, it finds no device arguments and
follwing message is coming:

rsp_tcp version 1.0

libmirsdrapi-rsp version 2.13 found
detected RSP model 'RSP 2' (hw ver 2)
listening...
Use the device argument 'rtl_tcp=127.0.0.1:1234' in OsmoSDR (gr-osmosdr) source
to receive samples in GRC and control rtl_tcp parameters (frequency, gain, ...).

So i use -E and all is working fine.

I wish all a happy new year, and enjoy the radio waves.

73 de Christian.

Patrick Lindecker
 

Hello Christian,

>So i use -E and all is working fine.
Yes you are right. I have the same message here with the RSP1.

Moreover, I tried your procedure with the RSP1 and it works also without problem.

I will add this way to do with RSP2 and beyond in the manual (TKS)

 

For the ones not having written the batch file, I add it in the attached file with a .TXT extension (because refused for a “.BAT” one). So change the extension  from “TXT” to “BAT”.

 

73
Patrick

 

 

De : multipsk@groups.io [mailto:multipsk@groups.io] De la part de Christian, OE60200755
Envoyé : mercredi 1 janvier 2020 12:15
À : multipsk@groups.io
Objet : Re: [multipsk] SDRPlay and Multipsk

 

Hello Patrick and Fred!

When i do not use -E, it finds no device arguments and
follwing message is coming:

rsp_tcp version 1.0

libmirsdrapi-rsp version 2.13 found
detected RSP model 'RSP 2' (hw ver 2)
listening...
Use the device argument 'rtl_tcp=127.0.0.1:1234' in OsmoSDR (gr-osmosdr) source
to receive samples in GRC and control rtl_tcp parameters (frequency, gain, ...).

So i use -E and all is working fine.

I wish all a happy new year, and enjoy the radio waves.

73 de Christian.

Fred Albertson
 

Hi Patrick and Christian,

This also works for the RSP2duo which has ports two tuners with ports as follows:

P0 is the tuner 1 50 Ohm port (the default)

P1 is the tuner 2 50 Ohm port

P2 is the tuner 1 HiZ port

Hope this helps,

Fred

Patrick Lindecker
 

TKS Fred for the information.

 

I added this paragraph on the manual from the Christian text:

 

About the RSP2 model and beyond:

If the direct interface with Multipsk does not work (with an error message), try this procedure (thanks to Christian and Fred):

1. start "rsp_tcp.exe -E" (from the Multipsk folder), with, for example, the "SDRPlay_RSP2.BAT" batch file in the Multipsk package.
Note that it can be added the parameter "-P0" = PORT A (default) or "-P1" = PORT B or "-P2" = HIz

2. start Multipsk,

3. press on the "SDRplay" button

4. press on the "RX/TX screen" button

 

I hope there is no ambiguity.

 

73

Patrick

 

De : multipsk@groups.io [mailto:multipsk@groups.io] De la part de Fred Albertson
Envoyé : mercredi 1 janvier 2020 23:19
À : multipsk@groups.io
Objet : Re: [multipsk] SDRPlay and Multipsk

 

Hi Patrick and Christian,

This also works for the RSP2duo which has ports two tuners with ports as follows:

P0 is the tuner 1 50 Ohm port (the default)

P1 is the tuner 2 50 Ohm port

P2 is the tuner 1 HiZ port

Hope this helps,

Fred

Christian, OE60200755
 
Edited

Hello Patrick and Fred!

Fred, yes it helps, thank you for the information about the RSP2duo.
Patrick thank you for the manual addition. I still have
a suggestion: Please, after 3. press on the "SDRplay" button,
could you add a further numbering for the "+Speaker"
to listen to the demodulated sound.

With the batch file it works greatly.

73 de Christian

Patrick Lindecker
 

Hello Christian,

 

OK for the addition. Here it is:

 

About the RSP2 model and beyond:

If the direct interface with Multipsk does not work (with an error message), try this procedure (thanks to Christian and Fred):

1. start "rsp_tcp.exe -E" (from the Multipsk folder), with, for example, the "SDRPlay_RSP2.BAT" batch file in the Multipsk package.
Note that it can be added the parameter "-P0" = PORT A (default) or "-P1" = PORT B or "-P2" = HIz

2. start Multipsk,

3. press on the "SDRplay" button and, possibly, on "+Speaker" to listen to the demodulated sound

4. press on the "RX/TX screen" button

73

Patrick

 

De : multipsk@groups.io [mailto:multipsk@groups.io] De la part de Christian, OE60200755
Envoyé : jeudi 2 janvier 2020 15:56
À : multipsk@groups.io
Objet : Re: [multipsk] SDRPlay and Multipsk

 

[Edited Message Follows]

Hello Patrick and Fred!

Fred, yes it helps, thank you for the information about the RSP2duo.
Patrick thank you for the manual addition. I still have
a suggestion: Please, after 3. press on the "SDRplay" button,
could you add a further numbering for the "+Speaker"
to listen to the demodulated sound.

With the batch file it works greatly.

73 de Christian

Fred Albertson
 

Hi Patrick and Christian,

I just checked the procedure with all three ports on my
RSPduo and it works as stated.

This is the first time I have been able to monitor ADSB with
MultiPSK directly controlling the RSP.  It makes a nice setup.

Thank you both for the efforts.

Fred

MadMike
 

Hi Fred,

Unfortunately, I have had no luck at all trying to run my RSPdx in direct mode.

I entered the CLI text as follows (with responses):-

E:\Radio Utilities\MultiPSK-1>rsp_tcp.exe -E -P0
rsp_tcp version 1.0

libmirsdrapi-rsp version 2.13 found
detected RSP model 'RSP DUO' (hw ver 3)
listening...
client accepted!
sending RSP extended capabilities structure
failed to start the RSP device, return (3)
failed to initialise RSP device
bye!

I note that the above does say 'RSP DUO' but don't think that is the problem?

The RSPdx is working fine when using a VAC with MultiPSK, it is only the direct mode which is giving me problems.

The Error Message box shows the following:-
Failure of the TCP/IP connection, the SDRplay receiver is
probably not connected.
Disconnecting error.
Socket Error no 10053: Software caused the connection to
abort. A connection that has been made was aborted.
Usually due to connection or protocol error.

Any ideas?


Regards, Mike Simpson
South Penrith, NSW, Australia