webserver library #github

Craig T. Bailey
 

Hi everyone,

I've been working on this for about a day now., I've got my Ardunio IDE totally setup with all the libraries from Willi's files that he added to the wiki on the groups.io page.

But the "webserver" library is causing a fatal error during the compile operation of the source code.

The error that the compiler is puking out is this::

_________
\Arduino\\libraries\\WebServer\\src" "C:\\Users\\Craig\\AppData\\Local\\Temp\\arduino_build_441441\\sketch\\morse_3_v1.4.ino.cpp" -o nul
In file included from C:\Users\Craig\Documents\MorserinoSRC\Morserino-32-master\Software\src\morse_3_v1.4\morse_3_v1.4.ino:56:0:

C:\Users\Craig\Documents\Arduino\libraries\WebServer\src/WebServer.h:27:22: fatal error: functional: No such file or directory

compilation terminated.

Using library Wire at version 1.0 in folder: C:\Program Files (x86)\Arduino\hardware\arduino\avr\libraries\Wire
Using library OLED at version 4.0.1 in folder: C:\Users\Craig\Documents\Arduino\libraries\OLED
Using library ClickButton in folder: C:\Users\Craig\Documents\Arduino\libraries\ClickButton (legacy)
Using library Preferences at version 1.0 in folder: C:\Users\Craig\Documents\Arduino\libraries\Preferences
Using library SPI at version 1.0 in folder: C:\Program Files (x86)\Arduino\hardware\arduino\avr\libraries\SPI
Using library LoRa at version 0.3.0 in folder: C:\Users\Craig\Documents\Arduino\libraries\LoRa
Using library WiFi at version 1.2.7 in folder: C:\Program Files (x86)\Arduino\libraries\WiFi
Using library WebServer at version 1.0 in folder: C:\Users\Craig\Documents\Arduino\libraries\WebServer
exit status 1
Error compiling for board Arduino/Genuino Uno.

_________________

I've used the Webserver library provided by Willi, and I have tried a different Webserver library foudn on github.

Has anyone seen these kinds of errors, and any guidance on how to get around them?
I'm looking forward to compiling the newest Morserino, and taking a swipe at adding the US States as an optional set of items to send...

but can't get the thing to compile.

Thanks in advance.

Craig
N1SFT

Join morserino@groups.io to automatically receive all group messages.