Calibration process hanging - solved


Hi All,

Just a recap perhaps someone can reuse it.

Thanks to Dietmar, I upgraded the FW to the latest and all issues are gone. Managed to create calibrations/test scans.

So it seems the older FW (V2.3 21-05-2011) bug caused the issue with the new java versions. Now I have java 16 and vanJ 3.4.7 operates as it should.

Thanks a lot to everyone who helped.

Csaba HA3LN / HG3N

On 2021-08-08 12:03, Roland Lyman via wrote:
I'm using a rather recent JAVA version I think. Probably downloaded it in May when trying to get the vna/j running on the new PC. It says version 1.8.0_291-b10. I have no idea of what it means. I haven't tried a FW upgrade. Looks a bit scary. Maybe you can find something on DL2SBA's home page or a MiniVNA forum
There is a newer JAVA version available, but I haven't downloaded it.
I'm using vna/j 3.1.13.
73, Roland SM0BRF
-----Ursprungligt meddelande-----
Från: <> För HA3LN
Skickat: den 7 augusti 2021 23:28
Ämne: Re: [miniVNA] Calibration process hanging
...thanks Roland.
This might be the problem then.
I cannot use my old vnaJ 3.1.11 version due to the new java version.
Where can I obtain the FW?
Cannot find it on the vendor's page.
Thanks and 73!
On 2021-08-07 20:11, Roland Nyman via wrote:
I had a similar problem after a computer crash and trying to install the SW on a new PC. My VNA did run OK on the Android app though.

Somewhere on the road is says new VNA/Js are no longer compatible with the old firmware:

”This is due to a miniVNApro firmware bug for versions <2.6.

miniVNApro with firmware < 2.6 is only working with vna/J up to version 3.1.14

miniVNApro with firmware = 2.6 is working with all versions of vna/J

Firmware 2.6 is mandatory using the extender and/or vna/J > 3.1.14.

To use all version of vna/J > 3.1.14, you have to update the firmware of your miniVNApro to the newest firmware.”

That was my problem. After downloading an old VNA/J, problem gone.

73, Roland SM0BRF

-----Ursprungligt meddelande-----
Från: <> För HA3LN
Skickat: den 7 augusti 2021 19:05
Ämne: Re: [miniVNA] Calibration process hanging

...thanks Juro.

Tried but unfortunately did not help to move forward the 2nd calibration step. :-\



On 2021-08-07 16:47, Juraj Neupauer wrote:

Hi all
I have had some issues related to calibration of Mini Vna Pro BT2. It
was not possible to calibrate it correctly. It used to happen after
long time of not using Vna /I think/. Then I tried to reset instrument
using the small red knob and it helped. Juro om2xa
Dňa so 7. 8. 2021, 16:21 KA4INM radio < <mailto:ka4inm@...> ka4inm@...> napísal(a):
HA3LN wrote:
I used to be a happy user of version vnaJ.3.1.11 for long time
executing the jar directly.
Most probably due to the updates of the java environment I got
missing dependent library error msg at the start-up:
I tried to update several version of different java versions with
same result.
I downloaded the newest (3.4.7) version of vnaJ assuming this must
work with the latest java envs.
However it starts-up but when I try to create new calibration for my
minivna pro hangs for ever during the process. It starts to count
the samples and sometimes I can perform the first of the 3 (open,
load) but at the second run hangs each and every time.
I cannot surely exclude the java env either but I followed the
instructions from the manual.
Has anyone came across with this symptom?
Could anyone help how to overcome this step?
Thanks in advance.
You claim "my minivna pro hangs," does it "hang"
when you use the android application "BlueVNA"?
Ron W4BIN - Understanding is much better than
knowing how.MX
Ron W4BIN - Understanding is much better than
knowing how.