Moderated strange issue - random PTT - SOLVED

Dave - N9QNZ <dave@...>

Hi all,

I wanted to report back with what I hope will be useful information for at least TS-480 owners if not others.  I had been experiencing strange and unstable behavior with flrig for days and the problem turned out to be my use of a serial-USB adapter with a prolific chipset.  I am using a Raspberry Pi.

I switched to an adapter with the FTDI chipset and it appears to be working perfectly now.  In fact, I purchased an adapter that has a full set of signal LEDs on the DB9 connector that provide a useful aid for debugging.  The brand is Gearmo and it is available on Amazon.  Not cheap but IMO, worth it.

For those having random frequency changes or any other quirky behavior when using flrig, please look at the adapter chipset as a possible explanation for your troubles.

Also, for those who may be debugging their serial to rig connections, I see constant serial traffic between the Pi and the TS-480.  Also, my "PC" indicator on the radio is constantly on now whereas before it would turn off after 7-8 seconds.


On Thu, Nov 19, 2020 at 11:59 AM Dave - N9QNZ via <> wrote:
Hi All,

I'm not sure where to go for advice on this issue.  I've been testing a relatively new setup with the following components:

Raspberry Pi 4
MiniPro SC (audio interface)
Wellbrook receiving loop

I've been testing receive only while waiting on a Chameleon antenna delivery.  Most of my time has been spent playing around with WEFAX or PSK31 decoding.  At no time have I ever tried any form of transmit with this setup.

From time to time, I find the TS-480SAT in transmit.  I have had the power dialed down to the minimum and no mic connected but PTT is "on" in flrig which I presume it is reading from the radio.  I can't for the life of me understand what might be triggering this condition so I thought I would post here to see if anyone else here has experienced this.  I'll also post to the TS-480 group.