moderated fldigi 4.1.16 Pulse Audio configuration issue #raspberrypi #pi3


dan n1ukj
 

how do you edit the 'Server string' textbox ?
mine is grayed out and i am unable to modify it.

also if i enable the 'PulseAudio' checkbox, this error dialog window pops up.

"Pulse Audio error:
 Pulse Audio error: Connection refused

 Is the server running ?
 Close fldigi and execute 'pulseaudio --start' "

the server appears to be running


Dave, W1HKJ
 

Which operating system / distribution / version ?

David, W1HKJ

On 11/16/20 12:01 PM, Dan, N1UKJ wrote:

how do you edit the 'Server string' textbox ?
mine is grayed out and i am unable to modify it.

also if i enable the 'PulseAudio' checkbox, this error dialog window pops up.

"Pulse Audio error:
 Pulse Audio error: Connection refused

 Is the server running ?
 Close fldigi and execute 'pulseaudio --start' "

the server appears to be running


dan n1ukj
 

sorry David,
i should have stated that.

Raspbian buster 10

i thought that the hostname was to be entered into the 'Server string' textbox.
on the pi3 system configuration page, it displays the hostname as "raspberrypi"

this is what i entered into the Fldigi Server string textbox and as i stated in the last post;
i am not able to edit this textbox as it is grayed-out but i can still see "raspberrypi" is in there.

thanks for the contact,
73's
dan - N1UKJ


G8DQX
 

Dan,

had you specifically installed PulseAudio? On Buster it is not installed by default. If you do install PulseAudio, then it is broken in several respects. Pi OS Buster expects you to use ALSA, which, as far as my informal tests go, fully supports built-in audio & audio peripherals.

73, Stay Safe,

Robin, G8DQX

On 16/11/2020 18:01, Dan, N1UKJ wrote:
also if i enable the 'PulseAudio' checkbox, this error dialog window pops up.

"Pulse Audio error:
 Pulse Audio error: Connection refused

 Is the server running ?
 Close fldigi and execute 'pulseaudio --start' "

the server appears to be running


dan n1ukj
 

hi Robin,thank you for the reply.

some background, i tried everyday for a week to install FlDigi on a RaspberryPi 3B+ with fresh Buster 10 OS image.
i attempted several FlDigi versions including 4.1.12, 4.1.15, 4.1.16 all of which kept failing during the 'make install'
the failure point, was at what i think is possibly called a module install process.
anyway, it was always at the exact same point on all versions. i do not remember its name but was something like
dialogconfig or maybe configdialog.

on sunday i turned to linuxham@groups.io for help
Dave - W3DJS offered a script file to install FlDigi which i used and was successful in running the program as well.
i have some limited knowledge of linux and programming but not familiar with Pulse Audio or the other programs
that this script installs:
sudo apt -y install build-essential libfltk1.3-dev libsamplerate0-dev portaudio19-dev libsndfile1-dev libxft-dev libxinerama-dev libxcursor-dev libusb-1.0.0-dev lib
-dev pavucontrol

after the script installed Fldigi 4.1.16, i attempted to setup the soundcard settings in the Configure menu > Devices
using PulseAudio as the setup instructions mention PulseAudio is the system for FlDigi.
the rest of what occurred, i have provided in previous posts.

note: i did add user pi to the 'dialout' group and that seem to go ok but perhaps it did not.
under the raspberry menu item "Sound & Video" > "Pulse Audio Volume Control" & "VLC Media Player" are listed.
i got the hostname  from running sudo raspi-config > System Options > Hostname which is the value i entered in the
'Server string' text box in FlDigi > Configure Devices > PulseAudio.

i have not completed any additional installs or setups beyond what the provided script has done.
perhaps there are additional downloads that need to be done but i am not aware of them.
thank you again for your feedback.
do you have some suggestions as to what i can / should do now.

dan - N1UKJ 


Cliff, AE5ZA
 

Hi Dan,

First a report on my Pi-3B install. All went as expected. I had a self inflicted issue with trying to build with static libs, but when I went back to the normal way everything went as expected so I don’t know what was your issue in building fldigi.

I noticed you are trying to use Pulse Audio. That’s fine, I use it also as it is more stable on the Pi3 than Pulse audio, at least on mine. Please realize you don’t need to put any thing in the server string to make it run. Just leave that blank. What issue are you trying to solve with the audio? I don’t remember seeing your other posts on that issue.

73,
Cliff, AE5ZA

On Nov 17, 2020, at 10:39, Dan, N1UKJ <uspt@...> wrote:

hi Robin,thank you for the reply.

some background, i tried everyday for a week to install FlDigi on a RaspberryPi 3B+ with fresh Buster 10 OS image.
i attempted several FlDigi versions including 4.1.12, 4.1.15, 4.1.16 all of which kept failing during the 'make install'
the failure point, was at what i think is possibly called a module install process.
anyway, it was always at the exact same point on all versions. i do not remember its name but was something like
dialogconfig or maybe configdialog.

on sunday i turned to linuxham@groups.io for help
Dave - W3DJS offered a script file to install FlDigi which i used and was successful in running the program as well.
i have some limited knowledge of linux and programming but not familiar with Pulse Audio or the other programs
that this script installs:
sudo apt -y install build-essential libfltk1.3-dev libsamplerate0-dev portaudio19-dev libsndfile1-dev libxft-dev libxinerama-dev libxcursor-dev libusb-1.0.0-dev lib
-dev pavucontrol

after the script installed Fldigi 4.1.16, i attempted to setup the soundcard settings in the Configure menu > Devices
using PulseAudio as the setup instructions mention PulseAudio is the system for FlDigi.
the rest of what occurred, i have provided in previous posts.

note: i did add user pi to the 'dialout' group and that seem to go ok but perhaps it did not.
under the raspberry menu item "Sound & Video" > "Pulse Audio Volume Control" & "VLC Media Player" are listed.
i got the hostname  from running sudo raspi-config > System Options > Hostname which is the value i entered in the
'Server string' text box in FlDigi > Configure Devices > PulseAudio.

i have not completed any additional installs or setups beyond what the provided script has done.
perhaps there are additional downloads that need to be done but i am not aware of them.
thank you again for your feedback.
do you have some suggestions as to what i can / should do now.

dan - N1UKJ 



Dave - N9QNZ <dave@...>
 

In what ways is pulseaudio "broken"?

On Tue, Nov 17, 2020 at 9:45 AM G8DQX <list@...> wrote:
Dan,

had you specifically installed PulseAudio? On Buster it is not installed
by default. If you do install PulseAudio, then it is broken in several
respects. Pi OS Buster expects you to use ALSA, which, as far as my
informal tests go, fully supports built-in audio & audio peripherals.

73, Stay Safe,

Robin, G8DQX

On 16/11/2020 18:01, Dan, N1UKJ wrote:
> also if i enable the 'PulseAudio' checkbox, this error dialog window
> pops up.
>
> "Pulse Audio error:
>  Pulse Audio error: Connection refused
>
>  Is the server running ?
>  Close fldigi and execute 'pulseaudio --start' "
>
> the server appears to be running






dan n1ukj
 

hi Cliff -AE5ZA
thanks for keeping me up to speed on your install.
glad that you were able to self-heal.

if you want to see my prior post look at messages#
 https://groups.io/g/linuxham/message/43353 https://groups.io/g/linuxham/message/43355

in your post above you said:
"Please realize you don’t need to put any thing in the server string to make it run. Just leave that blank"

that is my problem, i can not edit that textbox - it is grayed-out but i can still see the hostname: 'raspberrypi' in the background.
i am unable to remove , change or edit this field. i would love to make it blank ; but can not even do that !

maybe there is an XML file that i can edit to remove the offend entry.
is anyone aware of such a XML file ???

thanks Cliff.
dan - N1UKJ


dan n1ukj
 

hi Dave - N9QNZ,

take a look at this message posting where i describe that when i attempt to put a checkmark into the checkbox to active
PulseAudio
a pop-up Error window opens with the alert that i mentioned in my posting.

https://groups.io/g/linuxham/message/43353
dan - N1UKJ


Dave - N9QNZ <dave@...>
 

My message was for G8DQX regarding pulseaudio being broken, presumably in general based on how he worded that statement.

As to your problem regarding the checkbox resulting in an error, are you sure pulseaudio is running?  How are you checking?

I believe that server string relates to pulseaudio receiving audio from, or perhaps sending audio to, a remote server.  It is blank in my setup.

So far, pulseaudio has worked fine for me.  I have just now switched to using rdp to access my Pi remote (instead of VNC).  I now plan to try to get audio streamed over the network from the Pi to my Macbook.  This will require compiling and adding some libraries to pulseaudio.





On Tue, Nov 17, 2020 at 2:12 PM Dan, N1UKJ <uspt@...> wrote:
hi Dave - N9QNZ,

take a look at this message posting where i describe that when i attempt to put a checkmark into the checkbox to active
PulseAudio
a pop-up Error window opens with the alert that i mentioned in my posting.

https://groups.io/g/linuxham/message/43353
dan - N1UKJ


Cliff, AE5ZA
 

Dan,

Close fldigi then go to your Home directory and then to the hidden directory .fldigi. In that directory, using the text editor, open the fldigi_def.xml file. Do a search for <PULSESERVER>. There should be nothing between the <PULSESERVER> and the following </PULSESERVER> tags. If there is then delete it to remove everything between the two tags. Save the file then open fldigi again.

Check that PulseAudio is running by opening the system Task Manager. You should fine Pulse Audio in the list of running tasks.

Open the app PulseAudio Volume Control and you should see your Audio Codec listed in Input and Ouptput devices, usually below the Built-in Audio information. Be sure the volume is set to 100% to start out with. That is often a bug-a-boo for people not getting TX power out.

73,
Cliff, AE5ZA

On Nov 17, 2020, at 12:59, Dan, N1UKJ <uspt@...> wrote:

hi Cliff -AE5ZA
thanks for keeping me up to speed on your install.
glad that you were able to self-heal.

if you want to see my prior post look at messages#
 https://groups.io/g/linuxham/message/43353 https://groups.io/g/linuxham/message/43355

in your post above you said:
"Please realize you don’t need to put any thing in the server string to make it run. Just leave that blank"

that is my problem, i can not edit that textbox - it is grayed-out but i can still see the hostname: 'raspberrypi' in the background.
i am unable to remove , change or edit this field. i would love to make it blank ; but can not even do that !

maybe there is an XML file that i can edit to remove the offend entry.
is anyone aware of such a XML file ???

thanks Cliff.
dan - N1UKJ



G8DQX
 

Dave,

a good question. PulseAudio has not been part of Pi OS (née Raspbian) since Raspbian Stretch. It was introduced to support Bluetooth audio, but was dropped in Stretch, and is absent from Buster. My observations in Buster, when PulseAudio is installed, are (on Pi 4B hardware) that:

1) Bluetooth audio is not supported when PulseAudio is active (it is under ALSA)

2) audio from the 3.5mm socket is reduced to mono (under ALSA, the audio is stereo, of pretty high quality)

The reasons for this behaviour are not directly known. The behaviour is consistent with the dropping of PulseAudio, which is otherwise generally easier to use than raw ALSA.

HTH, 73, Stay Safe,

Robin, G8DQX

From the release notes (https://downloads.raspberrypi.org/raspios_armhf/release_notes.txt):

2017-08-16:
  * Based on Raspbian Stretch (Debian version 9)
  * Version 60 of Chromium browser included
  * Version 3.0.1 of Sonic Pi included
  * Version 6.1.1 of RealVNC included
  * Version 0.17.4 of NodeRED included
  * Bluetooth audio routed via ALSA rather than Pulseaudio


On 17/11/2020 18:53, Dave - N9QNZ wrote:
In what ways is pulseaudio "broken"?

On Tue, Nov 17, 2020 at 9:45 AM G8DQX <list@...> wrote:
Dan,

had you specifically installed PulseAudio? On Buster it is not installed
by default. If you do install PulseAudio, then it is broken in several
respects. Pi OS Buster expects you to use ALSA, which, as far as my
informal tests go, fully supports built-in audio & audio peripherals.

73, Stay Safe,

Robin, G8DQX


Ken Cox, WA8OMR
 

I had issues with Pulse Audio Output volume setting changing on it's own running flrig and fldigi 4.1.15. Went back to using alsa and no more problems. Also 4.1.16 works well on pi 4b.


Cliff, AE5ZA
 

Robin,

I don’t know who installs PulseAudio for fldigi, but it’s there when fldigi is built and works fine for me on a Pi3 and Pi4. It even starts without being told to. All I do is build fldigi and install Pavcontrol and it’s there. Just did it yesterday with the latest Buster.

73,
Cliff, AE5ZA

On Nov 17, 2020, at 17:31, G8DQX <list@...> wrote:

Dave,

a good question. PulseAudio has not been part of Pi OS (née Raspbian) since Raspbian Stretch. It was introduced to support Bluetooth audio, but was dropped in Stretch, and is absent from Buster. My observations in Buster, when PulseAudio is installed, are (on Pi 4B hardware) that:

1) Bluetooth audio is not supported when PulseAudio is active (it is under ALSA)

2) audio from the 3.5mm socket is reduced to mono (under ALSA, the audio is stereo, of pretty high quality)

The reasons for this behaviour are not directly known. The behaviour is consistent with the dropping of PulseAudio, which is otherwise generally easier to use than raw ALSA.

HTH, 73, Stay Safe,

Robin, G8DQX

From the release notes (https://downloads.raspberrypi.org/raspios_armhf/release_notes.txt):


2017-08-16:
  * Based on Raspbian Stretch (Debian version 9)
  * Version 60 of Chromium browser included
  * Version 3.0.1 of Sonic Pi included
  * Version 6.1.1 of RealVNC included
  * Version 0.17.4 of NodeRED included
  * Bluetooth audio routed via ALSA rather than Pulseaudio



On 17/11/2020 18:53, Dave - N9QNZ wrote:
In what ways is pulseaudio "broken"?

On Tue, Nov 17, 2020 at 9:45 AM G8DQX <list@...> wrote:
Dan,

had you specifically installed PulseAudio? On Buster it is not installed
by default. If you do install PulseAudio, then it is broken in several
respects. Pi OS Buster expects you to use ALSA, which, as far as my
informal tests go, fully supports built-in audio & audio peripherals.

73, Stay Safe,

Robin, G8DQX


Dave - N9QNZ <dave@...>
 

As for #2, alsamixer shows mono stereo is output.  The incorrect "label" can be fixed by commenting out the mono section of /usr/share/pulseaudio/alsa-mixer/profile-sets/default.conf

Assuming this is what you are referring to, this is an old and well known "issue".


On Tue, Nov 17, 2020 at 6:31 PM G8DQX <list@...> wrote:

Dave,

a good question. PulseAudio has not been part of Pi OS (née Raspbian) since Raspbian Stretch. It was introduced to support Bluetooth audio, but was dropped in Stretch, and is absent from Buster. My observations in Buster, when PulseAudio is installed, are (on Pi 4B hardware) that:

1) Bluetooth audio is not supported when PulseAudio is active (it is under ALSA)

2) audio from the 3.5mm socket is reduced to mono (under ALSA, the audio is stereo, of pretty high quality)

The reasons for this behaviour are not directly known. The behaviour is consistent with the dropping of PulseAudio, which is otherwise generally easier to use than raw ALSA.

HTH, 73, Stay Safe,

Robin, G8DQX

From the release notes (https://downloads.raspberrypi.org/raspios_armhf/release_notes.txt):

2017-08-16:
  * Based on Raspbian Stretch (Debian version 9)
  * Version 60 of Chromium browser included
  * Version 3.0.1 of Sonic Pi included
  * Version 6.1.1 of RealVNC included
  * Version 0.17.4 of NodeRED included
  * Bluetooth audio routed via ALSA rather than Pulseaudio


On 17/11/2020 18:53, Dave - N9QNZ wrote:
In what ways is pulseaudio "broken"?

On Tue, Nov 17, 2020 at 9:45 AM G8DQX <list@...> wrote:
Dan,

had you specifically installed PulseAudio? On Buster it is not installed
by default. If you do install PulseAudio, then it is broken in several
respects. Pi OS Buster expects you to use ALSA, which, as far as my
informal tests go, fully supports built-in audio & audio peripherals.

73, Stay Safe,

Robin, G8DQX


dan n1ukj
 

yea Cliff - AE5ZA  !

in my message: https://groups.io/g/linuxham/message/43366

my question was : "maybe there is an XML file that i can edit to remove the offend entry.
is anyone aware of such a XML file ??? "
you did It !
in your message reply: https://groups.io/g/linuxham/message/43369

your answer was : "open the fldigi_def.xml file. Do a search for <PULSESERVER>"

thank you, thank you, thank you, thank you, thank you !
here is what the  offending line looks like on my system, that i have been looking for in the fldigi_def.xml file.
<!-- type: std::string; default: &quot;&quot;
PulseAudio server string -->
<PULSESERVER>raspberrypi</PULSESERVER>

the result is that in Fldigi-4.1.16   Configure>Soundcard>Devices > [ ] PulseAudio  ---->Server string: [            ]

the "Server srting:"      textbox is empty, as it should be !
NOW when i put a check into the " [ ] PulseAudio"   checkbox, the program no longer generates a pop-up
Error window message i was getting as stated in my original posting message:

https://groups.io/g/linuxham/message/43353

as a side note i made a similar mistake a year ago and was never able to resolve it on groups.io
guess that just says i'm not ageing gracefully or can't remember sh_t.
i'm thankful to those who endured this very long drawn out posting
but remember,  i have been dealing with this same issue for a year.

 i am exceeding grateful that there is a community like linuxham@groups.io 
and the special effort of support that i found here.
i just knew it could be fix but the final credit has to go to :
Cliff - AE5ZA  !

dan - N1UKJ


dan n1ukj
 

i just want to make it clear to anyone who has encountered this problem that the offending line in:
fldigi_def.xml
on my RaspberryPi 3 B+ using OS buster 10 was:

<PULSESERVER>raspberrypi</PULSESERVER>



when the line is corrected it should look like:

<PULSESERVER></PULSESERVER>



NOTE:
when restarting Fldigi  the file  fldigi_def.xml   was not read so,

i reboot the RaspberryPi  to ensure the file fldigi_def.xml
was read by the FlDigi program.



Cliff, AE5ZA
 

Great news, Dan. Thanks for letting us know it’s all working finally. Now enjoy!

73,
Cliff, AE5ZA

On Nov 17, 2020, at 22:21, Dan, N1UKJ <uspt@...> wrote:

yea Cliff - AE5ZA  !

in my message: https://groups.io/g/linuxham/message/43366

my question was : "maybe there is an XML file that i can edit to remove the offend entry.
is anyone aware of such a XML file ??? "
you did It !
in your message reply: https://groups.io/g/linuxham/message/43369

your answer was : "open the fldigi_def.xml file. Do a search for <PULSESERVER>"

thank you, thank you, thank you, thank you, thank you !
here is what the  offending line looks like on my system, that i have been looking for in the fldigi_def.xml file.
<!-- type: std::string; default: &quot;&quot;
PulseAudio server string -->
<PULSESERVER>raspberrypi</PULSESERVER>

the result is that in Fldigi-4.1.16   Configure>Soundcard>Devices > [ ] PulseAudio  ---->Server string: [            ]

the "Server srting:"      textbox is empty, as it should be !
NOW when i put a check into the " [ ] PulseAudio"   checkbox, the program no longer generates a pop-up
Error window message i was getting as stated in my original posting message:

https://groups.io/g/linuxham/message/43353

as a side note i made a similar mistake a year ago and was never able to resolve it on groups.io
guess that just says i'm not ageing gracefully or can't remember sh_t.
i'm thankful to those who endured this very long drawn out posting
but remember,  i have been dealing with this same issue for a year.

 i am exceeding grateful that there is a community like linuxham@groups.io 
and the special effort of support that i found here.
i just knew it could be fix but the final credit has to go to :
Cliff - AE5ZA  !

dan - N1UKJ


dan n1ukj
 

hi Cliff - AE5ZA,

well, i can't say all is working just yet but we did get rid of the roadblock - "Server String" texbox issue !

could you provide me with the setting on your RaspberryPi in the Pulse Audio Volume Control panel, specifically
in the Configuration tab ?

i'm interested in knowing what you have showing for those 3 settings.

thanks,
73's
dan - N1UKJ


Dave - N9QNZ <dave@...>
 

I think your recording tab should look like the attached.

On Thu, Nov 19, 2020 at 11:31 AM Dan, N1UKJ <uspt@...> wrote:
hi Cliff - AE5ZA,

well, i can't say all is working just yet but we did get rid of the roadblock - "Server String" texbox issue !

could you provide me with the setting on your RaspberryPi in the Pulse Audio Volume Control panel, specifically
in the Configuration tab ?

i'm interested in knowing what you have showing for those 3 settings.

thanks,
73's
dan - N1UKJ