Topics

Stanza-window disappears in Windows 7

gerhard.ulli@...
 

Hi there, I've been rubbernecking Stanza for some time now and finally found motivation to start,

yet when I try to make my first steps I notice I can not continue because the window that opens when calling Stanza under windows

only shows up for a moment, way too fast to be read by anybody.

I invested some time but could not find a solution -

I know this is a trivial problem, but it clearly creates an inhibition threshold for beginners.


The right way to do it, in my experience, is to run the exe in the same window as it was called from.


  Please, answer soon :) so I can continue my journey into stanza !

BEst regards

-Ulli Gerhard

 

Hi Ulli!

Glad to hear you're giving it a try. Stanza is currently designed to be run in a console application. The default one that comes with Windows is called Command Prompt. You can start it up by opening the Start Menu, and searching for Command Prompt. After it launches, you can navigate to your project directory using the "cd" command.

Let me know if you still have issues.

  -Patrick

gerhard.ulli@...
 
Edited

Seems I should have explained better -

I already am in a command window (dos prompt) and run stanza from there, an additional command-window is opened.


I found the solution though: stanza.exe was configured to be run as administrator, once deactivated, it stays in the same cmd-window.

Thanks for your help anyway, now I can continue ^^

 

Hi Ulli.

That's interesting. It's good that you found a fix. I'll make a note of it in case anyone else runs into the same issues. Thanks for reporting it!

  -Patrick

gerhard.ulli@...
 

Your welcome !

The next issue could be a little more complicated, I'll just try having it answered here.

When compiling the example "helloworld.stanza" I get:

tmp3.s:876: Error: bad register name `%rsp)'
tmp3.s:877: Error: bad register name `%rsi'
tmp3.s:878: Error: bad register name `%rax'
tmp3.s:879: Error: bad register name `%rsp'
tmp3.s:882: Error: bad register name `%rsp'
tmp3.s:883: Error: missing or invalid immediate expression `4294967296'
tmp3.s:884: Error: bad register name^C

I guess it's an issue with mingw and the used architecture - it's stated you should use 64 bit, but while installing there's another point architecture which is on 686 by default

The linked mingw installation-routine is not working btw, it throws "The file has been downloaded incorrectly" when starting to download.

I got mingw via mingw-installation-manager

https://sourceforge.net/projects/mingw/files/latest/download?source=files

which was updated last time in 2013 hmmm....

 

Hi Ulli.

Sorry you're having such a rough time getting started! I think you're right that it's a problem with your MinGW installation. Can you verify that you visited: https://sourceforge.net/projects/mingw-w64/ ? 

There are actually two separate MinGW projects. One is called MinGW, and one is called MinGW-w64. It is doubly confusing because the MinGW project actually has a 64-bit version as well. That's not the one you want. You want the actual project called MinGW-w64. 

  -Patrick

gerhard.ulli@...
 

post scriptum:

Problem of "File downloaded incorrectly" still persists,

some of https://sourceforge.net/projects/mingw-w64/files/ distros are dead links,

I downloaded a "working" distros file and placed it with installer in same folder and made sure the installer would choose it (so I thought) but no sir, still downloaded incorrectly :(

gerhard.ulli@...
 


"file was downloaded incorrectly" for installation of all versions


niXman - 4 hours ago

Please redownload the mingw-w64-install.exe


Seems I was not the only one with that problem

gerhard.ulli@...
 

Problem still persisting.. no stanza today :(

going to sleep now - good night :)

 

Yup. I just tried using their official installer again. Looks like the current version is broken.

Here's a direct link to the .7z file: https://sourceforge.net/projects/mingw-w64/files/Toolchains%20targetting%20Win64/Personal%20Builds/mingw-builds/6.3.0/threads-posix/seh/

I verified that that file is good. You need to unzip it (using 7-zip if you don't already have it) to a folder, and put it on your path. 

  -Patrick

gerhard.ulli@...
 
Edited

Ok, works now, I install mingw without touching anything except the architecture setting, which I changed from "i686" to "x86_64"

This is not stated in the "Getting started"-chapter, could you elaborate on that ?

Can't be too wrong though, since I successfuly ran a stanza-example and got "Hello World" ! So it begins :)

And maybe a small reminder in the tutorial: if cmd spawns a new window for stanza-process, your permissions might be wrong.

best regards

 

Okay Ulli. Thanks a lot for explaining the steps you took. I'll document it on the website. It should be very helpful to other Windows users!

  -Patrick

Previous Topic Next Topic