Topics

Operations: Controlling staging traffic

Jon Schmidt
 

I must not be understanding something.  I am trying to restrict a load from going into a staging track, but when I do so, nothing goes into that track.  The build report shows:

1- Train terminates into staging at (South Stg), there are 2 tracks
5- Staging track (Track1) does not accept all loads
7- Staging track (Track1) cannot service train (X101S)
7- Option to restrict staging to the same car type, road, and load as train is enabled
5- Staging track (Track2) is occupied, found 0 locomotive(s) and 1 cars
1- Note that the program requires an empty staging track for each train!
1- All staging tracks at South Stg are occupied, reserved, or cannot service the train
1- Build failed for train (X101S)

*** But I only restricted one load:

Staging Name
Track1 is serviced by trains traveling North South
Rolling stock serviced by this track:
Baggage, Boxcar, Caboose, Coal, Coilcar, FlatBHPaper, FlatBHWood,
FlatBulkHead, FlatTimber, FlatTrailer, FlatWood, Flatcar, Gon-scrap,
Gondola, HopChem, HopCmnt, HopCoal, HopCoal-Ety, HopGrain, HopSand,
Hopper, MOW, MOWBox, Passenger, ReefMech, Reefer, ReeferIce, Stock,
Tank Food, Tank Gas, Tank Kero, Tank Oil, Tank Veg
Track accepts all roads
Loads NOT serviced by this track:
stgn
Loads NOT shipped from this track:
stgn
Any train can set out cars
Any train can pick up cars

What am I missing?

Jon Schmidt, San Rafael

frankjoanw
 

Hi. I have had the same problem. The staging insists on receiving all loads for some reason. I gave up and had to limit the loads hauled on the train. Good luck. I sure would appreciate having the answer to this problem as well..THANK YOU.


:>)....Have a good day.....Frank W in Houston Texas


:>)....Have a good day.....Frank W

Doc
 

If you cannot limit loads to staging, you could use special cars. Ie car type-type load. Then adjust car types accepted by staging tracks
Doc

Stefan ` Bartelski
 

Third line down seems to say that your train cannot be accepted. In other words, check why the load is assigned to the train. You may have to do something to your train definition, not staging track.

stefan

Jim Elbe
 

Jon,

Your problem is the 2nd "7" in the build report. From the main menu go to Operations > Settings > Options. Under Staging Options uncheck the first box. If you do not want to do this for some reason then you MUST make sure the load restrictions in the Staging track are the same as the train restrictions.

Jim E.


On 6/7/2018 9:02 PM, Jon Schmidt wrote:
I must not be understanding something.  I am trying to restrict a load from going into a staging track, but when I do so, nothing goes into that track.  The build report shows:

1- Train terminates into staging at (South Stg), there are 2 tracks
5- Staging track (Track1) does not accept all loads
7- Staging track (Track1) cannot service train (X101S)
7- Option to restrict staging to the same car type, road, and load as train is enabled
5- Staging track (Track2) is occupied, found 0 locomotive(s) and 1 cars
1- Note that the program requires an empty staging track for each train!
1- All staging tracks at South Stg are occupied, reserved, or cannot service the train
1- Build failed for train (X101S)

*** But I only restricted one load:

Staging Name
Track1 is serviced by trains traveling North South
Rolling stock serviced by this track:
Baggage, Boxcar, Caboose, Coal, Coilcar, FlatBHPaper, FlatBHWood,
FlatBulkHead, FlatTimber, FlatTrailer, FlatWood, Flatcar, Gon-scrap,
Gondola, HopChem, HopCmnt, HopCoal, HopCoal-Ety, HopGrain, HopSand,
Hopper, MOW, MOWBox, Passenger, ReefMech, Reefer, ReeferIce, Stock,
Tank Food, Tank Gas, Tank Kero, Tank Oil, Tank Veg
Track accepts all roads
Loads NOT serviced by this track:
stgn
Loads NOT shipped from this track:
stgn
Any train can set out cars
Any train can pick up cars

What am I missing?

Jon Schmidt, San Rafael

Dan Boudreau
 

Jon,

Under tools,  options,  deselect this option:
Restrict staging to the same car type, road, and load as train
http://jmri.sourceforge.net/help/en/package/jmri/jmrit/operations/Operations.shtml#SettingsOptions

Dan

Jon Schmidt
 

Got it.  I thought that was an 'or', not an 'and'.