Topics

JMRI/Z21 setup issues

@MoonGoddess
 

I’m struggling to get JMRI and my Z21 to work together well. After much frustration I’ve managed to get JMRI to talk to a train via XpressNet (direct bit) via the programming track. My problems are that I cannot seem to get it to work via programming on main, as XpressNet causes my Z21 to switch power to the programming track and the other options (internal and LocoNet) don’t seem to communicate with the train on the main track.

I also cannot seem to get any sort of throttle control either for any train, be it the programming track or the main.

Any help appreciated

Paul Bender
 

On Jun 7, 2018, at 3:35 PM, @MoonGoddess wrote:
I’m struggling to get JMRI and my Z21 to work together well. After much frustration I’ve managed to get JMRI to talk to a train via XpressNet (direct bit) via the programming track. My problems are that I cannot seem to get it to work via programming on main, as XpressNet causes my Z21 to switch power to the programming track and the other options (internal and LocoNet) don’t seem to communicate with the train on the main track.
You definitely want to use the XPressNet option.

Which version of JMRI do you have installed?

I also cannot seem to get any sort of throttle control either for any train, be it the programming track or the main.
Can you verify that you have the preferences set so that the XPressNet connection is the default for throttles?

I’ve been using a Z21 ( the black one ) as my primary testing/development/decoder programming device for the last year, and I am pretty sure I have all the kinks out of it.

Paul

@MoonGoddess
 

Hi Paul,

Thank you for your reply.

I’ve now set preferences/defaults to XpressNet and the throttle is working, although there does seem to be a lot of lag between pressing a button and he train acting on the command; something which isn’t present when I use the Roco Z21 app.

One other issue is that it only wants to allow the use of the programming track for decoder programming, despite the Z21 app allowing me to program on the main track (very useful when setting scale speeds).

@MoonGoddess
 

forgot to say I’m using the latest beta version of the software