Topics

help with Linux please (PROGRESS!)

David Copson
 

Progress. YEAH!  Not there yet though. Please keep help coming.


On Jun 9, 2018, at 12:48 PM, Dave Sand <ds@...> wrote:

To start JMRI from the desktop, you need to create an icon on the desktop….

THANKS Dave. Worked great. Can now open JMRI. (after months of intermittent attempts and frustration). Something is lacking in JMRI instructions. I had the icon but  it didn’t work. Again, thank you.
_._,_._,_

On Jun 9, 2018, at 7:33 AM, Dave Heap <dgheap@...> wrote:

You have typos….

I solved this using USB drive to copy/paste. Not used to the command line. 


- Confirm that the driver is loading/unloading
- Find out the assigned port name.
You will also need to enter the following command EXACTLY (except for the double quotes):
"sudo adduser ${USER} dialout"
   (This assumes "dialout" is the group shown beside your device in the list above.)

You won't see the port in JMRI until you get this one right.

Drive that disappears is ttyUSB0. This is on list in preferences and now selected. So think I did that all right.

HOWEVER on restart, Error Message:
Unable to create connection “LocoNet” (L)
Serial port ttyUSB0 is in use.

If you are still having problems, you need to check the /var/lock directory and remove any stale lock files for the device. This can particularly be a problem if you have ever run JMRI as root.

...Don't be tempted to use "sudo" to run JMRI.

I MAY have done that in attempts to get JMRI to open. 
What do I do next?   "check the /var/lock directory” is meaningless to me.

I very much appreciate your help. 

Richard Knight
 

I forgot how to do a screen shot widows XP.


On 6/12/2018 4:36 PM, David Copson wrote:
Progress. YEAH!  Not there yet though. Please keep help coming.


Lots of Daves here:

On Jun 9, 2018, at 12:48 PM, Dave Sand <ds@...> wrote:

To start JMRI from the desktop, you need to create an icon on the desktop….

THANKS Dave. Worked great. Can now open JMRI. (after months of intermittent attempts and frustration). Something is lacking in JMRI instructions. I had the icon but  it didn’t work. Again, thank you.

Richard Knight
 

Please disregard email-sent to wrong address !!


On 6/12/2018 4:47 PM, Richard Knight wrote:

I forgot how to do a screen shot widows XP.


On 6/12/2018 4:36 PM, David Copson wrote:
Progress. YEAH!  Not there yet though. Please keep help coming.


Lots of Daves here:

On Jun 9, 2018, at 12:48 PM, Dave Sand <ds@...> wrote:

To start JMRI from the desktop, you need to create an icon on the desktop….

THANKS Dave. Worked great. Can now open JMRI. (after months of intermittent attempts and frustration). Something is lacking in JMRI instructions. I had the icon but  it didn’t work. Again, thank you.

Dave Heap
 

See below:

On 13 Jun 2018, at 6:36 AM, David Copson <david@...> wrote:

You won't see the port in JMRI until you get this one right.

Drive that disappears is ttyUSB0. This is on list in preferences and now selected. So think I did that all right.

That's good.

HOWEVER on restart, Error Message:
Unable to create connection “LocoNet” (L)
Serial port ttyUSB0 is in use.

If you are still having problems, you need to check the /var/lock directory and remove any stale lock files for the device. This can particularly be a problem if you have ever run JMRI as root.

...Don't be tempted to use "sudo" to run JMRI.

I MAY have done that in attempts to get JMRI to open. 
What do I do next?   "check the /var/lock directory” is meaningless to me.

Some more Terminal commands:
cd /var/lock
ls -alR
(This should produce a list of files in the /var/lock folder and any subfolders)

ls -alR > ~/Desktop/files.txt
This should send that list of files to a text file on the Desktop so you can use sneaker net (USB drive) to get the contents to this list.

Dave Heap