Topics

JAWS Skype for Dekstop scripts no longer functioning after skype update

JM Casey
 

Hi.

The subject generally explains what I think has happened. Yesterday I invoked skype as I normally do (unusually for me, I actually have a hotkey for this), and, the user account control came up. I saw a quick “setup” screen, and the programme seemed to be updating. I feel like it wasn’t a major update because I seem to remember being on skype 8.51.something previously. Anyway, now it says, Skype 8.51.0.72, which it says is the latest version.

I’m using JAWS 2018, and as well as the native JAWS skype scripts, I had installed scripts from http://www.dlee.com, which add a little bit of extra functionality and keyboard commands.

Now, none of the scripts are loading. When I check with insert-q, JAWS announces that the scripts for “Google chrome settings” are running. I understand skype for desktop is now a chromium-based application, and if there were no scripts specifically designed for skype, this is exactly what it would say. But these scripts were all working fine until last night.

The programme is slightly usable without scripts, but it’s not great. Braille display does not track in message history (and increasily I like working with speech off so I can more comfortably listen to music or whatever). I have to keep remembering to hit insert-z to turn off the virtual cursor when typing.

Another weird thing, which may be related, is that  the first time I invoke skype, now, the programme activates, but seems to be minimised. I have “run in background” turned off in settings; in fact, my actual skype settings don’t seem to have changed at all.

What has gone wrong here? Anybody have any suggestions?