Re: Dropping support for Python 2.6 and 3.3

Menno Finlay-Smits
 

After thinking about this some more, I think we do want to drop support
for old Python versions. It helps to reduce our maintenance and testing
burden significantly, and I think it's important that we discourage
usage of these ancient versions too.

IMAPClient 2.0 will no longer officially support 2.6 and 3.3. I'm sorry
for the headaches this might cause some of you.

--
Menno Finlay-Smits
inbox@... :: http://menno.io/

On Fri, 18 Aug 2017, at 02:11, Adam Tauno Williams wrote:
The plan is to drop support for these Python versions in IMAPClient
2.0.
Does anyone use IMAPClient in a serious way with Python 2.6 or 3.3? 
Python 2.6 has too many other issues at this point - I'm using it on at
least Python 2.7.x

--
Adam Tauno Williams <mailto:@whitemice> GPG D95ED383
OpenGroupware Developer <http://www.opengroupware.us/>


Join imapclient@groups.io to automatically receive all group messages.