Topics

F buttons not working #all

pomponderoo@...
 

I hope this is a stupid question with a simple answer. My F1 F2 F3 and F4 buttons do not seem to be functioning. Did a factory reset and still nothing. Have read the manual back to front but still nothing. What am I doing wrong?

Steve W3AHL
 
Edited

Not a problem I remember seeing mentioned by other owners.  Most of the push buttons on the display head are set up in groups of four in series with resistors in between them.  When a button is pushed it grounds the series resistor chain, which determines the voltage that is read by an A/D input on the CPU, which deterrmines which button was pushed, that causes a control message to be sent to the main CPU.  If all of the other buttons seem to work, then there is either a problem with the CPU A/D input signal (pin 79, K1IL for the Fn switches), the pullup resistor to 3.3 VDC for  K1IL (R2017) or one of the series resistors between the switches.

A service manual and an ohmmeter can verify the resistors, PCB trace and switches are OK.  If so, then it may be a problem with the Display's CPU or the solder joint of pin 79. 

Steve, W3AHL

Charles & Sandra Cohen
 

FWIW --

Try cleaning the contacts on the connectors between the faceplate and the body -- or between the faceplate, remote cable, and body (if you have separated the rig).

Use alcohol, go over them twice.  No abrasive, no oily contact cleaner.

.      Charles / VA7CPC

pomponderoo@...
 

Will try that tomorrow and let you know...
Regards
Paul


On Sun, 8 Jul 2018 at 16:09, Charles & Sandra Cohen via Groups.Io <cpcohen1945=yahoo.com@groups.io> wrote:
FWIW --

Try cleaning the contacts on the connectors between the faceplate and the body -- or between the faceplate, remote cable, and body (if you have separated the rig).

Use alcohol, go over them twice.  No abrasive, no oily contact cleaner.

.      Charles / VA7CPC