Topics

Ventilation starts and temperature shows maximum when I plug the LDG IT-100 #all


Aurelian
 

Hi all,
Something is wrong with my IC-7000 or my LDG IT-100. It used to work very well before, but now I got this.  When I connect the LDG tuner with the cable to the IC-7000 the temperature indicator goes to maximum and ventilation starts. LDG tuner does not tune any more, the radio does not even recognize it. LDG tuner does not answer at all to any button push. ICOM radio works well...sensitivity is not affected...it even goes into TX wihout problems..except the temperature indicator.
Any idea about what can it be? IC-7000 seems to work very well without the tuner...and I wonder where is the problem

Aurelian - SA0CAN


WA8Y Steven
 

It sounds like a high SWR situation.
Test the rig on a dummy load and Wattmeter.

Check the 4 pin connection between the rig and the tuner.

I have the LDG AT-100 Pro 2 which works with any rigs so I'm not using the tuner connector.

Steve WA8Y 


On Wed, Mar 28, 2018, 4:14 PM <aurelian.bria@...> wrote:
Hi all,
Something is wrong with my IC-7000 or my LDG IT-100. It used to work very well before, but now I got this.  When I connect the LDG tuner with the cable to the IC-7000 the temperature indicator goes to maximum and ventilation starts. LDG tuner does not tune any more, the radio does not even recognize it. LDG tuner does not answer at all to any button push. ICOM radio works well...sensitivity is not affected...it even goes into TX wihout problems..except the temperature indicator.
Any idea about what can it be? IC-7000 seems to work very well without the tuner...and I wonder where is the problem

Aurelian - SA0CAN


Brian (N2MLP)
 

LDG IT-100

 

========================

         de N2MLP Brian

       Monroe County PA

 

 

========================

 

 

From: ic7000@groups.io [mailto:ic7000@groups.io] On Behalf Of aurelian.bria@...
Sent: Wednesday, March 28, 2018 8:03 AM
To: ic7000@groups.io
Subject: [ic7000] Ventilation starts and temperature shows maximum when I plug the LDG IT-100 #all

 

Hi all,
Something is wrong with my IC-7000 or my LDG IT-100. It used to work very well before, but now I got this.  When I connect the LDG tuner with the cable to the IC-7000 the temperature indicator goes to maximum and ventilation starts. LDG tuner does not tune any more, the radio does not even recognize it. LDG tuner does not answer at all to any button push. ICOM radio works well...sensitivity is not affected...it even goes into TX wihout problems..except the temperature indicator.
Any idea about what can it be? IC-7000 seems to work very well without the tuner...and I wonder where is the problem

Aurelian - SA0CAN


Steve Draper
 

I seem to recall that when the IC-7000 was released there was talk that the IC-7000 used the same data path/line for the tuner control and temperature control. I am guessing there is something wrong with the tuner internally that is pulling one of the lines high or low permanently which is fooling the IC-7000 temperature sensing circuitry. 

Steve VE7FM

On Wed, Mar 28, 2018 at 5:03 AM, <aurelian.bria@...> wrote:
Hi all,
Something is wrong with my IC-7000 or my LDG IT-100. It used to work very well before, but now I got this.  When I connect the LDG tuner with the cable to the IC-7000 the temperature indicator goes to maximum and ventilation starts. LDG tuner does not tune any more, the radio does not even recognize it. LDG tuner does not answer at all to any button push. ICOM radio works well...sensitivity is not affected...it even goes into TX wihout problems..except the temperature indicator.
Any idea about what can it be? IC-7000 seems to work very well without the tuner...and I wonder where is the problem

Aurelian - SA0CAN



Steve W3AHL
 

The problem you describe is caused by the tuner interface placing a voltage greater than 3.3 VDC on TUNER port pin 1, which is TKEY.  TKEY is clamped via two diodes to +3.3 VDC bus and to ground.  When TKEY signal is driven to a voltage greater than 3.3 VDC the 3 volt bus to the CPU is affected also which is connected to the CPU VREF pin, which results in an incorrect A/D converter output.  This causes the temperature gauge to read too high and the fan to turn on when it isn't really needed.

Something has failed on the IT-100's interface port.  LDG never provides schematics for their products, so unless you can find a short or damaged component by visual examination or with a meter, it may have to be returned to an LDG service center.  If you measure the voltage on TUNER port pin 1 to ground (pin 4), that should confirm if this is your problem.

Steve, W3AHL

Something is wrong with my IC-7000 or my LDG IT-100. It used to work very well before, but now I got this.  When I connect the LDG tuner with the cable to the IC-7000 the temperature indicator goes to maximum and ventilation starts. LDG tuner does not tune any more, the radio does not even recognize it. LDG tuner does not answer at all to any button push. ICOM radio works well...sensitivity is not affected...it even goes into TX wihout problems..except the temperature indicator.
Any idea about what can it be? IC-7000 seems to work very well without the tuner...and I wonder where is the problem

Aurelian - SA0CAN


Brent Hawks
 

Could it be the cable itself that's faulty?

On Wed, Mar 28, 2018 at 5:03 AM, <aurelian.bria@...> wrote:
Hi all,
Something is wrong with my IC-7000 or my LDG IT-100. It used to work very well before, but now I got this.  When I connect the LDG tuner with the cable to the IC-7000 the temperature indicator goes to maximum and ventilation starts. LDG tuner does not tune any more, the radio does not even recognize it. LDG tuner does not answer at all to any button push. ICOM radio works well...sensitivity is not affected...it even goes into TX wihout problems..except the temperature indicator.
Any idea about what can it be? IC-7000 seems to work very well without the tuner...and I wonder where is the problem

Aurelian - SA0CAN



m0wao
 

yeah, if i recall well the connector into the IT-100 is a small look like PS/2 keyboard / mouse plug easily damaged