Re: IC 7000 Quit - Now alive and well!

D C *Mac* Macdonald
 

I am reasonably sure that DX Engineering also carries it or at least a substitute.  You can also get it from Mosley antennas as they specify it for their antennas.
 
73 de Mac, K2GKK/5​
Since 30 Nov 1953​
Oklahoma City, OK​
USAF, Retired ('61-'81)​
FAA, Retired ('94-'10)


From: ic7000@groups.io <ic7000@groups.io> on behalf of Jim Szalajeski via Groups.Io <jimszal@...>
Sent: Friday, August 2, 2019 20:48
To: ic7000@groups.io <ic7000@groups.io>
Subject: Re: [ic7000] IC 7000 Quit - Now alive and well!
 
You might want to go to your electrical store, Lowe's and maybe Home Depot to see if they carry a grease used in the electrical field called Penetrox, made by Burndy.  It is sort of a copper black or so color.  If you get any on your fingers, it is hard to get it off.  It comes in a 4 oz. white squeeze container. 

I put it on any electrical connection that may get moisture on it.  it is also a good anti seize compound.  So it works just fine for battery connections. 

Jim 




On Friday, July 19, 2019, 8:58:05 AM CDT, Doug Neal <vo1.dwn@...> wrote:


Hi Everybody:
Thanks for all your input on this matter.
Sherlock Holmes once said: "when you've eliminated all other factors, the one that remains must be the truth" This is the case.here!
The battery terminals looked oK but that's where the problem lay.. If I had considered the
problem more, I might have concluded that since work was recently done on the car for an airbag safety recall the battery connections had been disturbed  It was a short time after that that the problem occurred. Meanwhile,  I now have nice clean fuse holders and corrections to the remote head. I even soldered the crimps inside the fuse holders, I didn't think anything was wrong with the way the crimp lugs were under the the bolts on the  battery clips, but when I finally took them off, what a mess underneath those nuts, it was something else. A quick cleaning did the trick. I'm surprised the car functioned at all, but it must have gotten connection on the underside of the metal plate, in my Toyota the battery has a clip around the post that comes out to a flat piece of metal, with a nut and bolt on it, there are three metal plates, stacked with various wires leaving them, while the top part is where the radio was connected it was not making connection there. Back up and running as of yesterday.
73 to all de Doug, Vo1DWN
 

Join ic7000@groups.io to automatically receive all group messages.