Topics

Version 4 error message


John, G4DRS
 

I see this error message:



when I start Logger32.

I have re-booted, but the error happened again.

What have I done wrong this time?


John
G4DRS


Bob
 

Well, as I recall, you had some finger trouble getting started, but finally got it working. So, what have you done between then and now? Been messing with your Cluster/Local host setup/configuration? Make a copy of your Logger32.INI file and hide it under the mattress.
 
Now, one by one delete these sections from the INI. Try to load Logger32 after each deletion.
 
[Local Host]
[wndClusterWindow Settings]
[Shortcuts]
 
If that doesn't work, delete the complete INI (your backup is under the mattress). 73.

On 01/20/2021 3:21 PM John, G4DRS via groups.io <g4drs@...> wrote:
 
 
I see this error message:



when I start Logger32.

I have re-booted, but the error happened again.

What have I done wrong this time?


John
G4DRS


John, G4DRS
 

On Wed, Jan 20, 2021 at 08:41 PM, Bob wrote:
Now, one by one delete these sections from the INI. Try to load Logger32 after each deletion.
 
[Local Host]
[wndClusterWindow Settings]
[Shortcuts]
Thanks, Bob.
Well, my Logger32.ini didn't have a [Local Host] section, or a [Shortcuts] section.
I deleted the [wndClusterWindow Settings] section.
No change.
(By the way, the program runs perfectly if I click 'OK' on the error message. It doesn't auto connect to the telnet node, but I presume that's because of the error.)
I closed the Cluster window inside Logger32, then closed Logger32. It restarted without complaint.
When, however, I asked it to open the Cluster window, it responded with that error message. I closed Logger32 again, then restarted it. The error message was back.
Next to try it the deletion...:(


John
G4DRS


John, G4DRS
 

On Wed, Jan 20, 2021 at 09:25 PM, John, G4DRS wrote:
It doesn't auto connect to the telnet node, but I presume that's because of the error.)
I tell a lie, it does if I wait a few more seconds.

Deleting the .ini file results in no error message. Not much in the way of settings, either, of course.
Reinstating the original .ini file reinstates the error. It's in there somewhere.


John
G4DRS


John, G4DRS
 

I tried re-sizing and moving the cluster window, and changing the remote host to a different one. No joy.


John
G4DRS


John, G4DRS
 

It's getting late now. I'll have another play tomorrow.


73


John
G4DRS


Bob
 

If clicking OK gets you past the error, then as a temporary measure, click VIEW and UNcheck ENABLE TRAPPING. This shouldtemporarily hide the error message. I have added additional error checking of the loading of all the menus for the Cluster Window. So, maybe after the next auto-update you can turn error trapping back on and we can zero in on the exact problem. 73.

On 01/20/2021 4:30 PM John, G4DRS via groups.io <g4drs@...> wrote:
 
 
On Wed, Jan 20, 2021 at 09:25 PM, John, G4DRS wrote:
It doesn't auto connect to the telnet node, but I presume that's because of the error.)
I tell a lie, it does if I wait a few more seconds.

Deleting the .ini file results in no error message. Not much in the way of settings, either, of course.
Reinstating the original .ini file reinstates the error. It's in there somewhere.


John
G4DRS


John, G4DRS
 

Great idea, Bob.

That is actually one of the things I messed with: I switched on enable trapping.
Maybe it's always done it...:)
I'm happy either to click past it or to disable trapping, if that 'fixes' it. If you need my files to help you track it down at any time in the future (when you've nothing better to do), you're very welcome
73

John
G4DRS