Topics

Using the Antenna ROTOR with JT modes.

Jim Hargrave
 

There is a lot of confusion surrounding what should have a simple solution.

 

Given:  The Logger32 Rotor  module does not know about JTDX/WSJT.  All Rotor setup is within Logger32.

 

To avoid more confusion, I will provide a  simple setup process for the rotor.

1)      Configure the Rotor module in Setup/Rotor/Setup rotator #1. Sample below is my setup’

 

Open Rotor port automatically,

Global capture,

3 second delay (for Callsign lookup) May vary, depends on lookup source/Internet connection/speed

 

2)      Tools/Setup bands and Modes: Rotor number is the rotor that is configured under Setup/Rotor #(x)

 

 

 

At this point, verify that the Rotor is operating as expected.

 

3)      Open the UDP port and select

 

 

With the above setup, the following things  happen.

a)      The selected FT program started by UDP selection

b)      Logger32 automatically closes the Logger32 radio port and switches radio control to the JT program.

c)       Logger32  re-opens the radio port when JTDX/wsjt-x is closed

d)      Logger32 maintains full control of the rotor.

 

e)      Callsign is placed in the Log Entry CALL field by any of following methods.

1)      Manual

2)      DX Spot selection

3)      UDP band map selection

4)      Cherry Picker selection

5)      JTDX/wsjt-x

f)       Following is initiated by bLogger32

1)      Callsign lookup in logbook/on-line as user configured.

2)      Bands & Mode chart scanned for Mode/Radio /Rotor options

 

Opening and closing JTDX/wsjt-x is accomplished from within the UDP Bandmap START/STOP options. This keeps all the changeover actions in sync.

 

I hope this helps de-mud the water.

 

Jim – w5ifp-

.

---------- Original Message ----------
From: Jim Cox <jcox123@...>
To: hamlogger@groups.io
Date: August 25, 2019 at 10:14 AM
Subject: Re: [hamlogger] rotor problem

Bob, I have the rotator box set ok in the band plan menu for FT8.  Strange behavior as sometimes the rotator will work ok but not when you click on a call in FT8 but will change directions when the station is first called and the xmitter keys..  This is evident also by the rotator debug screen.  All worked fine until a week or so ago when I first noticed this behavior.  Jim K4JAF

 

From: Bob

Sent: Sunday, August 25, 2019 8:55 AM

Subject: Re: [hamlogger] rotor problem

 

Click TOOLS | SETUP BANDS & MODES. You are now looking at your personalized BandPlan. Look at the FT4 and FT8 rows ... All the way over to the next to last column is where the Rotor # goes. No number = no rotor. So, when operating FT4 or FT8 the frequency changes to the appropriate row in the table. No number = no rotor.  SeventyThree(s).

On August 25, 2019 at 9:41 AM Jim Cox <jcox123@...> wrote:

I have been having this problem with the rotator --- not sure when it started, most of the time it will not work when going to JTDX but works fine outside of the program.  I can look at the rotator debug screen and no command is sent to the rotator itself from Logger32.  Again when a station is just selected from the spots screen within Logger32 it works FB.  Any ideas.  73s Jim K4JAF


 

Jim Cox
 

I see discrepancies in the actions of the rotator in JTDX here.  Using 2.0.1 rc115.
Scenarios:  1.  I click on spot in UDP map (monitoring with Rotator Debug Screen), nothing happens to rotator, then when xmitter is started because I double click on call in JTDX, the rotator will start to swing to correct position. 
Same as 1. above but nothing ever happens with rotator. 
Same as 1. above but rotator starts as soon as clicking on the spot even before double clicking in JTDX.
Same as 1, but rotator begins movement maybe on second time JTDX tries to call the spotted station. 
 
All of these actions are verified by rotator debug screen. 
 
I have everything apparently correct in band plan for rotator and frequency, mode, etc.  I use a 2 second delay in rotator screen. 
Any thoughts?   Jim K4JAF
 
 
 

From: Jim Hargrave
Sent: Monday, August 26, 2019 12:41 PM
To: hamlogger@groups.io
Subject: [hamlogger] Using the Antenna ROTOR with JT modes.
 

There is a lot of confusion surrounding what should have a simple solution.

 

Given:  The Logger32 Rotor  module does not know about JTDX/WSJT.  All Rotor setup is within Logger32.

 

To avoid more confusion, I will provide a  simple setup process for the rotor.

1)      Configure the Rotor module in Setup/Rotor/Setup rotator #1. Sample below is my setup’

 

Open Rotor port automatically,

Global capture,

3 second delay (for Callsign lookup) May vary, depends on lookup source/Internet connection/speed

 

2)      Tools/Setup bands and Modes: Rotor number is the rotor that is configured under Setup/Rotor #(x)

 

 

 

At this point, verify that the Rotor is operating as expected.

 

3)      Open the UDP port and select

 

 

With the above setup, the following things  happen.

a)      The selected FT program started by UDP selection

b)      Logger32 automatically closes the Logger32 radio port and switches radio control to the JT program.

c)       Logger32  re-opens the radio port when JTDX/wsjt-x is closed

d)      Logger32 maintains full control of the rotor.

 

e)      Callsign is placed in the Log Entry CALL field by any of following methods.

1)      Manual

2)      DX Spot selection

3)      UDP band map selection

4)      Cherry Picker selection

5)      JTDX/wsjt-x

f)       Following is initiated by bLogger32

1)      Callsign lookup in logbook/on-line as user configured.

2)      Bands & Mode chart scanned for Mode/Radio /Rotor options

 

Opening and closing JTDX/wsjt-x is accomplished from within the UDP Bandmap START/STOP options. This keeps all the changeover actions in sync.

 

I hope this helps de-mud the water.

 

Jim – w5ifp-

.

---------- Original Message ----------
From: Jim Cox <jcox123@...>
To: hamlogger@groups.io
Date: August 25, 2019 at 10:14 AM
Subject: Re: [hamlogger] rotor problem

Bob, I have the rotator box set ok in the band plan menu for FT8.  Strange behavior as sometimes the rotator will work ok but not when you click on a call in FT8 but will change directions when the station is first called and the xmitter keys..  This is evident also by the rotator debug screen.  All worked fine until a week or so ago when I first noticed this behavior.  Jim K4JAF

 

From: Bob

Sent: Sunday, August 25, 2019 8:55 AM

To: hamlogger@groups.io

Subject: Re: [hamlogger] rotor problem

 

Click TOOLS | SETUP BANDS & MODES. You are now looking at your personalized BandPlan. Look at the FT4 and FT8 rows ... All the way over to the next to last column is where the Rotor # goes. No number = no rotor. So, when operating FT4 or FT8 the frequency changes to the appropriate row in the table. No number = no rotor.  SeventyThree(s).

On August 25, 2019 at 9:41 AM Jim Cox <jcox123@...> wrote:

I have been having this problem with the rotator --- not sure when it started, most of the time it will not work when going to JTDX but works fine outside of the program.  I can look at the rotator debug screen and no command is sent to the rotator itself from Logger32.  Again when a station is just selected from the spots screen within Logger32 it works FB.  Any ideas.  73s Jim K4JAF


 

Jim Hargrave
 

Below is a Rotor option that I omitted in my previous e-mail. This is a user option that is also available with JT modes.

This is a desirable option which  reduces operator engagement. This is especially useful when in Cherry picking mode.

 

Right click the “Rotor” box on the lower status bar.

 

 

Note: Excessive use of this function may affect Rotor component reliability.

 

Jim – w5ifp-

 

From: hamlogger@groups.io [mailto:hamlogger@groups.io] On Behalf Of Jim Hargrave
Sent: Monday, August 26, 2019 12:42 PM
To: hamlogger@groups.io
Subject: [hamlogger] Using the Antenna ROTOR with JT modes.

 

There is a lot of confusion surrounding what should have a simple solution.

 

Given:  The Logger32 Rotor  module does not know about JTDX/WSJT.  All Rotor setup is within Logger32.

 

To avoid more confusion, I will provide a  simple setup process for the rotor.

1)      Configure the Rotor module in Setup/Rotor/Setup rotator #1. Sample below is my setup’

 

Open Rotor port automatically,

Global capture,

3 second delay (for Callsign lookup) May vary, depends on lookup source/Internet connection/speed

 

2)      Tools/Setup bands and Modes: Rotor number is the rotor that is configured under Setup/Rotor #(x)

 

 

 

At this point, verify that the Rotor is operating as expected.

 

3)      Open the UDP port and select

 

 

With the above setup, the following things  happen.

a)      The selected FT program started by UDP selection

b)      Logger32 automatically closes the Logger32 radio port and switches radio control to the JT program.

c)       Logger32  re-opens the radio port when JTDX/wsjt-x is closed

d)      Logger32 maintains full control of the rotor.

 

e)      Callsign is placed in the Log Entry CALL field by any of following methods.

1)      Manual

2)      DX Spot selection

3)      UDP band map selection

4)      Cherry Picker selection

5)      JTDX/wsjt-x

f)       Following is initiated by bLogger32

1)      Callsign lookup in logbook/on-line as user configured.

2)      Bands & Mode chart scanned for Mode/Radio /Rotor options

 

Opening and closing JTDX/wsjt-x is accomplished from within the UDP Bandmap START/STOP options. This keeps all the changeover actions in sync.

 

I hope this helps de-mud the water.

 

Jim – w5ifp-

.

---------- Original Message ----------
From: Jim Cox <jcox123@...>
To: hamlogger@groups.io
Date: August 25, 2019 at 10:14 AM
Subject: Re: [hamlogger] rotor problem

Bob, I have the rotator box set ok in the band plan menu for FT8.  Strange behavior as sometimes the rotator will work ok but not when you click on a call in FT8 but will change directions when the station is first called and the xmitter keys..  This is evident also by the rotator debug screen.  All worked fine until a week or so ago when I first noticed this behavior.  Jim K4JAF

 

From: Bob

Sent: Sunday, August 25, 2019 8:55 AM

Subject: Re: [hamlogger] rotor problem

 

Click TOOLS | SETUP BANDS & MODES. You are now looking at your personalized BandPlan. Look at the FT4 and FT8 rows ... All the way over to the next to last column is where the Rotor # goes. No number = no rotor. So, when operating FT4 or FT8 the frequency changes to the appropriate row in the table. No number = no rotor.  SeventyThree(s).

On August 25, 2019 at 9:41 AM Jim Cox <jcox123@...> wrote:

I have been having this problem with the rotator --- not sure when it started, most of the time it will not work when going to JTDX but works fine outside of the program.  I can look at the rotator debug screen and no command is sent to the rotator itself from Logger32.  Again when a station is just selected from the spots screen within Logger32 it works FB.  Any ideas.  73s Jim K4JAF


 

Jim Hargrave
 

Hi Jim,

 

I have not noted that condition. Give me some time to see if I can duplicate.

 

Jim – w5ifp-

 

From: hamlogger@groups.io [mailto:hamlogger@groups.io] On Behalf Of Jim Cox
Sent: Monday, August 26, 2019 4:30 PM
To: hamlogger@groups.io
Subject: Re: [hamlogger] Using the Antenna ROTOR with JT modes.

 

I see discrepancies in the actions of the rotator in JTDX here.  Using 2.0.1 rc115.

Scenarios:  1.  I click on spot in UDP map (monitoring with Rotator Debug Screen), nothing happens to rotator, then when xmitter is started because I double click on call in JTDX, the rotator will start to swing to correct position. 

Same as 1. above but nothing ever happens with rotator. 

Same as 1. above but rotator starts as soon as clicking on the spot even before double clicking in JTDX.

Same as 1, but rotator begins movement maybe on second time JTDX tries to call the spotted station. 

 

All of these actions are verified by rotator debug screen. 

 

I have everything apparently correct in band plan for rotator and frequency, mode, etc.  I use a 2 second delay in rotator screen. 

Any thoughts?   Jim K4JAF

 

 

 

From: Jim Hargrave

Sent: Monday, August 26, 2019 12:41 PM

To: hamlogger@groups.io

Subject: [hamlogger] Using the Antenna ROTOR with JT modes.

 

There is a lot of confusion surrounding what should have a simple solution.

 

Given:  The Logger32 Rotor  module does not know about JTDX/WSJT.  All Rotor setup is within Logger32.

 

To avoid more confusion, I will provide a  simple setup process for the rotor.

1)      Configure the Rotor module in Setup/Rotor/Setup rotator #1. Sample below is my setup’

 

Open Rotor port automatically,

Global capture,

3 second delay (for Callsign lookup) May vary, depends on lookup source/Internet connection/speed

 

2)      Tools/Setup bands and Modes: Rotor number is the rotor that is configured under Setup/Rotor #(x)

 

 

 

At this point, verify that the Rotor is operating as expected.

 

3)      Open the UDP port and select

 

Image removed by sender.

 

With the above setup, the following things  happen.

a)      The selected FT program started by UDP selection

b)      Logger32 automatically closes the Logger32 radio port and switches radio control to the JT program.

c)       Logger32  re-opens the radio port when JTDX/wsjt-x is closed

d)      Logger32 maintains full control of the rotor.

 

e)      Callsign is placed in the Log Entry CALL field by any of following methods.

1)      Manual

2)      DX Spot selection

3)      UDP band map selection

4)      Cherry Picker selection

5)      JTDX/wsjt-x

f)       Following is initiated by bLogger32

1)      Callsign lookup in logbook/on-line as user configured.

2)      Bands & Mode chart scanned for Mode/Radio /Rotor options

 

Opening and closing JTDX/wsjt-x is accomplished from within the UDP Bandmap START/STOP options. This keeps all the changeover actions in sync.

 

I hope this helps de-mud the water.

 

Jim – w5ifp-

.

---------- Original Message ----------
From: Jim Cox <jcox123@...>
To: hamlogger@groups.io
Date: August 25, 2019 at 10:14 AM
Subject: Re: [hamlogger] rotor problem

Bob, I have the rotator box set ok in the band plan menu for FT8.  Strange behavior as sometimes the rotator will work ok but not when you click on a call in FT8 but will change directions when the station is first called and the xmitter keys..  This is evident also by the rotator debug screen.  All worked fine until a week or so ago when I first noticed this behavior.  Jim K4JAF

 

From: Bob

Sent: Sunday, August 25, 2019 8:55 AM

To: hamlogger@groups.io

Subject: Re: [hamlogger] rotor problem

 

Click TOOLS | SETUP BANDS & MODES. You are now looking at your personalized BandPlan. Look at the FT4 and FT8 rows ... All the way over to the next to last column is where the Rotor # goes. No number = no rotor. So, when operating FT4 or FT8 the frequency changes to the appropriate row in the table. No number = no rotor.  SeventyThree(s).

On August 25, 2019 at 9:41 AM Jim Cox <jcox123@...> wrote:

I have been having this problem with the rotator --- not sure when it started, most of the time it will not work when going to JTDX but works fine outside of the program.  I can look at the rotator debug screen and no command is sent to the rotator itself from Logger32.  Again when a station is just selected from the spots screen within Logger32 it works FB.  Any ideas.  73s Jim K4JAF


 

Jim Cox
 

OK, I can duplicate this here just about al the time..  I did not have any of this several weeks ago.   JTDX has worked beautifully for many months before these problems arose..   Again as others have said the rotator function works FB if I clock on a spot from the DX spots screen or if I manually click on the Tracking Window.  73s Jim K4JAF
 

From: Jim Hargrave
Sent: Monday, August 26, 2019 4:59 PM
To: hamlogger@groups.io
Subject: Re: [hamlogger] Using the Antenna ROTOR with JT modes.
 

Hi Jim,

 

I have not noted that condition. Give me some time to see if I can duplicate.

 

Jim – w5ifp-

 

From: hamlogger@groups.io [mailto:hamlogger@groups.io] On Behalf Of Jim Cox
Sent: Monday, August 26, 2019 4:30 PM
To: hamlogger@groups.io
Subject: Re: [hamlogger] Using the Antenna ROTOR with JT modes.

 

I see discrepancies in the actions of the rotator in JTDX here.  Using 2.0.1 rc115.

Scenarios:  1.  I click on spot in UDP map (monitoring with Rotator Debug Screen), nothing happens to rotator, then when xmitter is started because I double click on call in JTDX, the rotator will start to swing to correct position. 

Same as 1. above but nothing ever happens with rotator. 

Same as 1. above but rotator starts as soon as clicking on the spot even before double clicking in JTDX.

Same as 1, but rotator begins movement maybe on second time JTDX tries to call the spotted station. 

 

All of these actions are verified by rotator debug screen. 

 

I have everything apparently correct in band plan for rotator and frequency, mode, etc.  I use a 2 second delay in rotator screen. 

Any thoughts?   Jim K4JAF

 

 

 

From: Jim Hargrave

Sent: Monday, August 26, 2019 12:41 PM

To: hamlogger@groups.io

Subject: [hamlogger] Using the Antenna ROTOR with JT modes.

 

There is a lot of confusion surrounding what should have a simple solution.

 

Given:  The Logger32 Rotor  module does not know about JTDX/WSJT.  All Rotor setup is within Logger32.

 

To avoid more confusion, I will provide a  simple setup process for the rotor.

1)      Configure the Rotor module in Setup/Rotor/Setup rotator #1. Sample below is my setup’

 

Open Rotor port automatically,

Global capture,

3 second delay (for Callsign lookup) May vary, depends on lookup source/Internet connection/speed

 

2)      Tools/Setup bands and Modes: Rotor number is the rotor that is configured under Setup/Rotor #(x)

 

 

 

At this point, verify that the Rotor is operating as expected.

 

3)      Open the UDP port and select

 

Image removed by sender.

 

With the above setup, the following things  happen.

a)      The selected FT program started by UDP selection

b)      Logger32 automatically closes the Logger32 radio port and switches radio control to the JT program.

c)       Logger32  re-opens the radio port when JTDX/wsjt-x is closed

d)      Logger32 maintains full control of the rotor.

 

e)      Callsign is placed in the Log Entry CALL field by any of following methods.

1)      Manual

2)      DX Spot selection

3)      UDP band map selection

4)      Cherry Picker selection

5)      JTDX/wsjt-x

f)       Following is initiated by bLogger32

1)      Callsign lookup in logbook/on-line as user configured.

2)      Bands & Mode chart scanned for Mode/Radio /Rotor options

 

Opening and closing JTDX/wsjt-x is accomplished from within the UDP Bandmap START/STOP options. This keeps all the changeover actions in sync.

 

I hope this helps de-mud the water.

 

Jim – w5ifp-

.

---------- Original Message ----------
From: Jim Cox <jcox123@...>
To: hamlogger@groups.io
Date: August 25, 2019 at 10:14 AM
Subject: Re: [hamlogger] rotor problem

Bob, I have the rotator box set ok in the band plan menu for FT8.  Strange behavior as sometimes the rotator will work ok but not when you click on a call in FT8 but will change directions when the station is first called and the xmitter keys.  This is evident also by the rotator debug screen.  All worked fine until a week or so ago when I first noticed this behavior.  Jim K4JAF

 

From: Bob

Sent: Sunday, August 25, 2019 8:55 AM

To: hamlogger@groups.io

Subject: Re: [hamlogger] rotor problem

 

Click TOOLS | SETUP BANDS & MODES. You are now looking at your personalized BandPlan. Look at the FT4 and FT8 rows ... All the way over to the next to last column is where the Rotor # goes. No number = no rotor. So, when operating FT4 or FT8 the frequency changes to the appropriate row in the table. No number = no rotor.  SeventyThree(s).

On August 25, 2019 at 9:41 AM Jim Cox <jcox123@...> wrote:

I have been having this problem with the rotator --- not sure when it started, most of the time it will not work when going to JTDX but works fine outside of the program.  I can look at the rotator debug screen and no command is sent to the rotator itself from Logger32.  Again when a station is just selected from the spots screen within Logger32 it works FB.  Any ideas.  73s Jim K4JAF