Topics

Program loses frequency and a lag on entering callsigns


Ron Stone
 

Greetings.

I'm using L32 version 3.50.422. CAT control is via a IC7300. Correct frequency is shown in the entry window but often it is sporadically lost and replaced with 0.00,  then switches back to the correct frequency. If there is a call in the entry window it is lost.

Additionally, typing any call into the entry window incurs a significant lag. For instance typing GW3YDX takes four seconds to appear after the G is entered. There is nothing gobbling memory from the PC. Neither of these issues are RF-related as they both occur during both RX and TX periods. Neither of these issues occur when I use N1MM+ for contesting. PC is a Windows 7 machine but it is stable and responsive with all other programs.

This issue is only evident in Logger32 and I would dearly love it if someone can suggest a fix, thanks.

73 and stay safe
Ron GW3YDX


Bob
 

Ron, my first suggestion is to recommend you use a program that works for you. But, seeing as many thousands of Logger32 users have no problem with CAT control (and hundreds using IC7300s), maybe you'd like to do some experimentation to resolve your problems ...

My SWAG at why the CAT fails periodically is that you have the polling interval too short. Click SETUP | RADIO | RADIO 1 CONFIGURATION. A rhetorical question - What is the polling interval? Add 100ms and try that for a while. If that resolves the problem, reduce it by 25ms. Experiment until you get a reliable configuration. Other than that, you could open the Radio debug window (Right click on the RADIO pane on the bottom status bar, then click SHOW RADIO DEBUG WINDOW. There is a goldmine of information now waiting to be interpreted.

In regard to your high speed keyboard. You said: typing any call into the entry window incurs a significant lag. For instance typing GW3YDX takes four seconds to appear after the G is entered ... Aren't you the lucky one. I tried it here. I typed G and waited for 10 seconds, but nothing happened. Then I thought maybe because my call is K4CY I should type K and wait 10 seconds? Nope, still nothing happens. Maybe you could try to explain your observations in a way I could attempt to duplicate.

SeventyThree(s).

On 09/11/2020 5:28 PM Ron Stone via groups.io <gw3ydx@...> wrote:


Greetings.

I'm using L32 version 3.50.422. CAT control is via a IC7300. Correct frequency is shown in the entry window but often it is sporadically lost and replaced with 0.00,  then switches back to the correct frequency. If there is a call in the entry window it is lost.

Additionally, typing any call into the entry window incurs a significant lag. For instance typing GW3YDX takes four seconds to appear after the G is entered. There is nothing gobbling memory from the PC. Neither of these issues are RF-related as they both occur during both RX and TX periods. Neither of these issues occur when I use N1MM+ for contesting. PC is a Windows 7 machine but it is stable and responsive with all other programs.

This issue is only evident in Logger32 and I would dearly love it if someone can suggest a fix, thanks.

73 and stay safe
Ron GW3YDX


Bob
 

... and, to make sure your settings are all correct, hopefully someone with an IC7300 will post a picture of their configuration window. 73.

On 09/11/2020 5:46 PM Bob <k4cy@...> wrote:


Ron, my first suggestion is to recommend you use a program that works for you. But, seeing as many thousands of Logger32 users have no problem with CAT control (and hundreds using IC7300s), maybe you'd like to do some experimentation to resolve your problems ...

My SWAG at why the CAT fails periodically is that you have the polling interval too short. Click SETUP | RADIO | RADIO 1 CONFIGURATION. A rhetorical question - What is the polling interval? Add 100ms and try that for a while. If that resolves the problem, reduce it by 25ms. Experiment until you get a reliable configuration. Other than that, you could open the Radio debug window (Right click on the RADIO pane on the bottom status bar, then click SHOW RADIO DEBUG WINDOW. There is a goldmine of information now waiting to be interpreted.

In regard to your high speed keyboard. You said: typing any call into the entry window incurs a significant lag. For instance typing GW3YDX takes four seconds to appear after the G is entered ... Aren't you the lucky one. I tried it here. I typed G and waited for 10 seconds, but nothing happened. Then I thought maybe because my call is K4CY I should type K and wait 10 seconds? Nope, still nothing happens. Maybe you could try to explain your observations in a way I could attempt to duplicate.

SeventyThree(s).
On 09/11/2020 5:28 PM Ron Stone via groups.io <gw3ydx@...> wrote:


Greetings.

I'm using L32 version 3.50.422. CAT control is via a IC7300. Correct frequency is shown in the entry window but often it is sporadically lost and replaced with 0.00,  then switches back to the correct frequency. If there is a call in the entry window it is lost.

Additionally, typing any call into the entry window incurs a significant lag. For instance typing GW3YDX takes four seconds to appear after the G is entered. There is nothing gobbling memory from the PC. Neither of these issues are RF-related as they both occur during both RX and TX periods. Neither of these issues occur when I use N1MM+ for contesting. PC is a Windows 7 machine but it is stable and responsive with all other programs.

This issue is only evident in Logger32 and I would dearly love it if someone can suggest a fix, thanks.

73 and stay safe
Ron GW3YDX


Bob
 

...but wait. I checked the help file. I see this for IC-7300 menu settings:

Select Set/Connectors and set following items.
ACC/USB Output Select: AF
ACC/USB AF Output Level: 20%
ACC/USB AF SQL: OFF
ACC/USB AF Beep/Speech Output: OFF
USB MOD level: 50%
DATA OFF MOD: MIC
DATA MOD: USB

Select Set/Connectors/CI-V and set following items.
CI-V address: 94h
CI-V Transceive: OFF
CI-V USB->Remote Transceive address: 94h
CI-V Output (for ANT) : OFF
CI-V USB Port: Unlink from [Remote]
CI-V USB Baud Rate: 115200
CI-V USB Echo Back: ON

I see this for Logger32 settings:


73.

On 09/11/2020 5:53 PM Bob <k4cy@...> wrote:


... and, to make sure your settings are all correct, hopefully someone with an IC7300 will post a picture of their configuration window. 73.
On 09/11/2020 5:46 PM Bob <k4cy@...> wrote:


Ron, my first suggestion is to recommend you use a program that works for you. But, seeing as many thousands of Logger32 users have no problem with CAT control (and hundreds using IC7300s), maybe you'd like to do some experimentation to resolve your problems ...

My SWAG at why the CAT fails periodically is that you have the polling interval too short. Click SETUP | RADIO | RADIO 1 CONFIGURATION. A rhetorical question - What is the polling interval? Add 100ms and try that for a while. If that resolves the problem, reduce it by 25ms. Experiment until you get a reliable configuration. Other than that, you could open the Radio debug window (Right click on the RADIO pane on the bottom status bar, then click SHOW RADIO DEBUG WINDOW. There is a goldmine of information now waiting to be interpreted.

In regard to your high speed keyboard. You said: typing any call into the entry window incurs a significant lag. For instance typing GW3YDX takes four seconds to appear after the G is entered ... Aren't you the lucky one. I tried it here. I typed G and waited for 10 seconds, but nothing happened. Then I thought maybe because my call is K4CY I should type K and wait 10 seconds? Nope, still nothing happens. Maybe you could try to explain your observations in a way I could attempt to duplicate.

SeventyThree(s).
On 09/11/2020 5:28 PM Ron Stone via groups.io <gw3ydx@...> wrote:


Greetings.

I'm using L32 version 3.50.422. CAT control is via a IC7300. Correct frequency is shown in the entry window but often it is sporadically lost and replaced with 0.00,  then switches back to the correct frequency. If there is a call in the entry window it is lost.

Additionally, typing any call into the entry window incurs a significant lag. For instance typing GW3YDX takes four seconds to appear after the G is entered. There is nothing gobbling memory from the PC. Neither of these issues are RF-related as they both occur during both RX and TX periods. Neither of these issues occur when I use N1MM+ for contesting. PC is a Windows 7 machine but it is stable and responsive with all other programs.

This issue is only evident in Logger32 and I would dearly love it if someone can suggest a fix, thanks.

73 and stay safe
Ron GW3YDX


ja1nlx
 

Sample picture is in the IC-7300 section in Logger32 Help.

73

On 2020/09/12 6:53, Bob wrote:
... and, to make sure your settings are all correct, hopefully someone with an IC7300 will post a picture of their configuration window. 73.
On 09/11/2020 5:46 PM Bob <k4cy@...> wrote:


Ron, my first suggestion is to recommend you use a program that works for you. But, seeing as many thousands of Logger32 users have no problem with CAT control (and hundreds using IC7300s), maybe you'd like to do some experimentation to resolve your problems ...

My SWAG at why the CAT fails periodically is that you have the polling interval too short. Click SETUP | RADIO | RADIO 1 CONFIGURATION. A rhetorical question - What is the polling interval? Add 100ms and try that for a while. If that resolves the problem, reduce it by 25ms. Experiment until you get a reliable configuration. Other than that, you could open the Radio debug window (Right click on the RADIO pane on the bottom status bar, then click SHOW RADIO DEBUG WINDOW. There is a goldmine of information now waiting to be interpreted.

In regard to your high speed keyboard. You said: typing any call into the entry window incurs a significant lag. For instance typing GW3YDX takes four seconds to appear after the G is entered ... Aren't you the lucky one. I tried it here. I typed G and waited for 10 seconds, but nothing happened. Then I thought maybe because my call is K4CY I should type K and wait 10 seconds? Nope, still nothing happens. Maybe you could try to explain your observations in a way I could attempt to duplicate.

SeventyThree(s).
On 09/11/2020 5:28 PM Ron Stone via groups.io <gw3ydx@...> wrote:


Greetings.

I'm using L32 version 3.50.422. CAT control is via a IC7300. Correct frequency is shown in the entry window but often it is sporadically lost and replaced with 0.00,  then switches back to the correct frequency. If there is a call in the entry window it is lost.

Additionally, typing any call into the entry window incurs a significant lag. For instance typing GW3YDX takes four seconds to appear after the G is entered. There is nothing gobbling memory from the PC. Neither of these issues are RF-related as they both occur during both RX and TX periods. Neither of these issues occur when I use N1MM+ for contesting. PC is a Windows 7 machine but it is stable and responsive with all other programs.

This issue is only evident in Logger32 and I would dearly love it if someone can suggest a fix, thanks.

73 and stay safe
Ron GW3YDX
--
73 de aki
JA1NLX


NICK K. PLUMIDAKIS
 

Dear Ron Hi.

I am using the 7300 as my primary radio with L32 and microKEYER II and is working fantastic.

Best 73’s

DE

Nick

SV1VS

 

From: hamlogger@groups.io [mailto:hamlogger@groups.io] On Behalf Of ja1nlx
Sent: Saturday, 12 September, 2020 1:03
To: hamlogger@groups.io
Subject: Re: [hamlogger] Program loses frequency and a lag on entering callsigns

 

Sample picture is in the IC-7300 section in Logger32 Help.

73

On 2020/09/12 6:53, Bob wrote:

... and, to make sure your settings are all correct, hopefully someone with an IC7300 will post a picture of their configuration window. 73.

On 09/11/2020 5:46 PM Bob <k4cy@...> wrote:

 

 

Ron, my first suggestion is to recommend you use a program that works for you. But, seeing as many thousands of Logger32 users have no problem with CAT control (and hundreds using IC7300s), maybe you'd like to do some experimentation to resolve your problems ...

 

My SWAG at why the CAT fails periodically is that you have the polling interval too short. Click SETUP | RADIO | RADIO 1 CONFIGURATION. A rhetorical question - What is the polling interval? Add 100ms and try that for a while. If that resolves the problem, reduce it by 25ms. Experiment until you get a reliable configuration. Other than that, you could open the Radio debug window (Right click on the RADIO pane on the bottom status bar, then click SHOW RADIO DEBUG WINDOW. There is a goldmine of information now waiting to be interpreted.

 

In regard to your high speed keyboard. You said: typing any call into the entry window incurs a significant lag. For instance typing GW3YDX takes four seconds to appear after the G is entered ... Aren't you the lucky one. I tried it here. I typed G and waited for 10 seconds, but nothing happened. Then I thought maybe because my call is K4CY I should type K and wait 10 seconds? Nope, still nothing happens. Maybe you could try to explain your observations in a way I could attempt to duplicate.

 

SeventyThree(s).

On 09/11/2020 5:28 PM Ron Stone via groups.io <gw3ydx@...> wrote:

 

 

Greetings.

 

I'm using L32 version 3.50.422. CAT control is via a IC7300. Correct frequency is shown in the entry window but often it is sporadically lost and replaced with 0.00,  then switches back to the correct frequency. If there is a call in the entry window it is lost.

 

Additionally, typing any call into the entry window incurs a significant lag. For instance typing GW3YDX takes four seconds to appear after the G is entered. There is nothing gobbling memory from the PC. Neither of these issues are RF-related as they both occur during both RX and TX periods. Neither of these issues occur when I use N1MM+ for contesting. PC is a Windows 7 machine but it is stable and responsive with all other programs.

 

This issue is only evident in Logger32 and I would dearly love it if someone can suggest a fix, thanks.

 

73 and stay safe

Ron GW3YDX

--
73 de aki
JA1NLX


Ron Stone
 

Hi Bob

Not to imply that your program isnt the best there is..... ! I have been using it since 1995 - that's an excellent 25 years - and only recently have I run into problems with it. So
do please accept my thanks for it. Freeware and great support ? Not many others like that so you can be very proud of it.

Regarding the entry of calls into the logbook entry window, previously instantaneous, so I rolled back to 3.50.394 and hey now the calls go in there fast again. No more lag
at all !. Then I uploaded 422 again and now the calls go in just as fast. Surely one for "Go figure...." I have checked the radio settings as you suggest.
Not possible in the IC7300 menus to go above 19200 baud so I have left it at 9600 where it was. Putting CI-V transceive
to OFF (I had it ON) resulted in no frequency change on VFO movement so I changed it back to ON and it is responding to QSY's again. I have tried playing with all settings
of polling times and nothing makes any difference. Used the radio debug window and indeed the frequency went to 0.00 when the prog lost the frequency. I have attached
a screen dump of when it happened. So the loss of frequency still happens very often unfortunately.

Now hear this.. Tried my W10 laptop and no prob with call entries or frequency. Everything stable. So I suppose the next step - taken reluctantly as I really dont like W10- is
to upgrade my W7 machine to W10. I've ordered a large thumb drive to back everything up and then will try again.

Others commenting. Thanks but are you using W7 or W10 please ?

73 and thanks again for your help. Stay safe

Ron


Bob
 

As I don't have an IC-7300, I leave it to those that do to walk you through the settings. 73

On 09/12/2020 9:30 AM Ron Stone via groups.io <gw3ydx@...> wrote:


Hi Bob

Not to imply that your program isnt the best there is..... ! I have been using it since 1995 - that's an excellent 25 years - and only recently have I run into problems with it. So
do please accept my thanks for it. Freeware and great support ? Not many others like that so you can be very proud of it.

Regarding the entry of calls into the logbook entry window, previously instantaneous, so I rolled back to 3.50.394 and hey now the calls go in there fast again. No more lag
at all !. Then I uploaded 422 again and now the calls go in just as fast. Surely one for "Go figure...." I have checked the radio settings as you suggest.
Not possible in the IC7300 menus to go above 19200 baud so I have left it at 9600 where it was. Putting CI-V transceive
to OFF (I had it ON) resulted in no frequency change on VFO movement so I changed it back to ON and it is responding to QSY's again. I have tried playing with all settings
of polling times and nothing makes any difference. Used the radio debug window and indeed the frequency went to 0.00 when the prog lost the frequency. I have attached
a screen dump of when it happened. So the loss of frequency still happens very often unfortunately.

Now hear this.. Tried my W10 laptop and no prob with call entries or frequency. Everything stable. So I suppose the next step - taken reluctantly as I really dont like W10- is
to upgrade my W7 machine to W10. I've ordered a large thumb drive to back everything up and then will try again.

Others commenting. Thanks but are you using W7 or W10 please ?

73 and thanks again for your help. Stay safe

Ron


Jan
 

Hi Ron

My 7300 shows in the CI-V USB Baud Rate a maximum setting of 115200 which I use with Logger32.
You said yours is not going above 19200 but you use 9600.
Why not use 19200??

73
Jan
PA4JJ



Op 12-9-2020 om 15:30 schreef Ron Stone via groups.io:
Hi Bob

Not to imply that your program isnt the best there is..... ! I have been using it since 1995 - that's an excellent 25 years - and only recently have I run into problems with it. So
do please accept my thanks for it. Freeware and great support ? Not many others like that so you can be very proud of it.

Regarding the entry of calls into the logbook entry window, previously instantaneous, so I rolled back to 3.50.394 and hey now the calls go in there fast again. No more lag
at all !. Then I uploaded 422 again and now the calls go in just as fast. Surely one for "Go figure...." I have checked the radio settings as you suggest.
Not possible in the IC7300 menus to go above 19200 baud so I have left it at 9600 where it was. Putting CI-V transceive
to OFF (I had it ON) resulted in no frequency change on VFO movement so I changed it back to ON and it is responding to QSY's again. I have tried playing with all settings
of polling times and nothing makes any difference. Used the radio debug window and indeed the frequency went to 0.00 when the prog lost the frequency. I have attached
a screen dump of when it happened. So the loss of frequency still happens very often unfortunately.

Now hear this.. Tried my W10 laptop and no prob with call entries or frequency. Everything stable. So I suppose the next step - taken reluctantly as I really dont like W10- is
to upgrade my W7 machine to W10. I've ordered a large thumb drive to back everything up and then will try again.

Others commenting. Thanks but are you using W7 or W10 please ?

73 and thanks again for your help. Stay safe

Ron

-- 
____________________________________________________
my dxspider clusters running on a raspberry pi:  
pa4jj-2 83.162.186.242 port 7300
pa4jj-3 83.162.186.242 port 7388


Michael Buckle
 

I have checked my ICOM 7610, I know it's not a IC7300 but I wonder if the Baud rate settings are the same in as much as:

There are two Baud Rate settings on the CI-V menu:

  1. CI-V Auto (As you say will not go above 19200)
  2. CI-V USB 38400

I suggest you just check the IC 7300 to ascertain these settings?

On 12/09/2020 15:38, Jan wrote:
Hi Ron

My 7300 shows in the CI-V USB Baud Rate a maximum setting of 115200 which I use with Logger32.
You said yours is not going above 19200 but you use 9600.
Why not use 19200??

73
Jan
PA4JJ



Op 12-9-2020 om 15:30 schreef Ron Stone via groups.io:
Hi Bob

Not to imply that your program isnt the best there is..... ! I have been using it since 1995 - that's an excellent 25 years - and only recently have I run into problems with it. So
do please accept my thanks for it. Freeware and great support ? Not many others like that so you can be very proud of it.

Regarding the entry of calls into the logbook entry window, previously instantaneous, so I rolled back to 3.50.394 and hey now the calls go in there fast again. No more lag
at all !. Then I uploaded 422 again and now the calls go in just as fast. Surely one for "Go figure...." I have checked the radio settings as you suggest.
Not possible in the IC7300 menus to go above 19200 baud so I have left it at 9600 where it was. Putting CI-V transceive
to OFF (I had it ON) resulted in no frequency change on VFO movement so I changed it back to ON and it is responding to QSY's again. I have tried playing with all settings
of polling times and nothing makes any difference. Used the radio debug window and indeed the frequency went to 0.00 when the prog lost the frequency. I have attached
a screen dump of when it happened. So the loss of frequency still happens very often unfortunately.

Now hear this.. Tried my W10 laptop and no prob with call entries or frequency. Everything stable. So I suppose the next step - taken reluctantly as I really dont like W10- is
to upgrade my W7 machine to W10. I've ordered a large thumb drive to back everything up and then will try again.

Others commenting. Thanks but are you using W7 or W10 please ?

73 and thanks again for your help. Stay safe

Ron

-- 
____________________________________________________
my dxspider clusters running on a raspberry pi:  
pa4jj-2 83.162.186.242 port 7300
pa4jj-3 83.162.186.242 port 7388


Dave Colliau
 

19200 fixed works fine. I never use auto . I have my polling set to 50ms also
Dave N8DC

On 09/12/2020 2:37 PM Michael Buckle via groups.io <mikejohnb@...> wrote:


I have checked my ICOM 7610, I know it's not a IC7300 but I wonder if the Baud rate settings are the same in as much as:

There are two Baud Rate settings on the CI-V menu:

  1. CI-V Auto (As you say will not go above 19200)
  2. CI-V USB 38400

I suggest you just check the IC 7300 to ascertain these settings?

On 12/09/2020 15:38, Jan wrote:
Hi Ron

My 7300 shows in the CI-V USB Baud Rate a maximum setting of 115200 which I use with Logger32.
You said yours is not going above 19200 but you use 9600.
Why not use 19200??

73
Jan
PA4JJ



Op 12-9-2020 om 15:30 schreef Ron Stone via groups.io:
Hi Bob

Not to imply that your program isnt the best there is..... ! I have been using it since 1995 - that's an excellent 25 years - and only recently have I run into problems with it. So
do please accept my thanks for it. Freeware and great support ? Not many others like that so you can be very proud of it.

Regarding the entry of calls into the logbook entry window, previously instantaneous, so I rolled back to 3.50.394 and hey now the calls go in there fast again. No more lag
at all !. Then I uploaded 422 again and now the calls go in just as fast. Surely one for "Go figure...." I have checked the radio settings as you suggest.
Not possible in the IC7300 menus to go above 19200 baud so I have left it at 9600 where it was. Putting CI-V transceive
to OFF (I had it ON) resulted in no frequency change on VFO movement so I changed it back to ON and it is responding to QSY's again. I have tried playing with all settings
of polling times and nothing makes any difference. Used the radio debug window and indeed the frequency went to 0.00 when the prog lost the frequency. I have attached
a screen dump of when it happened. So the loss of frequency still happens very often unfortunately.

Now hear this.. Tried my W10 laptop and no prob with call entries or frequency. Everything stable. So I suppose the next step - taken reluctantly as I really dont like W10- is
to upgrade my W7 machine to W10. I've ordered a large thumb drive to back everything up and then will try again.

Others commenting. Thanks but are you using W7 or W10 please ?

73 and thanks again for your help. Stay safe

Ron

-- 
____________________________________________________
my dxspider clusters running on a raspberry pi:  
pa4jj-2 83.162.186.242 port 7300
pa4jj-3 83.162.186.242 port 7388


Michael Buckle
 

sorry should have been:

  1. CI-V Baud Rate mine is set to Auto (As you say it will not go above 19200)
  2. CI-V USB 38400 (Will go to 115200)

In the manual, it states that you shouldn't push it above a certain level but I cant remember that suggestion now?

On 12/09/2020 19:37, Michael Buckle via groups.io wrote:

I have checked my ICOM 7610, I know it's not a IC7300 but I wonder if the Baud rate settings are the same in as much as:

There are two Baud Rate settings on the CI-V menu:

  1. CI-V Auto (As you say will not go above 19200)
  2. CI-V USB 38400

I suggest you just check the IC 7300 to ascertain these settings?

On 12/09/2020 15:38, Jan wrote:
Hi Ron

My 7300 shows in the CI-V USB Baud Rate a maximum setting of 115200 which I use with Logger32.
You said yours is not going above 19200 but you use 9600.
Why not use 19200??

73
Jan
PA4JJ



Op 12-9-2020 om 15:30 schreef Ron Stone via groups.io:
Hi Bob

Not to imply that your program isnt the best there is..... ! I have been using it since 1995 - that's an excellent 25 years - and only recently have I run into problems with it. So
do please accept my thanks for it. Freeware and great support ? Not many others like that so you can be very proud of it.

Regarding the entry of calls into the logbook entry window, previously instantaneous, so I rolled back to 3.50.394 and hey now the calls go in there fast again. No more lag
at all !. Then I uploaded 422 again and now the calls go in just as fast. Surely one for "Go figure...." I have checked the radio settings as you suggest.
Not possible in the IC7300 menus to go above 19200 baud so I have left it at 9600 where it was. Putting CI-V transceive
to OFF (I had it ON) resulted in no frequency change on VFO movement so I changed it back to ON and it is responding to QSY's again. I have tried playing with all settings
of polling times and nothing makes any difference. Used the radio debug window and indeed the frequency went to 0.00 when the prog lost the frequency. I have attached
a screen dump of when it happened. So the loss of frequency still happens very often unfortunately.

Now hear this.. Tried my W10 laptop and no prob with call entries or frequency. Everything stable. So I suppose the next step - taken reluctantly as I really dont like W10- is
to upgrade my W7 machine to W10. I've ordered a large thumb drive to back everything up and then will try again.

Others commenting. Thanks but are you using W7 or W10 please ?

73 and thanks again for your help. Stay safe

Ron

-- 
____________________________________________________
my dxspider clusters running on a raspberry pi:  
pa4jj-2 83.162.186.242 port 7300
pa4jj-3 83.162.186.242 port 7388


Jim Hargrave
 

Let me offer some input to this discussion.

Instead of analyzing every bodies radio setup, to see who’s computer is fastest, I suggest you configure a basic radio interface.

 

Try the following suggestions for starters.

 

1)      Suggest setting Radio Baud rate to 9600 FIXED” Rate. “Never use AUTO”.

2)      Set Logger32 to the same rate

3)       Set Polling interval to “500”.

4)      Set/verify  Icom address Is the same in Logger32 and Radio.

5)      Set Stop bits to “2”

6)      Set Computer port “Sleep time” to “NEVER” .

 

These settings should result in solid communications between radio and computer/Logger32.

 

The main objective is to getting them talking , without burning rubber.

 

 

Jim – w5ifp-

 

From: hamlogger@groups.io [mailto:hamlogger@groups.io] On Behalf Of Michael Buckle via groups.io
Sent: Saturday, September 12, 2020 1:42 PM
To: hamlogger@groups.io
Subject: Re: [hamlogger] Program loses frequency and a lag on entering callsigns

 

sorry should have been:

  1. CI-V Baud Rate mine is set to Auto (As you say it will not go above 19200)
  2. CI-V USB 38400 (Will go to 115200)

In the manual, it states that you shouldn't push it above a certain level but I cant remember that suggestion now?

On 12/09/2020 19:37, Michael Buckle via groups.io wrote:

I have checked my ICOM 7610, I know it's not a IC7300 but I wonder if the Baud rate settings are the same in as much as:

There are two Baud Rate settings on the CI-V menu:

  1. CI-V Auto (As you say will not go above 19200)
  2. CI-V USB 38400

I suggest you just check the IC 7300 to ascertain these settings?

On 12/09/2020 15:38, Jan wrote:

Hi Ron

My 7300 shows in the CI-V USB Baud Rate a maximum setting of 115200 which I use with Logger32.
You said yours is not going above 19200 but you use 9600.
Why not use 19200??

73
Jan
PA4JJ


Op 12-9-2020 om 15:30 schreef Ron Stone via groups.io:

Hi Bob

Not to imply that your program isnt the best there is..... ! I have been using it since 1995 - that's an excellent 25 years - and only recently have I run into problems with it. So
do please accept my thanks for it. Freeware and great support ? Not many others like that so you can be very proud of it.

Regarding the entry of calls into the logbook entry window, previously instantaneous, so I rolled back to 3.50.394 and hey now the calls go in there fast again. No more lag
at all !. Then I uploaded 422 again and now the calls go in just as fast. Surely one for "Go figure...." I have checked the radio settings as you suggest.
Not possible in the IC7300 menus to go above 19200 baud so I have left it at 9600 where it was. Putting CI-V transceive
to OFF (I had it ON) resulted in no frequency change on VFO movement so I changed it back to ON and it is responding to QSY's again. I have tried playing with all settings
of polling times and nothing makes any difference. Used the radio debug window and indeed the frequency went to 0.00 when the prog lost the frequency. I have attached
a screen dump of when it happened. So the loss of frequency still happens very often unfortunately.

Now hear this.. Tried my W10 laptop and no prob with call entries or frequency. Everything stable. So I suppose the next step - taken reluctantly as I really dont like W10- is
to upgrade my W7 machine to W10. I've ordered a large thumb drive to back everything up and then will try again.

Others commenting. Thanks but are you using W7 or W10 please ?

73 and thanks again for your help. Stay safe

Ron



-- 
____________________________________________________
my dxspider clusters running on a raspberry pi:  
pa4jj-2 83.162.186.242 port 7300
pa4jj-3 83.162.186.242 port 7388


Bob
 

If I remember an old thread on the subject ... With Icom radio, the transceive must be off, and new Icoms have something like echo (which echoes the command with the reply (like old icoms did). This must be on. 73.

On 09/12/2020 4:56 PM Jim Hargrave <w5ifp@...> wrote:


Let me offer some input to this discussion.

Instead of analyzing every bodies radio setup, to see who’s computer is fastest, I suggest you configure a basic radio interface.

 

Try the following suggestions for starters.

 

1)      Suggest setting Radio Baud rate to 9600 FIXED” Rate. “Never use AUTO”.

2)      Set Logger32 to the same rate

3)       Set Polling interval to “500”.

4)      Set/verify  Icom address Is the same in Logger32 and Radio.

5)      Set Stop bits to “2”

6)      Set Computer port “Sleep time” to “NEVER” .

 

These settings should result in solid communications between radio and computer/Logger32.

 

The main objective is to getting them talking , without burning rubber.

 

 

Jim – w5ifp-

 

From: hamlogger@groups.io [mailto:hamlogger@groups.io] On Behalf Of Michael Buckle via groups.io
Sent: Saturday, September 12, 2020 1:42 PM
To: hamlogger@groups.io
Subject: Re: [hamlogger] Program loses frequency and a lag on entering callsigns


sorry should have been:

  1. CI-V Baud Rate mine is set to Auto (As you say it will not go above 19200)
  2. CI-V USB 38400 (Will go to 115200)

In the manual, it states that you shouldn't push it above a certain level but I cant remember that suggestion now?

On 12/09/2020 19:37, Michael Buckle via groups.io wrote:

I have checked my ICOM 7610, I know it's not a IC7300 but I wonder if the Baud rate settings are the same in as much as:

There are two Baud Rate settings on the CI-V menu:

  1. CI-V Auto (As you say will not go above 19200)
  2. CI-V USB 38400

I suggest you just check the IC 7300 to ascertain these settings?

On 12/09/2020 15:38, Jan wrote:

Hi Ron

My 7300 shows in the CI-V USB Baud Rate a maximum setting of 115200 which I use with Logger32.
You said yours is not going above 19200 but you use 9600.
Why not use 19200??

73
Jan
PA4JJ


Op 12-9-2020 om 15:30 schreef Ron Stone via groups.io:

Hi Bob

Not to imply that your program isnt the best there is..... ! I have been using it since 1995 - that's an excellent 25 years - and only recently have I run into problems with it. So
do please accept my thanks for it. Freeware and great support ? Not many others like that so you can be very proud of it.

Regarding the entry of calls into the logbook entry window, previously instantaneous, so I rolled back to 3.50.394 and hey now the calls go in there fast again. No more lag
at all !. Then I uploaded 422 again and now the calls go in just as fast. Surely one for "Go figure...." I have checked the radio settings as you suggest.
Not possible in the IC7300 menus to go above 19200 baud so I have left it at 9600 where it was. Putting CI-V transceive
to OFF (I had it ON) resulted in no frequency change on VFO movement so I changed it back to ON and it is responding to QSY's again. I have tried playing with all settings
of polling times and nothing makes any difference. Used the radio debug window and indeed the frequency went to 0.00 when the prog lost the frequency. I have attached
a screen dump of when it happened. So the loss of frequency still happens very often unfortunately.

Now hear this.. Tried my W10 laptop and no prob with call entries or frequency. Everything stable. So I suppose the next step - taken reluctantly as I really dont like W10- is
to upgrade my W7 machine to W10. I've ordered a large thumb drive to back everything up and then will try again.

Others commenting. Thanks but are you using W7 or W10 please ?

73 and thanks again for your help. Stay safe

Ron



-- 
____________________________________________________
my dxspider clusters running on a raspberry pi:  
pa4jj-2 83.162.186.242 port 7300
pa4jj-3 83.162.186.242 port 7388



Michael Buckle
 

Agree with the Echo Bob, if its not on, no radio information is returned to the logger, like QRG and Band info etc.

On 12/09/2020 22:19, Bob wrote:
If I remember an old thread on the subject ... With Icom radio, the transceive must be off, and new Icoms have something like echo (which echoes the command with the reply (like old icoms did). This must be on. 73.
On 09/12/2020 4:56 PM Jim Hargrave <w5ifp@...> wrote:


Let me offer some input to this discussion.

Instead of analyzing every bodies radio setup, to see who’s computer is fastest, I suggest you configure a basic radio interface.

 

Try the following suggestions for starters.

 

1)      Suggest setting Radio Baud rate to 9600 FIXED” Rate. “Never use AUTO”.

2)      Set Logger32 to the same rate

3)       Set Polling interval to “500”.

4)      Set/verify  Icom address Is the same in Logger32 and Radio.

5)      Set Stop bits to “2”

6)      Set Computer port “Sleep time” to “NEVER” .

 

These settings should result in solid communications between radio and computer/Logger32.

 

The main objective is to getting them talking , without burning rubber.

 

 

Jim – w5ifp-

 

From: hamlogger@groups.io [mailto:hamlogger@groups.io] On Behalf Of Michael Buckle via groups.io
Sent: Saturday, September 12, 2020 1:42 PM
To: hamlogger@groups.io
Subject: Re: [hamlogger] Program loses frequency and a lag on entering callsigns


sorry should have been:

  1. CI-V Baud Rate mine is set to Auto (As you say it will not go above 19200)
  2. CI-V USB 38400 (Will go to 115200)

In the manual, it states that you shouldn't push it above a certain level but I cant remember that suggestion now?

On 12/09/2020 19:37, Michael Buckle via groups.io wrote:

I have checked my ICOM 7610, I know it's not a IC7300 but I wonder if the Baud rate settings are the same in as much as:

There are two Baud Rate settings on the CI-V menu:

  1. CI-V Auto (As you say will not go above 19200)
  2. CI-V USB 38400

I suggest you just check the IC 7300 to ascertain these settings?

On 12/09/2020 15:38, Jan wrote:

Hi Ron

My 7300 shows in the CI-V USB Baud Rate a maximum setting of 115200 which I use with Logger32.
You said yours is not going above 19200 but you use 9600.
Why not use 19200??

73
Jan
PA4JJ


Op 12-9-2020 om 15:30 schreef Ron Stone via groups.io:

Hi Bob

Not to imply that your program isnt the best there is..... ! I have been using it since 1995 - that's an excellent 25 years - and only recently have I run into problems with it. So
do please accept my thanks for it. Freeware and great support ? Not many others like that so you can be very proud of it.

Regarding the entry of calls into the logbook entry window, previously instantaneous, so I rolled back to 3.50.394 and hey now the calls go in there fast again. No more lag
at all !. Then I uploaded 422 again and now the calls go in just as fast. Surely one for "Go figure...." I have checked the radio settings as you suggest.
Not possible in the IC7300 menus to go above 19200 baud so I have left it at 9600 where it was. Putting CI-V transceive
to OFF (I had it ON) resulted in no frequency change on VFO movement so I changed it back to ON and it is responding to QSY's again. I have tried playing with all settings
of polling times and nothing makes any difference. Used the radio debug window and indeed the frequency went to 0.00 when the prog lost the frequency. I have attached
a screen dump of when it happened. So the loss of frequency still happens very often unfortunately.

Now hear this.. Tried my W10 laptop and no prob with call entries or frequency. Everything stable. So I suppose the next step - taken reluctantly as I really dont like W10- is
to upgrade my W7 machine to W10. I've ordered a large thumb drive to back everything up and then will try again.

Others commenting. Thanks but are you using W7 or W10 please ?

73 and thanks again for your help. Stay safe

Ron



-- 
____________________________________________________
my dxspider clusters running on a raspberry pi:  
pa4jj-2 83.162.186.242 port 7300
pa4jj-3 83.162.186.242 port 7388



Ron Stone
 

Thanks John

Tried all those. No joy but thanks for the suggestions.

73
Ron


Ron Stone
 

Hello Bob

No joy with transceive off with echo on or off. No change with stop bits either 1 or 2 but it did take 2 which suprised me. As for changing the sleep time, N1MM never fails on that, so I dont think that is the issue.

But I have noticed one big diff between L32 and N1MM (which works). I have it configured for COM20 in N1MM. If I try to configure L32 for COM20 although it is in the drop down menu for radio setup when I set the port to 20 and try it
,I get a "COM  port doesnt exist message". Do I remember seeing somewhere that L32 cannot handle COM ports about 15 or somesuch ? Maybe that is the problem. BUT - if I configure the radio to work via a CT-17 to a real (not USB) COM port , in my case COM14, I still get the frequency drop out problem. Methinks all this is maybe a W7 issue. I have ordered a big thumb drive to back up all my files and will then reluctantly convert to W10.

73
Ron


Bob
 

I'd still like to see a picture of the Radio Debug Window when the 'problem' manifests itself. 73.

On 09/13/2020 1:14 AM Ron Stone via groups.io <gw3ydx@...> wrote:


Hello Bob

No joy with transceive off with echo on or off. No change with stop bits either 1 or 2 but it did take 2 which suprised me. As for changing the sleep time, N1MM never fails on that, so I dont think that is the issue.

But I have noticed one big diff between L32 and N1MM (which works). I have it configured for COM20 in N1MM. If I try to configure L32 for COM20 although it is in the drop down menu for radio setup when I set the port to 20 and try it
,I get a "COM  port doesnt exist message". Do I remember seeing somewhere that L32 cannot handle COM ports about 15 or somesuch ? Maybe that is the problem. BUT - if I configure the radio to work via a CT-17 to a real (not USB) COM port , in my case COM14, I still get the frequency drop out problem. Methinks all this is maybe a W7 issue. I have ordered a big thumb drive to back up all my files and will then reluctantly convert to W10.

73
Ron


Ron Stone
 

Frequency loss - PROBLEM SOLVED - This post is for anyone else getting this.

From the IC7300 using a CT-17 interface, I had the PC connected for logging, an ACOM600s amplifier, and a 3el SteppIR
Not really a lot of point in connecting the amplifier as it has no antenna choice or ATU. Just a simple in-out device, but one can
switch the bandpass filters by connecting a CAT line rather than having them RF switch. It seemed the right thing to do...

Just sold the amplifier to acquire a different one. CAT line removed prior to packing it and yes you have guessed it - Logger32
frequency now perfectly stable and does not drop out. The amplifier connection was the problem, despite a correct lead being
made using the ACOM diagram. The amplifier uses the latest firmware and is correctly configured for CAT, but there must be
a polling or other problem that was fouling up the frequency reporting to Logger32, This problem was not present using N1MM+
or testing the interfacing with OMNI-RIG, so it is still a puzzle.

IF YOU HAVE THIS ISSUE, DISCONNECT EVERYTHING EXCEPT THE LINK TO YOUR PC and reconnect them in sequence
seeing if the issue stays away. Or you risk hours of agony and troubling the good people on this newsgroup.

73
Ron GW3YDX / F4VSM