John T. Blair

When I first loaded Logger32 on my Win 7 desktop back in 2021, I ran into an error about MSCOMCT2.OCX.  After I researching the problem and figuring how to fix it I posted a solution.

Well, I just got a new computer, a Kamuri running Win 10, for my radio desk.  For the last 2 days I've been trying to get Logger32 running on it.  I had 2 major problems:

1. After loading the program, and trying to run it, I was getting a VIS_BAD_DATASET_NUMBER Logbook32.extension.  After trying to reload the program, moving things around, reading the help file, etc
I did a search for the ".INI" files in the Logger32 directory.  I loaded each one, one at a time, into notepad and
did a search for logger32.  I had loaded Logger32 in "c:\Ham Radio\Logger32", but the path in the ".INI" files was pointing to "c:\logger32".  So I edited each of these entries and change it to "c:\Ham Radio\Logger32".  This time when I tried to run Logger32, it came up.

So next I loaded copies of the Logbook.isd, .isl  & .ism to get my current QSOs loaded.

So far so good.  But then I tried to add a QSO by right clicking the mouse in the Logbook page.  I got a MSCOMCT2.OCX error.   Trying several things I also got a 0x8002801c error.  So more researching the problem.

I finally had success about 11pm 3/12/23, tonight.  I've spent quite a bit of time researching various solutions and trying them.  So I'm here to report the process that I used to finally fix the problem.

1. Make sure mscomct2.ocx is in the directory c:\windows\SysWOW64

2. Run System File Checker (SFC) to check for bad files
    a. win + X - promps in c:\windows\system32
    b. run "sfc /scannow"

3. Register the ocx file:
    a. win + X - promps in c:\windows\system32
    b. Change directory  "cd c:\windows\SysWOW64"
    c. Register program regsvr32 mscomct2.ocx

I have not successfully added and deleted a QSO via Add QSO manually and manually deleting a QSO.

Hope this may help someone.

Virginia Beach, VA