Topics

Improvements for "Mode from DX Spots"


Fabio IZ8MBW
 

Hi all, hi Bob.
Running latest version 4.0.242.
I have Logger32 set as this screen:



 
So I expect that if I click on a Callsign from a DX Spot the mode of the radio will change accordingly IF in the Comment's spot is specified the mode.
Well, it seems to partially works.
For example, in my Logger32 Band Plan the frequency 7098,0 (40m) is Phone (SSB), so after clicking on a DX spot on that frequency Logger32 set the radio as SSB (LSB). OK, this is correct.
But if the "Comment" of that DX Spot specify the mode (RTTY or rtty for example), I expect the radio will set the Mode accordingly of the Comment for that DX Spot.
It seems does not work properly, in fact also if the Comment specify "RTTY" (or "rtty") Logger32 set the radio Mode to LSB.
 
Is it possible that Logger32 will "better" take care of the radio Mode from the DX Spot comment also if the Mode reported is outside the Logger32's Band Plan?
 
Thanks.

73s
Fabio, IZ8MBW

 


Bob <k4cy@...>
 

Fabio, open you BandPlan Window. Scroll to the band you were operating. Find the RTTY row. Look at the Radio Mode column. What does it say? SeventyThree(s).

On 02/15/2021 3:45 AM iz8mbw via groups.io <iz8mbw@...> wrote:
 
 
Hi all, hi Bob.
Running latest version 4.0.242.
I have Logger32 set as this screen:



 
So I expect that if I click on a Callsign from a DX Spot the mode of the radio will change accordingly IF in the Comment's spot is specified the mode.
Well, it seems to partially works.
For example, in my Logger32 Band Plan the frequency 7098,0 (40m) is Phone (SSB), so after clicking on a DX spot on that frequency Logger32 set the radio as SSB (LSB). OK, this is correct.
But if the "Comment" of that DX Spot specify the mode (RTTY or rtty for example), I expect the radio will set the Mode accordingly of the Comment for that DX Spot.
It seems does not work properly, in fact also if the Comment specify "RTTY" (or "rtty") Logger32 set the radio Mode to LSB.
 
Is it possible that Logger32 will "better" take care of the radio Mode from the DX Spot comment also if the Mode reported is outside the Logger32's Band Plan?
 
Thanks.

73s
Fabio, IZ8MBW

 


Fabio IZ8MBW
 

Ciao Bob!
RTTY is set to RTTY.
See here:


in fact it works RTTY from 7040 to 7050.

But for a Spot on 7090 (that is LSB) with "RTTY" as Comment, the radio does not go in RTTY but goes in LSB.
This is why I asked to "better" take care of the radio Mode from the DX Spot comments.

Obviously, if the Spot on 7090 does not have a Comment, it's Ok to go on LSB.

73s


Bob <k4cy@...>
 

Not for me. I tested a DX Spot on 21300 RTTY. Click on the DX Spot and the command was sent to change the radio mode to RTTY. SeventyThree(s). 

On 02/15/2021 10:26 AM iz8mbw via groups.io <iz8mbw@...> wrote:
 
 
Ciao Bob!
RTTY is set to RTTY.
See here:


in fact it works RTTY from 7040 to 7050.

But for a Spot on 7090 (that is LSB) with "RTTY" as Comment, the radio does not go in RTTY but goes in LSB.
This is why I asked to "better" take care of the radio Mode from the DX Spot comments.

Obviously, if the Spot on 7090 does not have a Comment, it's Ok to go on LSB.

73s


John Munton - G7SSE
 

Bob, would the entries in the table below affect Fabio's issue?



Ps. not what is in the red box but the "Radio Mode translation to OPERATING MODE or SUBMODE" columns.
--
73, John - G7SSE


Fabio IZ8MBW
 

Hi John,
the table you show should be only to specify which modes are for Digital Mode.

73
Fabio, IZ8MBW


Bob <k4cy@...>
 

John, good thought, but I don't think so. The code works like this example of a DX Spot on 21300 RTTY. In my case the 15m RTTY slot is 21080 to 21100.
 
a) Get the band from the frequency ... returns 15m
b) Find the 15m RTTY slot and look at the radio mode ... returns RTTY
c) send command to the radio.
 
SeventyThree(s).

On 02/15/2021 10:56 AM John Munton - G7SSE <johng7sse@...> wrote:
 
 
Bob, would the entries in the table below affect Fabio's issue?



Ps. not what is in the red box but the "Radio Mode translation to OPERATING MODE or SUBMODE" columns.
--
73, John - G7SSE


Fabio IZ8MBW
 

mmmm at step 2, why it looks for Radio Mode? I mean why reading data via CAT?
Should only pass to the radio (via CAT): go to 21300 in RTTY (also if the Band Plan is SSB) because in the Spot Comment there is the text "RTTY".


Bob <k4cy@...>
 

Step 2 has nothing to do with CAT. The Band of the DX Spot 15 15m. Step 2 must find the radio mode for RTTY on 15m. The step 3 sets the radio mode to what step 2 returns. It works as expected. SeventyThree(s). 

On 02/15/2021 11:17 AM iz8mbw via groups.io <iz8mbw@...> wrote:
 
 
mmmm at step 2, why it looks for Radio Mode? I mean why reading data via CAT?
Should only pass to the radio (via CAT): go to 21300 in RTTY (also if the Band Plan is SSB) because in the Spot Comment there is the text "RTTY".


Fabio IZ8MBW
 

Bob, see here.
There was a Spot with "RTTY" in the Comment on 14190 (SSB band portion). The spot is of "VK2PW".
After I click on that spot, the radio went on 14190 but in USB mode, see also the Radio Debug Window.



really sure that "works as expected"?  :-)

73s


Fabio IZ8MBW
 

instead if I click on a Spot on the RTTY Band Plan portion (14080), the radio goes correctly in RTTY, with the command: Set Radio Mode : FE FE 94 E0 06 04 FD


Bob <k4cy@...>
 

Absolutely. Ask on the reflector. 73.

On 02/15/2021 11:51 AM iz8mbw via groups.io <iz8mbw@...> wrote:
 
 
Bob, see here.
There was a Spot with "RTTY" in the Comment on 14190 (SSB band portion). The spot is of "VK2PW".
After I click on that spot, the radio went on 14190 but in USB mode, see also the Radio Debug Window.



really sure that "works as expected"?  :-)

73s


Fabio IZ8MBW
 

Ok Bob but for me it does not work.
Can you suggest me where to try to check in order to solve that issue?
Where/what can be the issue?
 
I add that the issue seems to not be related with which Radio I use because it happens with 2 different radio.
 
Thanks.
 


Bob <k4cy@...>
 

The only user option that controls this is to right click on the DX Spots window. Click SETUP | APPEARANCE. Check the option IF THE FIRST WORD OF COMMENTS IS A MODE, USE IT. SeventyThree(s).

On 02/16/2021 8:30 AM iz8mbw via groups.io <iz8mbw@...> wrote:
 
 
Ok Bob but for me it does not work.
Can you suggest me where to try to check in order to solve that issue?
Where/what can be the issue?
 
I add that the issue seems to not be related with which Radio I use because it happens with 2 different radio.
 
Thanks.
 


Fabio IZ8MBW
 

Thank you Bob, "IF THE FIRST WORD OF COMMENTS IS A MODE, USE IT" option solved my issue.

You are always the best!

73s