CW mode control for Flex 6600


Paul Sturpe
 

Selecting a cw frequency as defined under Tools, setup Bands & Modes does not put my Flex 6600 into CW mode.
The Operator window changes to CW mode but the radio doesn't.

I'm running Logger32 version 4.0.248.  Radio is selected as PowerSDR.  All other modes seem to work OK.

Paul, W3GQ


K8pk@...
 

Paul, had the same problem with my 6600.  Fixed it by changing radio to Kenwood, 38400 baudrate, 8 databits, 1 stop stopbit, no parity.  Com port connected to Slice A in SmartSDR CAT. Good luck!

Peter K8PK 


Paul Sturpe
 

Thanks Peter,
That does solve the CW mode problem here, unfortunately, RTTY and FT8 do not go to the proper mode with the Kenwood selected.
Paul, W3GQ


Jim Cox
 

Not sure what your problem is.   6400 changes fine here to CW.  I use PowerSDR.   Jim K4JAF
 

From: Paul Sturpe
Sent: Wednesday, March 24, 2021 5:06 PM
To: hamlogger@groups.io
Subject: Re: [hamlogger] CW mode control for Flex 6600
 
Thanks Peter,
That does solve the CW mode problem here, unfortunately, RTTY and FT8 do not go to the proper mode with the Kenwood selected.
Paul, W3GQ


Paul Sturpe
 

Jim,
I have attached my 20 meter Bands & Modes setup.

Now in my operator window, lets say I enter 14085.  The operator window AND the Smart SDR window will both show 14085 and RTTY Mode.

Now enter 14175 and both show 14175.  The operator window will show SSB and the Smart SDR window will show USB.

All correct so far.

Now enter 14020 in the operator window.  The operator window and Smart SDR both show 14020.   The operator window shows CW mode but the Smart SDR goes to USB.

Does your 6400 act differently?

Paul W3GQ.


Jim Cox
 

Your band mode file looks fine to me..  Do you have any other software program controlling the 6600 as well as Logger32?
Does your ADIFmode.txt file in Logger32 include CW?
I have had a 6600 in the past and all mode control worked as advertised.  Let me study the situation further or maybe someone else can give you a clue.  Jim K4JAF
 

From: Paul Sturpe
Sent: Thursday, March 25, 2021 8:34 AM
To: hamlogger@groups.io
Subject: Re: [hamlogger] CW mode control for Flex 6600
 
Jim,
I have attached my 20 meter Bands & Modes setup.

Now in my operator window, lets say I enter 14085.  The operator window AND the Smart SDR window will both show 14085 and RTTY Mode.

Now enter 14175 and both show 14175.  The operator window will show SSB and the Smart SDR window will show USB.

All correct so far.

Now enter 14020 in the operator window.  The operator window and Smart SDR both show 14020.   The operator window shows CW mode but the Smart SDR goes to USB.

Does your 6400 act differently?

Paul W3GQ.


Paul Sturpe
 

Jim,
No other software controlling the 6600.  The ADIFModes.txt file had CW  =PCW so I played around with just CW, CW  =CW and they all do the same.

Thanks,
Paul, W3GQ


Jim Cox
 

I really don’t understand the difference between my situation and yours....  I have the following under custom setting on the radio screen in setup.  You might try them and see if this helps..
Also try to turn on the radio debug under radio setup screen and see what is returned when you try to go to cw mode.. 
 
Here is what I have on custom settings:
 
USB=ZZMD01;ZZGT2;ZZFI04;
LSB=ZZMD00;ZZGT2;ZZFI04;
SSB=ZZGT2;ZZFI04;
RTTY=ZZMD30;ZZGT4;ZZFI04;ZZRT0;ZZRG00000;
DIGU=ZZMD07;ZZGT4;ZZFI01;ZZRT0;ZZRG00000;
CW=ZZMD03;ZZGT4;ZZFI4;ZZRT0;ZZRG00000;
CWL=ZZMD03;ZZGT3;ZZFI03;ZZRT0;ZZRG00000;
CWU=ZZMD03;ZZGT3;ZZFI03;ZZRT0;ZZRG00000;
FM=ZZMD05;
 
 
I don’t think cwl and cwu are even needed..   Jim K4JAF
 

From: Paul Sturpe
Sent: Thursday, March 25, 2021 3:36 PM
To: hamlogger@groups.io
Subject: Re: [hamlogger] CW mode control for Flex 6600
 
Jim,
No other software controlling the 6600.  The ADIFModes.txt file had CW  =PCW so I played around with just CW, CW  =CW and they all do the same.

Thanks,
Paul, W3GQ


Paul Sturpe
 

Hi Jim,
I'm not sure where your custom settings are coming from.  I assume from the ADIFModes.txt.  If so, my file doesn't look anything like yours.   I have attached mine.

I'll look at the debug and see if I spot anything that makes sense as to what is happening.

TNX.
Paul, W3GQ


Jim Cox
 

Paul if you go to the custom settings on the radio setup of baud rate, stop bits, powersdr etc.  It is where you turn the debug screen on to see what commands are being sent to the radio from Hamlogger.
On the debug screen see if the proper cw command is sent to the radio for that mode..    Here is a sample of my debug screen when changing to 14022 CW
 
 
 
Set VFO-A Freq : ZZFA00014022000;
Set RX1 Mode : ZZMD01;ZZMD03;ZZGT4;ZZFI4;ZZRT0;ZZRG00000;        (ZZMD03 sets to CWL, lower sideband tuning)
DX Spot sequence completed : 7 command lines executed in 1.784 seconds. Poll every 200 ms
Poll RX1 Freq : ZZFA;
RX1 Freq : ZZFA00014022000;
Poll RX1 Mode : ZZMD;
RX1 Mode : ZZMD03;
Poll TX VFO : ZZSW;
TX VFO : ZZSW0;
Poll RX2 Freq : ZZFB;
Poll RX2 Mode : ZZME;
Poll RX1 Freq : ZZFA;
 
I wonder if you need the ZZMD03 or ZZMD04 command sent to the 6600.  If you want to call me I can explain further.  My direct email address is k4jaf@...
 

From: Paul Sturpe
Sent: Friday, March 26, 2021 7:22 AM
To: hamlogger@groups.io
Subject: Re: [hamlogger] CW mode control for Flex 6600
 
Hi Jim,
I'm not sure where your custom settings are coming from.  I assume from the ADIFModes.txt.  If so, my file doesn't look anything like yours.   I have attached mine.

I'll look at the debug and see if I spot anything that makes sense as to what is happening.

TNX.
Paul, W3GQ


Jim Cox
 

Paul, have found your problem.  I took out the ZZMD03 command from my radio setup screen and my radio went to a cw frequency via bandplan but went to RTTY instead of CW. 
Jim K4JAF
 

From: Paul Sturpe
Sent: Friday, March 26, 2021 7:22 AM
To: hamlogger@groups.io
Subject: Re: [hamlogger] CW mode control for Flex 6600
 
Hi Jim,
I'm not sure where your custom settings are coming from.  I assume from the ADIFModes.txt.  If so, my file doesn't look anything like yours.   I have attached mine.

I'll look at the debug and see if I spot anything that makes sense as to what is happening.

TNX.
Paul, W3GQ


Jim Cox
 

Paul try this:  Instead of CW for radio mode use CWU or CWL  (CW with either upper or lower ssb tuning).  This should work.  Jim K4JAF
 

From: Paul Sturpe
Sent: Friday, March 26, 2021 7:22 AM
To: hamlogger@groups.io
Subject: Re: [hamlogger] CW mode control for Flex 6600
 
Hi Jim,
I'm not sure where your custom settings are coming from.  I assume from the ADIFModes.txt.  If so, my file doesn't look anything like yours.   I have attached mine.

I'll look at the debug and see if I spot anything that makes sense as to what is happening.

TNX.
Paul, W3GQ


Paul Sturpe
 

Jim,
Consulting with my friend, neighbor and part time Flex honcho,  Lou, N2TU I found the custom settings.  Mine wer blank, Lou's were CW=ZZFI03;ZZGT4; but that didn't solve my problem.

Your suggestion of using CWU or CWL in the bands & modes did it.   I thought I had ried that before I must have tried it in the ADIFModes.txt file.   

In any event, it looks like the issue is solved now.   Thanks for your help.
Paul, W3GQ


Jim Cox
 

Glad that solved your problem.  I have used the custom settings for years since the old PowerSDR days of the earlier Flex models..  So had never noticed the problem with CW on the new Flex 6000 series.
Jim K4JAF
 

From: Paul Sturpe
Sent: Friday, March 26, 2021 9:26 AM
To: hamlogger@groups.io
Subject: Re: [hamlogger] CW mode control for Flex 6600
 
Jim,
Consulting with my friend, neighbor and part time Flex honcho,  Lou, N2TU I found the custom settings.  Mine wer blank, Lou's were CW=ZZFI03;ZZGT4; but that didn't solve my problem.

Your suggestion of using CWU or CWL in the bands & modes did it.   I thought I had ried that before I must have tried it in the ADIFModes.txt file.  

In any event, it looks like the issue is solved now.   Thanks for your help.
Paul, W3GQ


Gary Hinson
 

Paul, Jim and other Flex users,

 

Based on the info exchanged in this thread, I have stitched together minimalist advice for the Logger32 v4 User Manual as follows:

 

Is that accurate?  Is it sufficient?  Additional info including screenshots of your setups would be useful, plus any details about config settings on the Flex itself.

 

Likewise config info for other Flex radios would be handy – perhaps even “Copy the 6600 settings: they work!”.

 

Please email me directly: Gary@...

 

73

Gary  ZL2iFB

 

From: hamlogger@groups.io <hamlogger@groups.io> On Behalf Of Paul Sturpe
Sent: 27 March 2021 03:26
To: hamlogger@groups.io
Subject: Re: [hamlogger] CW mode control for Flex 6600

 

Jim,
Consulting with my friend, neighbor and part time Flex honcho,  Lou, N2TU I found the custom settings.  Mine wer blank, Lou's were CW=ZZFI03;ZZGT4; but that didn't solve my problem.

Your suggestion of using CWU or CWL in the bands & modes did it.   I thought I had ried that before I must have tried it in the ADIFModes.txt file.   

In any event, it looks like the issue is solved now.   Thanks for your help.
Paul, W3GQ


Jim Cox
 

Your 53.2 should be changed to read: Flex 6000 series -- 6300, 6400, 6600, 6700
 
Should have another paragraph for second alternative:
 
Open setup-radio-radio1|2 configuration.  For the com port settings, try:
  Radio type = PowerSDR
  115200 baud
  8 databits
  1 stopbit   
  no parity   
  Com port connected to Slice A in SmartSDR CAT
 
In your band and modes table, use CWL  or CWU rather than plain CW.
 
 
 
If you have any questions just email me.. 
 
 
 
 
 
 

From: Gary Hinson
Sent: Friday, March 26, 2021 8:40 PM
To: hamlogger@groups.io
Subject: Re: [hamlogger] CW mode control for Flex 6600
 

Paul, Jim and other Flex users,

 

Based on the info exchanged in this thread, I have stitched together minimalist advice for the Logger32 v4 User Manual as follows:

 

Is that accurate?  Is it sufficient?  Additional info including screenshots of your setups would be useful, plus any details about config settings on the Flex itself.

 

Likewise config info for other Flex radios would be handy – perhaps even “Copy the 6600 settings: they work!”.

 

Please email me directly: Gary@...

 

73

Gary  ZL2iFB

 

From: hamlogger@groups.io <hamlogger@groups.io> On Behalf Of Paul Sturpe
Sent: 27 March 2021 03:26
To: hamlogger@groups.io
Subject: Re: [hamlogger] CW mode control for Flex 6600

 

Jim,
Consulting with my friend, neighbor and part time Flex honcho,  Lou, N2TU I found the custom settings.  Mine wer blank, Lou's were CW=ZZFI03;ZZGT4; but that didn't solve my problem.

Your suggestion of using CWU or CWL in the bands & modes did it.   I thought I had ried that before I must have tried it in the ADIFModes.txt file.  

In any event, it looks like the issue is solved now.   Thanks for your help.
Paul, W3GQ