Com port


Barry GM4GIF
 

I wonder if anyone else has experienced this …
I’m running L32 connected to my IC7300 on Com Port 6, everything working OK laptop controlling the rig, switching frequency when needed, logging etc. Then I click on ‘Start’ (in L32) to get JTDX or WSJT going, it starts no problem, shows Band Activity etc., I ‘Enable Tx’ send a CQ, stations respond and we complete the QSO and L32 logs it. Great stuff. During all this activity at the bottom of L32’s panel, I notice that  ‘Radio 1’ has turned red and when I hover the mouse over it I’m told that Com6 is closed. I go into Setup/Radio to open port Radio 1:IC7300 and am told ‘Invalid Port Number : Comm port 6’. During all this I’m operating as usual. Any thoughts anyone?

A few pics attached, sorry for the bandwidth.

73 de Barry / gm4gif



Dave Colliau
 

Thats normal. JTDX is controlling the CAT operation. When you exit Logger takes back over
Dave N8DC

On 09/27/2022 11:05 AM Barry GM4GIF <gm4gif@...> wrote:


I wonder if anyone else has experienced this …
I’m running L32 connected to my IC7300 on Com Port 6, everything working OK laptop controlling the rig, switching frequency when needed, logging etc. Then I click on ‘Start’ (in L32) to get JTDX or WSJT going, it starts no problem, shows Band Activity etc., I ‘Enable Tx’ send a CQ, stations respond and we complete the QSO and L32 logs it. Great stuff. During all this activity at the bottom of L32’s panel, I notice that  ‘Radio 1’ has turned red and when I hover the mouse over it I’m told that Com6 is closed. I go into Setup/Radio to open port Radio 1:IC7300 and am told ‘Invalid Port Number : Comm port 6’. During all this I’m operating as usual. Any thoughts anyone?

A few pics attached, sorry for the bandwidth.

73 de Barry / gm4gif



Colin Hendry
 

i think its because WSJT-X etc has taken control of the radio so cancelled L32's control.

Probably wrong but mine is the same running Flex 3000.

73 Colin G0ODR


On 27/09/2022 16:05, Barry GM4GIF wrote:

I wonder if anyone else has experienced this …
I’m running L32 connected to my IC7300 on Com Port 6, everything working OK laptop controlling the rig, switching frequency when needed, logging etc. Then I click on ‘Start’ (in L32) to get JTDX or WSJT going, it starts no problem, shows Band Activity etc., I ‘Enable Tx’ send a CQ, stations respond and we complete the QSO and L32 logs it. Great stuff. During all this activity at the bottom of L32’s panel, I notice that  ‘Radio 1’ has turned red and when I hover the mouse over it I’m told that Com6 is closed. I go into Setup/Radio to open port Radio 1:IC7300 and am told ‘Invalid Port Number : Comm port 6’. During all this I’m operating as usual. Any thoughts anyone?

A few pics attached, sorry for the bandwidth.

73 de Barry / gm4gif



bg0dpg
 

My FTDX10 is also this problem to open JTDX, L32 cannot link the station.





---- Replied Message ----
From Colin Hendry via groups.io<colin.hendry23@...>
Date 09/27/2022 23:37
To hamlogger@groups.io<hamlogger@groups.io>
Cc
Subject Re: [hamlogger] Com port

i think its because WSJT-X etc has taken control of the radio so cancelled L32's control.

Probably wrong but mine is the same running Flex 3000.

73 Colin G0ODR


On 27/09/2022 16:05, Barry GM4GIF wrote:

I wonder if anyone else has experienced this …
I’m running L32 connected to my IC7300 on Com Port 6, everything working OK laptop controlling the rig, switching frequency when needed, logging etc. Then I click on ‘Start’ (in L32) to get JTDX or WSJT going, it starts no problem, shows Band Activity etc., I ‘Enable Tx’ send a CQ, stations respond and we complete the QSO and L32 logs it. Great stuff. During all this activity at the bottom of L32’s panel, I notice that  ‘Radio 1’ has turned red and when I hover the mouse over it I’m told that Com6 is closed. I go into Setup/Radio to open port Radio 1:IC7300 and am told ‘Invalid Port Number : Comm port 6’. During all this I’m operating as usual. Any thoughts anyone?

A few pics attached, sorry for the bandwidth.

73 de Barry / gm4gif



Barry GM4GIF
 

OK, that’s reassuring, thanks.  I noticed when I came out of JTDX ‘Radio 1’ became blue again. As it had no effect on operations I probably didn’t notice it until recently when I’ve been attaching an external monitor and there’s a lot else going on in the FT8 display, hi. Thanks to those who responded.
73
Barry / gm4gif


Dave Colliau
 

What do you need to link. Wsjt-X and Jtdx take control of the cat control and if set properly will auto log or manually log your contacts.
Dave N8DC

On 09/27/2022 11:42 AM bg0dpg <bg0dpg@...> wrote:


My FTDX10 is also this problem to open JTDX, L32 cannot link the station.


bg0dpg@...
邮箱:bg0dpg@...



---- Replied Message ----
From Colin Hendry via groups.io<colin.hendry23@...>
Date 09/27/2022 23:37
To hamlogger@groups.io<hamlogger@groups.io>
Cc
Subject Re: [hamlogger] Com port

i think its because WSJT-X etc has taken control of the radio so cancelled L32's control.

Probably wrong but mine is the same running Flex 3000.

73 Colin G0ODR


On 27/09/2022 16:05, Barry GM4GIF wrote:

I wonder if anyone else has experienced this …
I’m running L32 connected to my IC7300 on Com Port 6, everything working OK laptop controlling the rig, switching frequency when needed, logging etc. Then I click on ‘Start’ (in L32) to get JTDX or WSJT going, it starts no problem, shows Band Activity etc., I ‘Enable Tx’ send a CQ, stations respond and we complete the QSO and L32 logs it. Great stuff. During all this activity at the bottom of L32’s panel, I notice that  ‘Radio 1’ has turned red and when I hover the mouse over it I’m told that Com6 is closed. I go into Setup/Radio to open port Radio 1:IC7300 and am told ‘Invalid Port Number : Comm port 6’. During all this I’m operating as usual. Any thoughts anyone?

A few pics attached, sorry for the bandwidth.

73 de Barry / gm4gif



bg0dpg
 

I now use L32 to open JTDX is normal, you can use it normally. But when I use JTDX, my L32 cannot replace the frequency display terminal connection. When the JTDX is turned off, the L32 port is restored to normal control radio.





---- Replied Message ----
From Dave Colliau<n8dc-8@...>
Date 09/28/2022 00:25
To hamlogger@groups.io<hamlogger@groups.io>
Cc
Subject Re: [hamlogger] Com port
What do you need to link. Wsjt-X and Jtdx take control of the cat control and if set properly will auto log or manually log your contacts.
Dave N8DC

On 09/27/2022 11:42 AM bg0dpg <bg0dpg@...> wrote:


My FTDX10 is also this problem to open JTDX, L32 cannot link the station.





---- Replied Message ----
From Colin Hendry via groups.io<colin.hendry23@...>
Date 09/27/2022 23:37
To hamlogger@groups.io<hamlogger@groups.io>
Cc
Subject Re: [hamlogger] Com port

i think its because WSJT-X etc has taken control of the radio so cancelled L32's control.

Probably wrong but mine is the same running Flex 3000.

73 Colin G0ODR


On 27/09/2022 16:05, Barry GM4GIF wrote:

I wonder if anyone else has experienced this …
I’m running L32 connected to my IC7300 on Com Port 6, everything working OK laptop controlling the rig, switching frequency when needed, logging etc. Then I click on ‘Start’ (in L32) to get JTDX or WSJT going, it starts no problem, shows Band Activity etc., I ‘Enable Tx’ send a CQ, stations respond and we complete the QSO and L32 logs it. Great stuff. During all this activity at the bottom of L32’s panel, I notice that  ‘Radio 1’ has turned red and when I hover the mouse over it I’m told that Com6 is closed. I go into Setup/Radio to open port Radio 1:IC7300 and am told ‘Invalid Port Number : Comm port 6’. During all this I’m operating as usual. Any thoughts anyone?

A few pics attached, sorry for the bandwidth.

73 de Barry / gm4gif



Dave Colliau
 

I think your saying that if you run Jtdx outside of logger 32 than logger doesnt read the frequency. You cant use the same port at the same time with 2 different programs.  There are programs that allow that .
Dave N8DC

On 09/27/2022 12:33 PM bg0dpg <bg0dpg@...> wrote:


I now use L32 to open JTDX is normal, you can use it normally. But when I use JTDX, my L32 cannot replace the frequency display terminal connection. When the JTDX is turned off, the L32 port is restored to normal control radio.


bg0dpg@...
邮箱:bg0dpg@...



---- Replied Message ----
From Dave Colliau<n8dc-8@...>
Date 09/28/2022 00:25
To hamlogger@groups.io<hamlogger@groups.io>
Cc
Subject Re: [hamlogger] Com port
What do you need to link. Wsjt-X and Jtdx take control of the cat control and if set properly will auto log or manually log your contacts.
Dave N8DC
On 09/27/2022 11:42 AM bg0dpg <bg0dpg@...> wrote:


My FTDX10 is also this problem to open JTDX, L32 cannot link the station.





---- Replied Message ----
From Colin Hendry via groups.io<colin.hendry23@...>
Date 09/27/2022 23:37
To hamlogger@groups.io<hamlogger@groups.io>
Cc
Subject Re: [hamlogger] Com port

i think its because WSJT-X etc has taken control of the radio so cancelled L32's control.

Probably wrong but mine is the same running Flex 3000.

73 Colin G0ODR


On 27/09/2022 16:05, Barry GM4GIF wrote:

I wonder if anyone else has experienced this …
I’m running L32 connected to my IC7300 on Com Port 6, everything working OK laptop controlling the rig, switching frequency when needed, logging etc. Then I click on ‘Start’ (in L32) to get JTDX or WSJT going, it starts no problem, shows Band Activity etc., I ‘Enable Tx’ send a CQ, stations respond and we complete the QSO and L32 logs it. Great stuff. During all this activity at the bottom of L32’s panel, I notice that  ‘Radio 1’ has turned red and when I hover the mouse over it I’m told that Com6 is closed. I go into Setup/Radio to open port Radio 1:IC7300 and am told ‘Invalid Port Number : Comm port 6’. During all this I’m operating as usual. Any thoughts anyone?

A few pics attached, sorry for the bandwidth.

73 de Barry / gm4gif



bg0dpg
 

Yes, it seems that L32 cannot open at the same time with JTDX.





---- Replied Message ----
From Dave Colliau<n8dc-8@...>
Date 09/28/2022 01:22
To hamlogger@groups.io<hamlogger@groups.io>
Cc
Subject Re: [hamlogger] Com port
I think your saying that if you run Jtdx outside of logger 32 than logger doesnt read the frequency. You cant use the same port at the same time with 2 different programs.  There are programs that allow that .
Dave N8DC

On 09/27/2022 12:33 PM bg0dpg <bg0dpg@...> wrote:


I now use L32 to open JTDX is normal, you can use it normally. But when I use JTDX, my L32 cannot replace the frequency display terminal connection. When the JTDX is turned off, the L32 port is restored to normal control radio.





---- Replied Message ----
From Dave Colliau<n8dc-8@...>
Date 09/28/2022 00:25
To hamlogger@groups.io<hamlogger@groups.io>
Cc
Subject Re: [hamlogger] Com port
What do you need to link. Wsjt-X and Jtdx take control of the cat control and if set properly will auto log or manually log your contacts.
Dave N8DC
On 09/27/2022 11:42 AM bg0dpg <bg0dpg@...> wrote:


My FTDX10 is also this problem to open JTDX, L32 cannot link the station.





---- Replied Message ----
From Colin Hendry via groups.io<colin.hendry23@...>
Date 09/27/2022 23:37
To hamlogger@groups.io<hamlogger@groups.io>
Cc
Subject Re: [hamlogger] Com port

i think its because WSJT-X etc has taken control of the radio so cancelled L32's control.

Probably wrong but mine is the same running Flex 3000.

73 Colin G0ODR


On 27/09/2022 16:05, Barry GM4GIF wrote:

I wonder if anyone else has experienced this …
I’m running L32 connected to my IC7300 on Com Port 6, everything working OK laptop controlling the rig, switching frequency when needed, logging etc. Then I click on ‘Start’ (in L32) to get JTDX or WSJT going, it starts no problem, shows Band Activity etc., I ‘Enable Tx’ send a CQ, stations respond and we complete the QSO and L32 logs it. Great stuff. During all this activity at the bottom of L32’s panel, I notice that  ‘Radio 1’ has turned red and when I hover the mouse over it I’m told that Com6 is closed. I go into Setup/Radio to open port Radio 1:IC7300 and am told ‘Invalid Port Number : Comm port 6’. During all this I’m operating as usual. Any thoughts anyone?

A few pics attached, sorry for the bandwidth.

73 de Barry / gm4gif



ja1nlx
 

This is by design in Logger32.

73 de aki
JA1NLX

On 2022/09/28 2:40:24, bg0dpg <bg0dpg@...> wrote:




---- Replied Message ----
From Dave Colliau<n8dc-8@...>
Date 09/28/2022 01:22
To hamlogger@groups.io<hamlogger@groups.io>
Cc
Subject Re: [hamlogger] Com port
I think your saying that if you run Jtdx outside of logger 32 than logger doesnt read the frequency. You cant use the same port at the same time with 2 different programs.  There are programs that allow that .
Dave N8DC
On 09/27/2022 12:33 PM bg0dpg <bg0dpg@...> wrote:


I now use L32 to open JTDX is normal, you can use it normally. But when I use JTDX, my L32 cannot replace the frequency display terminal connection. When the JTDX is turned off, the L32 port is restored to normal control radio.





---- Replied Message ----
From Dave Colliau<n8dc-8@...>
Date 09/28/2022 00:25
To hamlogger@groups.io<hamlogger@groups.io>
Cc
Subject Re: [hamlogger] Com port
What do you need to link. Wsjt-X and Jtdx take control of the cat control and if set properly will auto log or manually log your contacts.
Dave N8DC
On 09/27/2022 11:42 AM bg0dpg <bg0dpg@...> wrote:


My FTDX10 is also this problem to open JTDX, L32 cannot link the station.





---- Replied Message ----
From Colin Hendry via groups.io<colin.hendry23@...>
Date 09/27/2022 23:37
To hamlogger@groups.io<hamlogger@groups.io>
Cc
Subject Re: [hamlogger] Com port

i think its because WSJT-X etc has taken control of the radio so cancelled L32's control.

Probably wrong but mine is the same running Flex 3000.

73 Colin G0ODR


On 27/09/2022 16:05, Barry GM4GIF wrote:

I wonder if anyone else has experienced this …
I’m running L32 connected to my IC7300 on Com Port 6, everything working OK laptop controlling the rig, switching frequency when needed, logging etc. Then I click on ‘Start’ (in L32) to get JTDX or WSJT going, it starts no problem, shows Band Activity etc., I ‘Enable Tx’ send a CQ, stations respond and we complete the QSO and L32 logs it. Great stuff. During all this activity at the bottom of L32’s panel, I notice that  ‘Radio 1’ has turned red and when I hover the mouse over it I’m told that Com6 is closed. I go into Setup/Radio to open port Radio 1:IC7300 and am told ‘Invalid Port Number : Comm port 6’. During all this I’m operating as usual. Any thoughts anyone?

A few pics attached, sorry for the bandwidth.

73 de Barry / gm4gif



ja1nlx
 

and if you want to see frequency/mode displayed in Logbook entry window while operating
WSJT/JTDX, then
check "Allow WSJT/JTDX to set Logger32 frequency/band/mode" option in UDP BandMap
Config menu.



73 de aki
JA1NLX

On 2022/09/28 7:23:11, ja1nlx via groups.io <ayoshida0205@...> wrote:

This is by design in Logger32.

73 de aki
JA1NLX

On 2022/09/28 2:40:24, bg0dpg <bg0dpg@...> wrote:




---- Replied Message ----
From Dave Colliau<n8dc-8@...>
Date 09/28/2022 01:22
To hamlogger@groups.io<hamlogger@groups.io>
Cc
Subject Re: [hamlogger] Com port
I think your saying that if you run Jtdx outside of logger 32 than logger doesnt read the frequency. You cant use the same port at the same time with 2 different programs.  There are programs that allow that .
Dave N8DC
On 09/27/2022 12:33 PM bg0dpg <bg0dpg@...> wrote:


I now use L32 to open JTDX is normal, you can use it normally. But when I use JTDX, my L32 cannot replace the frequency display terminal connection. When the JTDX is turned off, the L32 port is restored to normal control radio.





---- Replied Message ----
From Dave Colliau<n8dc-8@...>
Date 09/28/2022 00:25
To hamlogger@groups.io<hamlogger@groups.io>
Cc
Subject Re: [hamlogger] Com port
What do you need to link. Wsjt-X and Jtdx take control of the cat control and if set properly will auto log or manually log your contacts.
Dave N8DC
On 09/27/2022 11:42 AM bg0dpg <bg0dpg@...> wrote:


My FTDX10 is also this problem to open JTDX, L32 cannot link the station.





---- Replied Message ----
From Colin Hendry via groups.io<colin.hendry23@...>
Date 09/27/2022 23:37
To hamlogger@groups.io<hamlogger@groups.io>
Cc
Subject Re: [hamlogger] Com port

i think its because WSJT-X etc has taken control of the radio so cancelled L32's control.

Probably wrong but mine is the same running Flex 3000.

73 Colin G0ODR


On 27/09/2022 16:05, Barry GM4GIF wrote:

I wonder if anyone else has experienced this …
I’m running L32 connected to my IC7300 on Com Port 6, everything working OK laptop controlling the rig, switching frequency when needed, logging etc. Then I click on ‘Start’ (in L32) to get JTDX or WSJT going, it starts no problem, shows Band Activity etc., I ‘Enable Tx’ send a CQ, stations respond and we complete the QSO and L32 logs it. Great stuff. During all this activity at the bottom of L32’s panel, I notice that  ‘Radio 1’ has turned red and when I hover the mouse over it I’m told that Com6 is closed. I go into Setup/Radio to open port Radio 1:IC7300 and am told ‘Invalid Port Number : Comm port 6’. During all this I’m operating as usual. Any thoughts anyone?

A few pics attached, sorry for the bandwidth.

73 de Barry / gm4gif



Steve VE3RX
 

The issue is more with Windows and its applications, it cannot share a COM port with more than one application at the same time.
This has been true for many years.
There are COM port sharing utilities out there, and some radio control/logging software has some of that "sharing" code built into them. But otherwise, no sharing "allowed" by Windows.

73
Steve