Topics

'<' and '>' not displaying correctly in DXC window

Sean - G4UCJ
 

I have noticed this strange phenomenon for some time, certainly over many versions (I can't remember when, or even if, the text has displayed correctly in the DX Cluster window).

Here's what happens: If I want to send a spot to the DX cluster that includes grid locators the '<' and '>' part of the spot get exchanged for other characters (i.e. IO92ma<ES>KP02xx, for example, end up like IO92ma&lt;ES&gt;KO02xx).
It doesn't seem to matter what I change, or whether the text comes from me entering a spot manually in the DX cluster window or if it comes from an external source (such as Live MUF which is connected to a different DX cluster node).
I have included a screengrab of the offending text. It does this on all spots that have the 'greater than'/'less than' symbols, whether entered by me or from another station on the cluster. I wondered if it might be a font issue, but I've tried changing the font wherever it has been possible (unless I have missed one that affects the cluster window) and I only use pretty standard fonts like Arial, Comic Sans or Calibri.
Any ideas on how to solve this as it makes spots tricky to read. BTW, the spots appear as they should when viewing the cluster from different software. I have also tried using different nodes just in case - but to no avail.
I'm thinking it is likely to be user error rather than a software issue.

Thanks in advance & 73,
Sean G4UCJ - IO92ma    

Jan
 

Sean

I think it has something to do with Unicode in Windows

73
Jan
PA4JJ

Op 1-6-2020 om 12:17 schreef Sean - G4UCJ:
I have noticed this strange phenomenon for some time, certainly over many versions (I can't remember when, or even if, the text has displayed correctly in the DX Cluster window).

Here's what happens: If I want to send a spot to the DX cluster that includes grid locators the '<' and '>' part of the spot get exchanged for other characters (i.e. IO92ma<ES>KP02xx, for example, end up like IO92ma&lt;ES&gt;KO02xx).
It doesn't seem to matter what I change, or whether the text comes from me entering a spot manually in the DX cluster window or if it comes from an external source (such as Live MUF which is connected to a different DX cluster node).
I have included a screengrab of the offending text. It does this on all spots that have the 'greater than'/'less than' symbols, whether entered by me or from another station on the cluster. I wondered if it might be a font issue, but I've tried changing the font wherever it has been possible (unless I have missed one that affects the cluster window) and I only use pretty standard fonts like Arial, Comic Sans or Calibri.
Any ideas on how to solve this as it makes spots tricky to read. BTW, the spots appear as they should when viewing the cluster from different software. I have also tried using different nodes just in case - but to no avail.
I'm thinking it is likely to be user error rather than a software issue.

Thanks in advance & 73,
Sean G4UCJ - IO92ma    

-- 
____________________________________________________
my dxspider clusters running on a raspberry pi:  
pa4jj-2 83.162.186.242 port 7300
pa4jj-3 83.162.186.242 port 7388

Bob
 

I assume this is done on purpose by the keeper of the DX Cluster. The text is converted to HTML so that it can be correct on a web browser. I have added code (for the next auto-update) that will un-HTML the DX Spots. Please let me know the address of the Cluster you use so that I can test the code. SeventyThree(s).

On June 1, 2020 at 6:17 AM Sean - G4UCJ <sean@...> wrote:

I have noticed this strange phenomenon for some time, certainly over many versions (I can't remember when, or even if, the text has displayed correctly in the DX Cluster window).

Here's what happens: If I want to send a spot to the DX cluster that includes grid locators the ' <' and ' >' part of the spot get exchanged for other characters (i.e. IO92ma<ES>KP02xx, for example, end up like IO92ma&lt;ES&gt;KO02xx).
It doesn't seem to matter what I change, or whether the text comes from me entering a spot manually in the DX cluster window or if it comes from an external source (such as Live MUF which is connected to a different DX cluster node).
I have included a screengrab of the offending text. It does this on all spots that have the 'greater than'/'less than' symbols, whether entered by me or from another station on the cluster. I wondered if it might be a font issue, but I've tried changing the font wherever it has been possible (unless I have missed one that affects the cluster window) and I only use pretty standard fonts like Arial, Comic Sans or Calibri.
Any ideas on how to solve this as it makes spots tricky to read. BTW, the spots appear as they should when viewing the cluster from different software. I have also tried using different nodes just in case - but to no avail.
I'm thinking it is likely to be user error rather than a software issue.

Thanks in advance & 73,
Sean G4UCJ - IO92ma    

 

Sean - G4UCJ
 

Hi Bob, the address is GB7MBC (gb7mbc.spoo.org port 8000)

Thanks for looking into this, it's appreciated.

73, Sean

Bob
 

There was no need for me to add the additional code, it is already there. The very first thing Logger32 does when receiving DX Spots from the socket is to replace any HTML symbols. I connected to GB7MBC (see the pictures) everything is as expected. To double check, I temporarily removed the code that checked for HTML symbols. No change, the text being sent by GB7MBC is not in HTML format. SeventyThree(s).




On June 1, 2020 at 7:42 AM Sean - G4UCJ <sean@...> wrote:

Hi Bob, the address is GB7MBC (gb7mbc.spoo.org port 8000)

Thanks for looking into this, it's appreciated.

73, Sean

 

Sean - G4UCJ
 

That's really strange as I have the same windows open and connected to the same cluster, but my 'DX Spots' window is showing the HTML type characters. I was wondering if a change of font would help but I can't see where to change the fonts in the 'DX Spots' window (maybe I am being dense - I checked all the 'righthand' menus and 'appearance' options but unable to find it).

Is there anything I can do to get the <> to show correctly in the 'DX Spots' window?

Thanks again. Bob.
73  - Sean

Bob
 

Try VIEW | GRID APPEARANCE. You didn't comment if you see the same HTML symbols in the Cluster Window. SeventyThree(s).

On June 1, 2020 at 10:14 AM Sean - G4UCJ <sean@...> wrote:

That's really strange as I have the same windows open and connected to the same cluster, but my 'DX Spots' window is showing the HTML type characters. I was wondering if a change of font would help but I can't see where to change the fonts in the 'DX Spots' window (maybe I am being dense - I checked all the 'righthand' menus and 'appearance' options but unable to find it).

Is there anything I can do to get the <> to show correctly in the 'DX Spots' window?

Thanks again. Bob.
73  - Sean

 

Sean - G4UCJ
 

No, the cluster window is fine. I have shown the DX Cluster window in the previous image, maybe it is too small to see. I've enlarged it, so hopefully, it is large enough to see now.
I have now changed the window font (I hadn't realised that the grid appearance changed all the windows/grids) and have tried several but nothing makes a difference, it remains as below. Cluster window displays correctly, DX Spots window displays incorrectly. 

It's strange.
73, Sean

Bob
 

The Cluster Window shows (like mine) that the raw DX Spot text is not in HTMP. Formatting of the DX Spot for the DX Spot Window does not include the use HTML symbols. It would be useful if other could comment on their observations. SeventyThree(s).

On June 1, 2020 at 11:12 AM Sean - G4UCJ <sean@...> wrote:

No, the cluster window is fine. I have shown the DX Cluster window in the previous image, maybe it is too small to see. I've enlarged it, so hopefully, it is large enough to see now.
I have now changed the window font (I hadn't realised that the grid appearance changed all the windows/grids) and have tried several but nothing makes a difference, it remains as below. Cluster window displays correctly, DX Spots window displays incorrectly. 

It's strange.
73, Sean

 

Bob
 

Ouch! Right click on the DX Spots Window and UNcheck ENABLE BROADCAST OF DX SPOTS. This option sends the DX Spots to an external program in HTML formal. I guess it inadvertently converted what is sent to the DX Spot Window too. Mia Culpa. I'll fix it for the next auto-update. SeventyThree(s).

On June 1, 2020 at 11:12 AM Sean - G4UCJ <sean@...> wrote:

No, the cluster window is fine. I have shown the DX Cluster window in the previous image, maybe it is too small to see. I've enlarged it, so hopefully, it is large enough to see now.
I have now changed the window font (I hadn't realised that the grid appearance changed all the windows/grids) and have tried several but nothing makes a difference, it remains as below. Cluster window displays correctly, DX Spots window displays incorrectly. 

It's strange.
73, Sean

 

Sean - G4UCJ
 

Thanks Bob, outstanding assistance - as ever!

73, Sean G4UCJ