JTDX on-top ...


Peter Eckersberger
 

Hi Bob,

In the meantime I'm convinced it was me in making a mistake in interpreting the manuals text. For one reason or an other I thought for "parallel logging" only the "TCP"-feature has to be active. Which means in other words no UDP needed at all. Just starting Logger32 and in a second step starting JTDX e.g. by its own program icon.

BUT ... For starting JTDX on top one needs the UDP-bandmap and its start menus. By doing it that way everything is working fine. Sorry for the inconvenience stealing your precious time.


73 de Peter, OE3EPW


Bob
 

Peter, your pictures show that JTDX is not starting on top. The JTDX title bar shows JTDX by HF community. Maybe Logger32 started JTDX, but is did not control it. On the UDP BandMap, click the START/STOP menu. Click DELAY AFTER STARTING JTDX. Set the time to 20 seconds (or maybe more). Now, after starting JTDX from Logger32 does the title bat say JTDX & Logger32 (on-top). SeventyThree(s).

On 09/16/2021 8:15 AM Peter Eckersberger <oe3epw@...> wrote:
 
 
Hello Bob,

Sorry I'm late. Have been out of my home. To answer your question ... YES, its ON TOP. Here some pics ...

That's the one where only 'TCP' is on. But no 'UDP" ... therefore no 'band plan'. Parallel logging is OK, but JTDX vanishes every time at the end of every single logging procedure. That means ... 1 QSO logged and fiddling with the mouse to recall 'JTDX' to the foreground ...




Here the start of 'JTDX' via 'start menus' within 'band plan' ...




This shows the activated 'ON TOP' switch ...





Finally the operating position when 'JTDX' and Logger32' is 'parallel logging' ...
 



Well, that's it. Hope you're getting the point.


73 de Peter, OE3EPW



Peter Eckersberger
 

Hello Bob,

Sorry I'm late. Have been out of my home. To answer your question ... YES, its ON TOP. Here some pics ...

That's the one where only 'TCP' is on. But no 'UDP" ... therefore no 'band plan'. Parallel logging is OK, but JTDX vanishes every time at the end of every single logging procedure. That means ... 1 QSO logged and fiddling with the mouse to recall 'JTDX' to the foreground ...




Here the start of 'JTDX' via 'start menus' within 'band plan' ...




This shows the activated 'ON TOP' switch ...





Finally the operating position when 'JTDX' and Logger32' is 'parallel logging' ...
 



Well, that's it. Hope you're getting the point.


73 de Peter, OE3EPW



Bob
 

Is Logger32 configured to start JTDX 'on-top'? SeventyThree(s).
 

On 09/15/2021 3:37 AM Peter Eckersberger <oe3epw@...> wrote:
 
 
Hi Gary,

Thanks for the feedback.

For Bob ... When doing "parallel logging" with TCP JTDX is not acting as 'On Top' window but disappears continuously into background. Is this on purpose or an operating error by myself? 


73 de Peter, OE3EPW
 
Am 14.09.2021 um 19:53 schrieb Gary Hinson:

HI Peter,

 

Thanks for that.  You’re right: there is no <Enable data transfer to external Log> option under Settings → Reporting in the current version of JTDX.  Like Logger32, JTDX is being actively maintained so I guess the option wording was updated without me noticing the change.

 

It's not exactly obvious but the JTDX Settings → Reporting tab has separate areas for TCP and UDP settings [in the JTDX v2.2.157-32A-rc1 beta version I am running anyway]:

 

 

So to transfer QSO data from JTDX to Logger32, you need to tell it to use either UDP (<Enable sending logged QSO ADIF data> as I do) which works with Logger32’s UDP functions such as the UDP BandMap, or TCP (<Enable sending to TCP server>) which communicates with the TCP server in Logger32. 

 

Don’t enable both TCP and UDP logging or I think you will log duplicate QSOs!

 

I will correct the manual for the next release.  Thanks for letting me know about the issue so clearly.

 

Bob and the beta crew are still working on parallel logging so more changes are likely in that area too.

 

73

Gary  ZL2iFB