Bandmap callsigns on WSJT-X not transferring to L32 Input Window


Jerry Spring
 

Gary,

I will have to check my colour settings but I'm pretty sure there is no box around the callsign.  I clicked once and waited 30 seconds and tried this several times.  

As for calling someone while still in QSO, this is standard procedure for 99.9% of operators (from what I've observed operating FT8 for 2 years).  I never call on their transmit frequency as I use the spectrum display to always try to find a clear slot to call.  So I wouldn't be stepping on their current QSO, unless I randomly picked the same frequency the other guy was transmitting on, assuming I couldn't see his signal.  Also, if trying to contact a DXpedition operating in Fox/Hound mode and I waited for them to CQ, I could wait a LONG time.  And finally, another reason not to wait for a CQ is if there is a lot of QSB and the other station is very weak.  You may want to call him a bunch of times, hoping he can hear you on one or two occasions. You might not work him at all if you wait for his CQ.  I would recommend a button, "Transmit Now", which is what WSJT-X gives you anyway.  

J


Gary Hinson
 

Hi Jerry.

 

Going back a step, I am still puzzled about your statement “When I single click on the callsign, no box appears around the callsign.”

 

Are you sure?  Are you patiently waiting for the selector box to appear?

 

On my system, that selector box can take a little while to appear, so having clicked I am often left wondering if I actually clicked it.  If I lose patience and click it again (“To be sure”), that can cancel the selection, if indeed it was selected in the first place.   [I reported this as a bug months ago and, as I recall, Bob changed something to make the system more responsive … but it seems to have regressed.]

 

Anyway, that your system is calling someone is a good sign: at least that proves the Logger32 can command WSJT-X to initiate a QSO.   

 

I wonder if your selector box is in the same colour as the background of the UDP BandMap, so it appears but is invisible!  I’ve forgotten how to check/change the box colour: it is hopefully in the manual.

 

Normally, the automatic cherry-picker and manual calling function both wait until the next station is ready to be called, rather than calling prematurely when he is still in QSO with someone else.  ‘Ready to be called’ means he appears to be ending a QSO (he sent an RR73 or 73 message) or he is CQing.  I’m not entirely sure what happens if he completes a QSO then remains silent: will we call him or not?  More observation required.

 

If for some reason you feel compelled to call someone prematurely during their QSO, you can force WSJT-X to transmit directly, but I don’t recommend it as a rule (especially not if your transmission is or may be on top of his QSO partner), and it’s not something that Logger32 will help you do.

 

73

Gary  ZL2iFB

 

From: hamlogger@groups.io <hamlogger@groups.io> On Behalf Of Jerry Spring
Sent: 31 March 2021 15:37
To: hamlogger@groups.io
Subject: Re: [hamlogger] Bandmap callsigns on WSJT-X not transferring to L32 Input Window

 

[Edited Message Follows]

Hi Gary,

IA little progress...

I just turned on the Cherry Picking option:  "Cherry-pick decoded callsign on next CQ" and now it is populating the Call field in the entry window!  It is still not drawing a box around the callsign, however.  I then clicked on "Show manual calling event viewer" and was able to work a station, but only after he called CQ.  Is there no way to call him before he calls CQ?  I still think there must be a setting or two I am missing.

Thanks again

Jerry VE6TL


Jerry Spring
 
Edited

Hi Gary,

IA little progress...

I just turned on the Cherry Picking option:  "Cherry-pick decoded callsign on next CQ" and now it is populating the Call field in the entry window!  It is still not drawing a box around the callsign, however.  I then clicked on "Show manual calling event viewer" and was able to work a station, but only after he called CQ.  Is there no way to call him before he calls CQ?  I still think there must be a setting or two I am missing.

Thanks again

Jerry VE6TL


Gary Hinson
 

Take your time Jerry, I know it is frustrating but let’s continue working on the problem. 

 

When we click a callsign on the UDP BandMap, a box should appear around it … like this:

 

 

The box indicates that the callsign has been selected for “manual calling”.

 

On my system, the box can be slow to appear, sometimes so slow that I wonder if I even clicked the callsign, so I click it again … but if the first click selected the callsign, the second click de-selects it, so the box appears and instantly disappears again!  The answer is for me to be patient: click the call and watch. 

 

Once the box appears, Logger32 is (as I said before) waiting for its chance to tell WSJT-X/JTDX to call that station.  Meanwhile, it pops the call into the log entry pane and does the online callsign lookup, just as if I had typed a call into the log entry pane by hand.  I think that is what you want.

 

If we click the boxed callsign, that clears the log entry pane, removes the box, and stops waiting to tell WSJT-X/JTDX to call the station.  We are back to square 1.

 

Does that work for you?

 

73

Gary  ZL2iFB

 

From: hamlogger@groups.io <hamlogger@groups.io> On Behalf Of Jerry Spring
Sent: 25 March 2021 10:26
To: hamlogger@groups.io
Subject: Re: [hamlogger] Bandmap callsigns on WSJT-X not transferring to L32 Input Window

 

I have not changed any of the settings in WSJT-X from when it was working perfectly in V3.5.  The fact that the input window in L32 receives the grid square but not the callsign says that there is a bug in L32.  I shouldn't have to swap out WSJT-X for JTDX because of a bug in L32. 

I have not implemented any of the cherry picking  schemes and have never had L32 telling WSJT-X to initiate a call to another station. I always select the station I want to call in WSJT-X and enable transmitting in WSJT-X.  All I want in L32 is to populate the input field and grid square in the L32 input window and automatically look it up in QRZ.com.  (The QRZ.com part is working.)  I also want L32 to automatically log the QSO as before (in V3.5). 

By the way, when I click on an interesting callsign in the L32 WSJT-X bandmap window, I don't see a box around it and nothing happens in the UDP debug window.  Yet, I see the grid square immediately show up in the L32 input window. 

Jerry


Kenneth Hansen
 

Running L32 version 4.0.248 and WSJT-X, everything  is working as it should 

de KB2SSE

On Wed, Mar 24, 2021 at 5:25 PM Jerry Spring <jspring@...> wrote:
I have not changed any of the settings in WSJT-X from when it was working perfectly in V3.5.  The fact that the input window in L32 receives the grid square but not the callsign says that there is a bug in L32.  I shouldn't have to swap out WSJT-X for JTDX because of a bug in L32. 

I have not implemented any of the cherry picking  schemes and have never had L32 telling WSJT-X to initiate a call to another station. I always select the station I want to call in WSJT-X and enable transmitting in WSJT-X.  All I want in L32 is to populate the input field and grid square in the L32 input window and automatically look it up in QRZ.com.  (The QRZ.com part is working.)  I also want L32 to automatically log the QSO as before (in V3.5). 

By the way, when I click on an interesting callsign in the L32 WSJT-X bandmap window, I don't see a box around it and nothing happens in the UDP debug window.  Yet, I see the grid square immediately show up in the L32 input window. 

Jerry

--
Kenneth Hansen
Owner
ScanAm Technical Services, LLC


Jerry Spring
 

I have not changed any of the settings in WSJT-X from when it was working perfectly in V3.5.  The fact that the input window in L32 receives the grid square but not the callsign says that there is a bug in L32.  I shouldn't have to swap out WSJT-X for JTDX because of a bug in L32. 

I have not implemented any of the cherry picking  schemes and have never had L32 telling WSJT-X to initiate a call to another station. I always select the station I want to call in WSJT-X and enable transmitting in WSJT-X.  All I want in L32 is to populate the input field and grid square in the L32 input window and automatically look it up in QRZ.com.  (The QRZ.com part is working.)  I also want L32 to automatically log the QSO as before (in V3.5). 

By the way, when I click on an interesting callsign in the L32 WSJT-X bandmap window, I don't see a box around it and nothing happens in the UDP debug window.  Yet, I see the grid square immediately show up in the L32 input window. 

Jerry


Gary Hinson
 

<No comment>

 

 

From: hamlogger@groups.io <hamlogger@groups.io> On Behalf Of Fabio IZ8MBW via groups.io
Sent: 25 March 2021 09:50
To: hamlogger@groups.io
Subject: Re: [hamlogger] Bandmap callsigns on WSJT-X not transferring to L32 Input Window

 

Hi Gary,

another behavior when Loggre32 clear the selected callsign from the Logbook Entry Window is in this case:

 

- DX Station call CQ.

- I select that DX Station so I will go to call him (now Logger32 correctly put the DX Station callsign into Logbook Entry Window and QRZ lookup start)

- The DX Station did not reply to me but replied to another station.

 

Well, in this case, when the DX Station did not reply to me but replied to another station, Loggre32 clear the selected callsign from the Logbook Entry Window.

 

If after I recall that DX station (doble click again on the DX Station)Loggre32 put again the DX station callsign into Logbook Entry Window and QRZ lookup start once again.

 

This is the example on WSJT-X:

Inline image

 

This happens with WSJT-X and not with JTDX (probably because JTDX did not send via UDP the message to immediately "clear" the Callsign).

 

 

Well, I think make more sense to leave the DX Station callsign into Logbook Entry Window until I will choose another DX Station to call or I click on a DX Spot of another station. I mean, do not clear the callsign into Logbook Entry Window if I did not decide it.

 

 

Thanks.

 

 

73s

Fabio, IZ8MBW

 

 

 

On Wednesday, March 24, 2021, 06:01:01 AM GMT+1, Gary Hinson <gary@...> wrote:

 

 

Hi Jerry.

 

We are currently beta testing a change that stops Logger32 erasing callsigns from the log entry pane when the UDP BandMap is open … since we normally operate split in FT8, and splits above 1 kHz were tripping the “Clear callsign on QSY > 1kHz setting” for those using it.

 

There are other changes & bug-fixes in the works, so it may take a wee while to complete the testing and release the next version.

 

I just hope it will cure your issue.

 

73

Gary  ZL2iFB

From: hamlogger@groups.io <hamlogger@groups.io> On Behalf Of Jerry Spring
Sent: 24 March 2021 17:04
To: hamlogger@groups.io
Subject: [hamlogger] Bandmap callsigns on WSJT-X not transferring to L32 Input Window

 

[Edited Message Follows]

I just upgraded from V3.5 to V4.0 and everything seemed to go perfectly.  Except that I can no longer double click on a callsign in the WSJT-X bandmap window and have it transferred to the Input "Call" field in L32.  The only field that does transfer is the Grid square.  So the UDP link is working.  I have the UDP server set to 127.0.0.1 in WSJT-X  with port 2238.  These are the same settings I see at the bottom of L32, when I hover over UDP.  What am I missing?  I also tried setting the port on both to 2237, with identical results. 

Thanks,

Jerry VE6TL


Fabio IZ8MBW
 

Hi Gary,
another behavior when Loggre32 clear the selected callsign from the Logbook Entry Window is in this case:

- DX Station call CQ.
- I select that DX Station so I will go to call him (now Logger32 correctly put the DX Station callsign into Logbook Entry Window and QRZ lookup start)
- The DX Station did not reply to me but replied to another station.

Well, in this case, when the DX Station did not reply to me but replied to another station, Loggre32 clear the selected callsign from the Logbook Entry Window.

If after I recall that DX station (doble click again on the DX Station)Loggre32 put again the DX station callsign into Logbook Entry Window and QRZ lookup start once again.

This is the example on WSJT-X:
Inline image


This happens with WSJT-X and not with JTDX (probably because JTDX did not send via UDP the message to immediately "clear" the Callsign).


Well, I think make more sense to leave the DX Station callsign into Logbook Entry Window until I will choose another DX Station to call or I click on a DX Spot of another station. I mean, do not clear the callsign into Logbook Entry Window if I did not decide it.


Thanks.


73s
Fabio, IZ8MBW



On Wednesday, March 24, 2021, 06:01:01 AM GMT+1, Gary Hinson <gary@...> wrote:


Hi Jerry.

 

We are currently beta testing a change that stops Logger32 erasing callsigns from the log entry pane when the UDP BandMap is open … since we normally operate split in FT8, and splits above 1 kHz were tripping the “Clear callsign on QSY > 1kHz setting” for those using it.

 

There are other changes & bug-fixes in the works, so it may take a wee while to complete the testing and release the next version.

 

I just hope it will cure your issue.

 

73

Gary  ZL2iFB

From: hamlogger@groups.io <hamlogger@groups.io> On Behalf Of Jerry Spring
Sent: 24 March 2021 17:04
To: hamlogger@groups.io
Subject: [hamlogger] Bandmap callsigns on WSJT-X not transferring to L32 Input Window

 

[Edited Message Follows]

I just upgraded from V3.5 to V4.0 and everything seemed to go perfectly.  Except that I can no longer double click on a callsign in the WSJT-X bandmap window and have it transferred to the Input "Call" field in L32.  The only field that does transfer is the Grid square.  So the UDP link is working.  I have the UDP server set to 127.0.0.1 in WSJT-X  with port 2238.  These are the same settings I see at the bottom of L32, when I hover over UDP.  What am I missing?  I also tried setting the port on both to 2237, with identical results. 

Thanks,

Jerry VE6TL


Gary Hinson
 

Hi Jerry.

 

OK, please [double] check your setups in both WSJT-X and Logger32 using chapter 15 of the Logger32 v4 User Manual

 

Here’s how the ‘manual calling’ sequence works, as I understand it:

  • WSJT-X receives and decodes messages, broadcasting the decoded messages to other programs via UDP using a specific UDP port
  • Logger32 receives the decodes via UDP on the specific UDP port, analyses them (e.g. for new ones and LoTW users) and displays them accordingly on the UDP BandMap
  • If you click an interesting callsign on the band map, a box soon appears around it …
  • … When Logger32 sees a decoded message indicating the interesting station is nearly finished or has finished a QSO, it sends the decoded message back to WSJT-X via UDP
  • WSJT-X receives the decode via UDP, populates the callsign field, composes the usual set of TX messages, and starts calling him
  • If the QSO completes, WSJT-X pops up the “Log QSO” form
  • Logger32 effectively clicks the “Log” button for you
  • WSJT-X broadcasts the logged QSO via UDP
  • Logger32 receives the logged QSO via UDP
  • Logger32 logs the QSO, optionally adding additional info from previous QSOs or online lookups

 

With the manual calling debug screen open (from the UDP BandMap menu), you should be able to see the sequence unfold – key steps at least.

 

You might also try using JTDX instead of WSJT-X.  JTDX works much the same, except it does not pop up the “Log QSO” form for Logger32 to click – provided it is set up to auto-log. 

 

73

Gary  ZL2iFB

 

From: hamlogger@groups.io <hamlogger@groups.io> On Behalf Of Jerry Spring
Sent: 25 March 2021 04:10
To: hamlogger@groups.io
Subject: Re: [hamlogger] Bandmap callsigns on WSJT-X not transferring to L32 Input Window

 

I turned off “Clear call sign on QSY > 1 KHz” and that did not solve the problem. I also noted that L32 no longer automatically logs the QSO, as it did before (the option is still selected).  I take it the two are connected. 


Jerry


Jerry Spring
 

I turned off “Clear call sign on QSY > 1 KHz” and that did not solve the problem. I also noted that L32 no longer automatically logs the QSO, as it did before (the option is still selected).  I take it the two are connected. 


Jerry


Gary Hinson
 

Hi Jerry.

 

We are currently beta testing a change that stops Logger32 erasing callsigns from the log entry pane when the UDP BandMap is open … since we normally operate split in FT8, and splits above 1 kHz were tripping the “Clear callsign on QSY > 1kHz setting” for those using it.

 

There are other changes & bug-fixes in the works, so it may take a wee while to complete the testing and release the next version.

 

I just hope it will cure your issue.

 

73

Gary  ZL2iFB

From: hamlogger@groups.io <hamlogger@groups.io> On Behalf Of Jerry Spring
Sent: 24 March 2021 17:04
To: hamlogger@groups.io
Subject: [hamlogger] Bandmap callsigns on WSJT-X not transferring to L32 Input Window

 

[Edited Message Follows]

I just upgraded from V3.5 to V4.0 and everything seemed to go perfectly.  Except that I can no longer double click on a callsign in the WSJT-X bandmap window and have it transferred to the Input "Call" field in L32.  The only field that does transfer is the Grid square.  So the UDP link is working.  I have the UDP server set to 127.0.0.1 in WSJT-X  with port 2238.  These are the same settings I see at the bottom of L32, when I hover over UDP.  What am I missing?  I also tried setting the port on both to 2237, with identical results. 

Thanks,

Jerry VE6TL


Jerry Spring
 
Edited

I just upgraded from V3.5 to V4.0 and everything seemed to go perfectly.  Except that I can no longer double click on a callsign in the WSJT-X bandmap window and have it transferred to the Input "Call" field in L32.  The only field that does transfer is the Grid square.  So the UDP link is working.  I have the UDP server set to 127.0.0.1 in WSJT-X  with port 2238.  These are the same settings I see at the bottom of L32, when I hover over UDP.  What am I missing?  I also tried setting the port on both to 2237, with identical results. 

Thanks,

Jerry VE6TL