Topics

4RE: [hamlogger] L32 and SDR Console

Rick Ellison
 

Hi Chuck..

Sorry for not responding sooner I had to set things back up so I could get the settings for you as I haven’t turned on my radio in about a month..

I’m using a 7300 and one virtual serial port.

 

1.       Open VSPE and create one virtual port in VSPE its called a connector. This is set to COM13.

2.       Load Logger32. In Logger32 I have the 7300 connected and Logger32 has full radio control over the radio

3.       Click on setup and then go to the radio setup window and select Slave Configuration. This is how my slave window is setup.

 

Note that I have COM13 the VSPE port set as the com port.

 

4.       Now open SDR Console and open up the options. In the options window you will want to click on Controllers and then CAT then port selection. Your Virtual port should be shown in the listing of ports available select it by placing a checkmark in the box. (If you want to make sure things are working correctly you can open the I/O Monitor and you should see the radio commands going by if they are connected.

 

After closing the options window the frequency in SDRC’s frequency display should show that of your radio in Logger32. This is a two-way connection. If you change the frequency in Logger32 the frequency should update in SDRC. If you change the frequency or mode in SDRC then Logger32 should update also.

Here is an image of my using SDRC within Logger32. I have an SDR-Play RSP1 connected to my computer that SDRC is getting its information from..

 

 

 

73 Rick N2AMG

 

From: hamlogger@groups.io [mailto:hamlogger@groups.io] On Behalf Of Chuck Miller
Sent: Tuesday, February 11, 2020 4:35 PM
To: hamlogger@groups.io
Subject: [hamlogger] L32 and SDR Console

 

How do I get L32 and SDR Console to talk to my FT-1000mp Mk V Field?
Logger32 does not work with Omnirig, but SDR Console seems to require it. SDR Console says use TS-2000 protocol, but logger32 does not have a selection for the TS-2000. Tried using VSPE, but no joy.

73, Chuck
N0NC

Bob
 

Thanks for the detailed description Rick. Simplicity itself (even I could understand it). This is an open request to all subscribers - How about a  YouTube video describing how to do this. Time to debunk the folklore and voodoo surrounding Logger32 and Omnirig. Yes, Omnirig and Logger32 do play together, but is it really necessary? SeventyThree(s).

On February 13, 2020 at 2:14 AM Rick Ellison <rellison@...> wrote:

Hi Chuck..

Sorry for not responding sooner I had to set things back up so I could get the settings for you as I haven’t turned on my radio in about a month..

I’m using a 7300 and one virtual serial port.

 

1.       Open VSPE and create one virtual port in VSPE its called a connector. This is set to COM13.

2.       Load Logger32. In Logger32 I have the 7300 connected and Logger32 has full radio control over the radio

3.       Click on setup and then go to the radio setup window and select Slave Configuration. This is how my slave window is setup.

 

Note that I have COM13 the VSPE port set as the com port.

 

4.       Now open SDR Console and open up the options. In the options window you will want to click on Controllers and then CAT then port selection. Your Virtual port should be shown in the listing of ports available select it by placing a checkmark in the box. (If you want to make sure things are working correctly you can open the I/O Monitor and you should see the radio commands going by if they are connected.

 

After closing the options window the frequency in SDRC’s frequency display should show that of your radio in Logger32. This is a two-way connection. If you change the frequency in Logger32 the frequency should update in SDRC. If you change the frequency or mode in SDRC then Logger32 should update also.

Here is an image of my using SDRC within Logger32. I have an SDR-Play RSP1 connected to my computer that SDRC is getting its information from..

 

 

 

73 Rick N2AMG

 

From: hamlogger@groups.io [mailto:hamlogger@groups.io] On Behalf Of Chuck Miller
Sent: Tuesday, February 11, 2020 4:35 PM
To: hamlogger@groups.io
Subject: [hamlogger] L32 and SDR Console

 

How do I get L32 and SDR Console to talk to my FT-1000mp Mk V Field?
Logger32 does not work with Omnirig, but SDR Console seems to require it. SDR Console says use TS-2000 protocol, but logger32 does not have a selection for the TS-2000. Tried using VSPE, but no joy.

73, Chuck
N0NC

 



 

Bob
 

... now how do you handle WSJT/JTDX into the mix? SeventyThree(s).

On February 13, 2020 at 2:14 AM Rick Ellison <rellison@...> wrote:

Hi Chuck..

Sorry for not responding sooner I had to set things back up so I could get the settings for you as I haven’t turned on my radio in about a month..

I’m using a 7300 and one virtual serial port.

 

1.       Open VSPE and create one virtual port in VSPE its called a connector. This is set to COM13.

2.       Load Logger32. In Logger32 I have the 7300 connected and Logger32 has full radio control over the radio

3.       Click on setup and then go to the radio setup window and select Slave Configuration. This is how my slave window is setup.

 

Note that I have COM13 the VSPE port set as the com port.

 

4.       Now open SDR Console and open up the options. In the options window you will want to click on Controllers and then CAT then port selection. Your Virtual port should be shown in the listing of ports available select it by placing a checkmark in the box. (If you want to make sure things are working correctly you can open the I/O Monitor and you should see the radio commands going by if they are connected.

 

After closing the options window the frequency in SDRC’s frequency display should show that of your radio in Logger32. This is a two-way connection. If you change the frequency in Logger32 the frequency should update in SDRC. If you change the frequency or mode in SDRC then Logger32 should update also.

Here is an image of my using SDRC within Logger32. I have an SDR-Play RSP1 connected to my computer that SDRC is getting its information from..

 

 

 

73 Rick N2AMG

 

From: hamlogger@groups.io [mailto:hamlogger@groups.io] On Behalf Of Chuck Miller
Sent: Tuesday, February 11, 2020 4:35 PM
To: hamlogger@groups.io
Subject: [hamlogger] L32 and SDR Console

 

How do I get L32 and SDR Console to talk to my FT-1000mp Mk V Field?
Logger32 does not work with Omnirig, but SDR Console seems to require it. SDR Console says use TS-2000 protocol, but logger32 does not have a selection for the TS-2000. Tried using VSPE, but no joy.

73, Chuck
N0NC

 



 

Rick Ellison
 

One thing that I did not mention is this same setup can also be used with SRDUno. You just need to enable the CAT port settings in the program and tell it what port to listen for the commands.

Not me doing any youtube videos. I have no camera setup here..

 

73 Rick N2AMG

 

From: hamlogger@groups.io [mailto:hamlogger@groups.io] On Behalf Of Bob
Sent: Thursday, February 13, 2020 7:56 AM
To: hamlogger@groups.io
Subject: Re: 4RE: [hamlogger] L32 and SDR Console

 

Thanks for the detailed description Rick. Simplicity itself (even I could understand it). This is an open request to all subscribers - How about a  YouTube video describing how to do this. Time to debunk the folklore and voodoo surrounding Logger32 and Omnirig. Yes, Omnirig and Logger32 do play together, but is it really necessary? SeventyThree(s).

On February 13, 2020 at 2:14 AM Rick Ellison <rellison@...> wrote:

Hi Chuck..

Sorry for not responding sooner I had to set things back up so I could get the settings for you as I haven’t turned on my radio in about a month..

I’m using a 7300 and one virtual serial port.

 

1.       Open VSPE and create one virtual port in VSPE its called a connector. This is set to COM13.

2.       Load Logger32. In Logger32 I have the 7300 connected and Logger32 has full radio control over the radio

3.       Click on setup and then go to the radio setup window and select Slave Configuration. This is how my slave window is setup.

 

Note that I have COM13 the VSPE port set as the com port.

 

4.       Now open SDR Console and open up the options. In the options window you will want to click on Controllers and then CAT then port selection. Your Virtual port should be shown in the listing of ports available select it by placing a checkmark in the box. (If you want to make sure things are working correctly you can open the I/O Monitor and you should see the radio commands going by if they are connected.

 

After closing the options window the frequency in SDRC’s frequency display should show that of your radio in Logger32. This is a two-way connection. If you change the frequency in Logger32 the frequency should update in SDRC. If you change the frequency or mode in SDRC then Logger32 should update also.

Here is an image of my using SDRC within Logger32. I have an SDR-Play RSP1 connected to my computer that SDRC is getting its information from..

 

 

 

73 Rick N2AMG

 

From: hamlogger@groups.io [mailto:hamlogger@groups.io] On Behalf Of Chuck Miller
Sent: Tuesday, February 11, 2020 4:35 PM
To: hamlogger@groups.io
Subject: [hamlogger] L32 and SDR Console

 

How do I get L32 and SDR Console to talk to my FT-1000mp Mk V Field?
Logger32 does not work with Omnirig, but SDR Console seems to require it. SDR Console says use TS-2000 protocol, but logger32 does not have a selection for the TS-2000. Tried using VSPE, but no joy.

73, Chuck
N0NC

 

 


 

Rick Ellison
 

I just don’t use SDRC if I am going to do WSJT. Since Logger32 closes the CAT port to WSJT the information would not be sent over to SDRC or SDRUno.

 

73 Rick N2AMG

 

From: hamlogger@groups.io [mailto:hamlogger@groups.io] On Behalf Of Bob
Sent: Thursday, February 13, 2020 8:00 AM
To: hamlogger@groups.io
Subject: Re: 4RE: [hamlogger] L32 and SDR Console

 

... now how do you handle WSJT/JTDX into the mix? SeventyThree(s).

On February 13, 2020 at 2:14 AM Rick Ellison <rellison@...> wrote:

Hi Chuck..

Sorry for not responding sooner I had to set things back up so I could get the settings for you as I haven’t turned on my radio in about a month..

I’m using a 7300 and one virtual serial port.

 

1.       Open VSPE and create one virtual port in VSPE its called a connector. This is set to COM13.

2.       Load Logger32. In Logger32 I have the 7300 connected and Logger32 has full radio control over the radio

3.       Click on setup and then go to the radio setup window and select Slave Configuration. This is how my slave window is setup.

 

Note that I have COM13 the VSPE port set as the com port.

 

4.       Now open SDR Console and open up the options. In the options window you will want to click on Controllers and then CAT then port selection. Your Virtual port should be shown in the listing of ports available select it by placing a checkmark in the box. (If you want to make sure things are working correctly you can open the I/O Monitor and you should see the radio commands going by if they are connected.

 

After closing the options window the frequency in SDRC’s frequency display should show that of your radio in Logger32. This is a two-way connection. If you change the frequency in Logger32 the frequency should update in SDRC. If you change the frequency or mode in SDRC then Logger32 should update also.

Here is an image of my using SDRC within Logger32. I have an SDR-Play RSP1 connected to my computer that SDRC is getting its information from..

 

 

 

73 Rick N2AMG

 

From: hamlogger@groups.io [mailto:hamlogger@groups.io] On Behalf Of Chuck Miller
Sent: Tuesday, February 11, 2020 4:35 PM
To: hamlogger@groups.io
Subject: [hamlogger] L32 and SDR Console

 

How do I get L32 and SDR Console to talk to my FT-1000mp Mk V Field?
Logger32 does not work with Omnirig, but SDR Console seems to require it. SDR Console says use TS-2000 protocol, but logger32 does not have a selection for the TS-2000. Tried using VSPE, but no joy.

73, Chuck
N0NC

 

 


 

Bob
 

I'm investigating a fix for that ... Take the Frequency sent over the UDP, generate/format a CAT frequency command message and send it to the slave port ... 73.

On February 13, 2020 at 11:29 AM Rick Ellison <rellison@...> wrote:

I just don’t use SDRC if I am going to do WSJT. Since Logger32 closes the CAT port to WSJT the information would not be sent over to SDRC or SDRUno.

 

73 Rick N2AMG

 

From: hamlogger@groups.io [mailto:hamlogger@groups.io] On Behalf Of Bob
Sent: Thursday, February 13, 2020 8:00 AM
To: hamlogger@groups.io
Subject: Re: 4RE: [hamlogger] L32 and SDR Console

 

... now how do you handle WSJT/JTDX into the mix? SeventyThree(s).

On February 13, 2020 at 2:14 AM Rick Ellison <rellison@...> wrote:

Hi Chuck..

Sorry for not responding sooner I had to set things back up so I could get the settings for you as I haven’t turned on my radio in about a month..

I’m using a 7300 and one virtual serial port.

 

1.       Open VSPE and create one virtual port in VSPE its called a connector. This is set to COM13.

2.       Load Logger32. In Logger32 I have the 7300 connected and Logger32 has full radio control over the radio

3.       Click on setup and then go to the radio setup window and select Slave Configuration. This is how my slave window is setup.

 

Note that I have COM13 the VSPE port set as the com port.

 

4.       Now open SDR Console and open up the options. In the options window you will want to click on Controllers and then CAT then port selection. Your Virtual port should be shown in the listing of ports available select it by placing a checkmark in the box. (If you want to make sure things are working correctly you can open the I/O Monitor and you should see the radio commands going by if they are connected.

 

After closing the options window the frequency in SDRC’s frequency display should show that of your radio in Logger32. This is a two-way connection. If you change the frequency in Logger32 the frequency should update in SDRC. If you change the frequency or mode in SDRC then Logger32 should update also.

Here is an image of my using SDRC within Logger32. I have an SDR-Play RSP1 connected to my computer that SDRC is getting its information from..

 

 

 

73 Rick N2AMG

 

From: hamlogger@groups.io [mailto:hamlogger@groups.io] On Behalf Of Chuck Miller
Sent: Tuesday, February 11, 2020 4:35 PM
To: hamlogger@groups.io
Subject: [hamlogger] L32 and SDR Console

 

How do I get L32 and SDR Console to talk to my FT-1000mp Mk V Field?
Logger32 does not work with Omnirig, but SDR Console seems to require it. SDR Console says use TS-2000 protocol, but logger32 does not have a selection for the TS-2000. Tried using VSPE, but no joy.

73, Chuck
N0NC

 

 


 

 



 

Bob
 

Rick, it's already working, guess I already coded for it. When Logger32 relinquishes radio control to WSJT/JTDX, Logger32 takes the WSJT/JTDX frequency from the UDP StatusOut message constructs a set frequency/mode message in the appropriate slave radio format and sends it. So, your ultra high def eye candy machine should still follow the radio as you snag those rare and exotic 77 byte (or whatever they are) QSOs. Give it a whirl. The attached picture is what was sent to the slave when I changed JTDX from FT8 to FT4 (no Logger32 CAT control connected). SeventyThree(s).


On February 13, 2020 at 11:46 AM Bob <k4cy@...> wrote:

I'm investigating a fix for that ... Take the Frequency sent over the UDP, generate/format a CAT frequency command message and send it to the slave port ... 73.
On February 13, 2020 at 11:29 AM Rick Ellison <rellison@...> wrote:

I just don’t use SDRC if I am going to do WSJT. Since Logger32 closes the CAT port to WSJT the information would not be sent over to SDRC or SDRUno.

 

73 Rick N2AMG

 

From: hamlogger@groups.io [mailto:hamlogger@groups.io] On Behalf Of Bob
Sent: Thursday, February 13, 2020 8:00 AM
To: hamlogger@groups.io
Subject: Re: 4RE: [hamlogger] L32 and SDR Console

 

... now how do you handle WSJT/JTDX into the mix? SeventyThree(s).

On February 13, 2020 at 2:14 AM Rick Ellison <rellison@...> wrote:

Hi Chuck..

Sorry for not responding sooner I had to set things back up so I could get the settings for you as I haven’t turned on my radio in about a month..

I’m using a 7300 and one virtual serial port.

 

1.       Open VSPE and create one virtual port in VSPE its called a connector. This is set to COM13.

2.       Load Logger32. In Logger32 I have the 7300 connected and Logger32 has full radio control over the radio

3.       Click on setup and then go to the radio setup window and select Slave Configuration. This is how my slave window is setup.

 

Note that I have COM13 the VSPE port set as the com port.

 

4.       Now open SDR Console and open up the options. In the options window you will want to click on Controllers and then CAT then port selection. Your Virtual port should be shown in the listing of ports available select it by placing a checkmark in the box. (If you want to make sure things are working correctly you can open the I/O Monitor and you should see the radio commands going by if they are connected.

 

After closing the options window the frequency in SDRC’s frequency display should show that of your radio in Logger32. This is a two-way connection. If you change the frequency in Logger32 the frequency should update in SDRC. If you change the frequency or mode in SDRC then Logger32 should update also.

Here is an image of my using SDRC within Logger32. I have an SDR-Play RSP1 connected to my computer that SDRC is getting its information from..

 

 

 

73 Rick N2AMG

 

From: hamlogger@groups.io [mailto:hamlogger@groups.io] On Behalf Of Chuck Miller
Sent: Tuesday, February 11, 2020 4:35 PM
To: hamlogger@groups.io
Subject: [hamlogger] L32 and SDR Console

 

How do I get L32 and SDR Console to talk to my FT-1000mp Mk V Field?
Logger32 does not work with Omnirig, but SDR Console seems to require it. SDR Console says use TS-2000 protocol, but logger32 does not have a selection for the TS-2000. Tried using VSPE, but no joy.

73, Chuck
N0NC

 

 


 

 



 

 

Rick Ellison
 

Ok I will try this a bit later have to go spend some more $$ with the wife..

73

 

From: hamlogger@groups.io [mailto:hamlogger@groups.io] On Behalf Of Bob
Sent: Thursday, February 13, 2020 12:28 PM
To: hamlogger@groups.io
Subject: Re: 4RE: [hamlogger] L32 and SDR Console

 

Rick, it's already working, guess I already coded for it. When Logger32 relinquishes radio control to WSJT/JTDX, Logger32 takes the WSJT/JTDX frequency from the UDP StatusOut message constructs a set frequency/mode message in the appropriate slave radio format and sends it. So, your ultra high def eye candy machine should still follow the radio as you snag those rare and exotic 77 byte (or whatever they are) QSOs. Give it a whirl. The attached picture is what was sent to the slave when I changed JTDX from FT8 to FT4 (no Logger32 CAT control connected). SeventyThree(s).

 

On February 13, 2020 at 11:46 AM Bob <k4cy@...> wrote:

I'm investigating a fix for that ... Take the Frequency sent over the UDP, generate/format a CAT frequency command message and send it to the slave port ... 73.

On February 13, 2020 at 11:29 AM Rick Ellison <rellison@...> wrote:

I just don’t use SDRC if I am going to do WSJT. Since Logger32 closes the CAT port to WSJT the information would not be sent over to SDRC or SDRUno.

 

73 Rick N2AMG

 

From: hamlogger@groups.io [mailto:hamlogger@groups.io] On Behalf Of Bob
Sent: Thursday, February 13, 2020 8:00 AM
To: hamlogger@groups.io
Subject: Re: 4RE: [hamlogger] L32 and SDR Console

 

... now how do you handle WSJT/JTDX into the mix? SeventyThree(s).

On February 13, 2020 at 2:14 AM Rick Ellison <rellison@...> wrote:

Hi Chuck..

Sorry for not responding sooner I had to set things back up so I could get the settings for you as I haven’t turned on my radio in about a month..

I’m using a 7300 and one virtual serial port.

 

1.       Open VSPE and create one virtual port in VSPE its called a connector. This is set to COM13.

2.       Load Logger32. In Logger32 I have the 7300 connected and Logger32 has full radio control over the radio

3.       Click on setup and then go to the radio setup window and select Slave Configuration. This is how my slave window is setup.

 

Note that I have COM13 the VSPE port set as the com port.

 

4.       Now open SDR Console and open up the options. In the options window you will want to click on Controllers and then CAT then port selection. Your Virtual port should be shown in the listing of ports available select it by placing a checkmark in the box. (If you want to make sure things are working correctly you can open the I/O Monitor and you should see the radio commands going by if they are connected.

 

After closing the options window the frequency in SDRC’s frequency display should show that of your radio in Logger32. This is a two-way connection. If you change the frequency in Logger32 the frequency should update in SDRC. If you change the frequency or mode in SDRC then Logger32 should update also.

Here is an image of my using SDRC within Logger32. I have an SDR-Play RSP1 connected to my computer that SDRC is getting its information from..

 

 

 

73 Rick N2AMG

 

From: hamlogger@groups.io [mailto:hamlogger@groups.io] On Behalf Of Chuck Miller
Sent: Tuesday, February 11, 2020 4:35 PM
To: hamlogger@groups.io
Subject: [hamlogger] L32 and SDR Console

 

How do I get L32 and SDR Console to talk to my FT-1000mp Mk V Field?
Logger32 does not work with Omnirig, but SDR Console seems to require it. SDR Console says use TS-2000 protocol, but logger32 does not have a selection for the TS-2000. Tried using VSPE, but no joy.

73, Chuck
N0NC

 

 


 

 

 


 


 

Chuck Miller
 

Thanks Rick; I'll give that a try. I thought I had already, but I was changing so many things, I'll follow your example exactly. Been away for a few days at the VA hospital. I'll report back after I try your example.
73, Chuck
N0NC

Chuck Miller
 

Rick I tried exactly what you said, right down to the port numbers. It doesn't work. In fact, it interferes with L32 controlling the rig (can't change modes ect.) until I close sdr-console. I think I'll unplug all the USB cables and try a different USB to RS-232 convertor on the radio to see if that changes any thing.
Thanks again for you help.
73,
Chuck
N0NC

Bob
 

What do you see in the Slave Debug window? From what you describe, it sounds like the SDR is replying to polls, but not responding to commands. You should be able to see this in the Slave Debug Window. Also, if you look at the Slave Port Setup Window (Click SETUP | RADIO | SLAVE PORT CONFIGURATION), you will see an option to ENABLE POLLING OF THE SLAVE RECEIVER/TRANSCEIVER ... As a temporary test, UNcheck this option and click APPLY. This will turn off the polling of the SDR and temporarily allow you to focus on the commands from Logger32 to set the SDR frequency/mode. Once you have that squared away, you can get fancy. SeventyThree(s).

On February 14, 2020 at 11:08 PM Chuck Miller <cwmiller20@...> wrote:

Rick I tried exactly what you said, right down to the port numbers. It doesn't work. In fact, it interferes with L32 controlling the rig (can't change modes ect.) until I close sdr-console. I think I'll unplug all the USB cables and try a different USB to RS-232 convertor on the radio to see if that changes any thing.
Thanks again for you help.
73,
Chuck
N0NC

 

Bob
 

... and to follow up, if/when you turn off slave polling, on the Slave Debug Window you should see only command messages from the radio to the SDR when the radio changes frequency/mode. SeventyThree(s).

On February 15, 2020 at 12:51 AM Bob <k4cy@...> wrote:

What do you see in the Slave Debug window? From what you describe, it sounds like the SDR is replying to polls, but not responding to commands. You should be able to see this in the Slave Debug Window. Also, if you look at the Slave Port Setup Window (Click SETUP | RADIO | SLAVE PORT CONFIGURATION), you will see an option to ENABLE POLLING OF THE SLAVE RECEIVER/TRANSCEIVER ... As a temporary test, UNcheck this option and click APPLY. This will turn off the polling of the SDR and temporarily allow you to focus on the commands from Logger32 to set the SDR frequency/mode. Once you have that squared away, you can get fancy. SeventyThree(s).
On February 14, 2020 at 11:08 PM Chuck Miller <cwmiller20@...> wrote:

Rick I tried exactly what you said, right down to the port numbers. It doesn't work. In fact, it interferes with L32 controlling the rig (can't change modes ect.) until I close sdr-console. I think I'll unplug all the USB cables and try a different USB to RS-232 convertor on the radio to see if that changes any thing.
Thanks again for you help.
73,
Chuck
N0NC

 

 

Chuck Miller
 

Bob and Rick, I've tried all the things you've suggested, and some times it looks like it's trying to work, but L32 keeps flashing a message that band plan has no entries for 142.619375 mhz, which is the same freq that  sdr-console is trying to listen to. Also I can't change modes on the ft1000mp field, sdr console keeps changing it right back. also sdr-console recieves no rf unless the Yaesu is talking to omni-rig. I tried a splitter virtual serial port but same thing, both programs change frequency at random.  The whole thing is a waste of time, having spent days trying to figure it out, I've come to the conclusion that Sdr-console is a fine program, and Logger32 is my favorite logger. But they just won't work together with the FT1000MP Mkv field. So unless someone with the exact same setup wants to provide some help, I just going to can SDR-console and stick with L32.

Bob
 

"So close, yet so far" (from the Elvis Presley song). Chuck, you have demonstrated that the slave port setup is correct - The SDR responds to Logger32 polls and tries to put the FT-1000 on 142 MHz. As far as I can tell, all that is missing is to find out why the SDR is not responding to frequency/mode commands. Easy to take the next step ... Please do this test step by step and report on your observation ...

1) Turn ON the option THE SLAVE PORT SYNCHRONIZES A SECOND .... Turn OFF the ENABLE POLLING OF THE SLAVE PORT ... option, and finally turn ON the SLAVE FOLLOWS VFO A option in the Slave port configuration window. Click APPLY.

2) With both the FT-1000 and the SDR running, open the Slave port debug window. You should see nothing hsppening.  Please confirm this.

3) Change the VFO frequency on the FT-1000. Confirm three things:
    a) The radio changes frequency
    b) The frequency shown in the Logbook Entry Window changes
    c)  You see commands from Logger32 to the slave radio like this



73.

On February 16, 2020 at 9:48 PM Chuck Miller <cwmiller20@...> wrote:

Bob and Rick, I've tried all the things you've suggested, and some times it looks like it's trying to work, but L32 keeps flashing a message that band plan has no entries for 142.619375 mhz, which is the same freq that  sdr-console is trying to listen to. Also I can't change modes on the ft1000mp field, sdr console keeps changing it right back. also sdr-console recieves no rf unless the Yaesu is talking to omni-rig. I tried a splitter virtual serial port but same thing, both programs change frequency at random.  The whole thing is a waste of time, having spent days trying to figure it out, I've come to the conclusion that Sdr-console is a fine program, and Logger32 is my favorite logger. But they just won't work together with the FT1000MP Mkv field. So unless someone with the exact same setup wants to provide some help, I just going to can SDR-console and stick with L32.

 

Chuck Miller
 
Edited

Step 1 Done
Step 2 Done nothing happens
Step 3 a. yes
           b. yes
           c.
      
           d. sdr-cosole tunes to 7.030.005.625
           e. SDR-COnsole recieves no rf

73, Chuck
N0NC

Bob
 

Chuck, another step closer, but still not quite there. Notice that the commands are unstable - Some are FA07xxxx, some are 007xxxx, and  some are FA00007xxxx. If the FT-1000 on 40M, they should all be FA00007xxxx. So, why the instability? What is the poll period set in your FT-1000 configuration? Maybe it's too fast. As an experiment, temporarily set it to 200ms (you can always crank it back up later). SeventyThree(s).

On February 17, 2020 at 11:31 AM Chuck Miller <cwmiller20@...> wrote:

Step 1 Done
Step 2 Done nothing happens
Step 3 a. yes
           b. yes
           c.
      
           d. sdr-cosole tunes to 7.030.005.625

73, Chuck
N0NC

 

Chuck Miller
 

Actually it was set to 600 ms. I changed it 100 ms, and then 200 ms as you asked, same result erratic data sent to SDR

73, cHUCK
N0NC

Chuck Miller
 

I even slowed the baud rate on both ends to 4800, (same as the ft1000mp), but still get erratic results.
N0NC

Bob
 

Chuck, clearly that's your problem, but I can't duplicate it here by simulation. I have been through the code line by line but don't see anything wrong. I assume that the radio debug window monitoring the FT-1000 CAT is showing stable results. Can you take a picture for me showing polls of the radio and replies while turning the VFO. If you could stretch the window vertically so several poll replies are visible. Thanks, 73.

On February 17, 2020 at 12:03 PM Chuck Miller <cwmiller20@...> wrote:

Actually it was set to 600 ms. I changed it 100 ms, and then 200 ms as you asked, same result erratic data sent to SDR

73, cHUCK
N0NC

 

Chuck Miller
 

Here's the radio debug window;


and here's the slave debug window;


I've changed to use a different USB to RS-232 adapter cable.
73, Chuck
N0NC