Topics

Time Series data request error

Nathan Paul
 

Hi All,

I am a newbie. I just setup grafana with graphite data source and graph is blank with time series data request error. How to go forward with the issue. Both are running on different hosts. Like to move later to the same host.

datasources: {
        graphite: {
          type: 'graphite',
          url: "http://172.31.1.146:80",
          default: true,
          render_method: 'GET',
        }
      },


Changed the max results to 10.  still I see the same issue.

appreciate the help.

Thanks,

NP



 

open chrome dev tools to i spect the error you get when querying graphite. Please read the grafana troubleshooting guide (in the docs). Your problem is probably CORS related.

Den 20 mar 2015 20:38 skrev "Nathan Paul" <nathan.paul8@...>:

Hi All,

I am a newbie. I just setup grafana with graphite data source and graph is blank with time series data request error. How to go forward with the issue. Both are running on different hosts. Like to move later to the same host.

datasources: {
        graphite: {
          type: 'graphite',
          url: "http://172.31.1.146:80",
          default: true,
          render_method: 'GET',
        }
      },


Changed the max results to 10.  still I see the same issue.

appreciate the help..

Thanks,

NP



Nathan Paul
 

Not sure CORS is the problem. Server is on AWS. I am seeing 401 not found for localhost.

If I give public i/p it is working. with 127.0.0.1  see 401 error in grafana.

graphite: {
          type: 'graphite',
          url: "http://127.0.0.1:80",
          render_method: 'GET',
          default: true
        },


All apache listeners are configured with the following. graphite on 80 and grafana on 8080.

Header set Access-Control-Allow-Origin "*"
        Header set Access-Control-Allow-Methods "GET, OPTIONS"
        Header set Access-Control-Allow-Headers "origin, authorization, accept"

Appreciate any advise.


Thanks,

NP

On Sat, Mar 21, 2015 at 3:20 AM, Torkel Ödegaard <torkel.odegaard@...> wrote:

open chrome dev tools to i spect the error you get when querying graphite. Please read the grafana troubleshooting guide (in the docs). Your problem is probably CORS related.

Den 20 mar 2015 20:38 skrev "Nathan Paul" <nathan.paul8@...>:
Hi All,

I am a newbie. I just setup grafana with graphite data source and graph is blank with time series data request error. How to go forward with the issue. Both are running on different hosts. Like to move later to the same host.

datasources: {
        graphite: {
          type: 'graphite',
          url: "http://172.31.1.146:80",
          default: true,
          render_method: 'GET',
        }
      },


Changed the max results to 10.  still I see the same issue.

appreciate the help..

Thanks,

NP



 

You need a public IP, graphite is accessed from your browser.. Grafana 1.x is a frontend only app, the forthcoming Grafana 2 comes with its own backend that can proxy data sources request (if you do not want to expose graphite)

Den 26 mar 2015 01:43 skrev "Nathan Paul" <nathan.paul8@...>:

Not sure CORS is the problem. Server is on AWS. I am seeing 401 not found for localhost.

If I give public i/p it is working. with 127.0.0.1  see 401 error in grafana.

graphite: {
          type: 'graphite',
          url: "http://127.0.0.1:80",
          render_method: 'GET',
          default: true
        },


All apache listeners are configured with the following. graphite on 80 and grafana on 8080.

Header set Access-Control-Allow-Origin "*"
        Header set Access-Control-Allow-Methods "GET, OPTIONS"
        Header set Access-Control-Allow-Headers "origin, authorization, accept"

Appreciate any advise.


Thanks,

NP

On Sat, Mar 21, 2015 at 3:20 AM, Torkel Ödegaard <torkel.odegaard@...> wrote:

open chrome dev tools to i spect the error you get when querying graphite. Please read the grafana troubleshooting guide (in the docs). Your problem is probably CORS related.

Den 20 mar 2015 20:38 skrev "Nathan Paul" <nathan.paul8@...>:
Hi All,

I am a newbie. I just setup grafana with graphite data source and graph is blank with time series data request error. How to go forward with the issue. Both are running on different hosts. Like to move later to the same host.

datasources: {
        graphite: {
          type: 'graphite',
          url: "http://172.31.1.146:80",
          default: true,
          render_method: 'GET',
        }
      },


Changed the max results to 10.  still I see the same issue.

appreciate the help..

Thanks,

NP




Nathan Paul
 

Thanks for the  clarification.

NP

On Wed, Mar 25, 2015 at 8:58 PM, Torkel Ödegaard <torkel.odegaard@...> wrote:

You need a public IP, graphite is accessed from your browser.. Grafana 1..x is a frontend only app, the forthcoming Grafana 2 comes with its own backend that can proxy data sources request (if you do not want to expose graphite)

Den 26 mar 2015 01:43 skrev "Nathan Paul" <nathan.paul8@...>:

Not sure CORS is the problem. Server is on AWS. I am seeing 401 not found for localhost.

If I give public i/p it is working. with 127.0.0.1  see 401 error in grafana.

graphite: {
          type: 'graphite',
          url: "http://127.0.0.1:80",
          render_method: 'GET',
          default: true
        },


All apache listeners are configured with the following. graphite on 80 and grafana on 8080.

Header set Access-Control-Allow-Origin "*"
        Header set Access-Control-Allow-Methods "GET, OPTIONS"
        Header set Access-Control-Allow-Headers "origin, authorization, accept"

Appreciate any advise.


Thanks,

NP

On Sat, Mar 21, 2015 at 3:20 AM, Torkel Ödegaard <torkel.odegaard@...> wrote:

open chrome dev tools to i spect the error you get when querying graphite. Please read the grafana troubleshooting guide (in the docs). Your problem is probably CORS related.

Den 20 mar 2015 20:38 skrev "Nathan Paul" <nathan.paul8@...>:
Hi All,

I am a newbie. I just setup grafana with graphite data source and graph is blank with time series data request error. How to go forward with the issue. Both are running on different hosts. Like to move later to the same host.

datasources: {
        graphite: {
          type: 'graphite',
          url: "http://172.31.1.146:80",
          default: true,
          render_method: 'GET',
        }
      },


Changed the max results to 10.  still I see the same issue.

appreciate the help..

Thanks,

NP