Topics

Installing GATE Developer 8.6 on Windows 10.

John Pashley
 

Hi.
I have installed the Platform-specific installer for Windows.
Everything installed normally but when starting the application the "Message" field filled with the error message below before it finally stopped.
Any ideas?
John
:
used by: org.eclipse.aether.transfer.ArtifactTransferException: Could not transfer artifact uk.ac.gate.plugins:tagger-chemistry:jar:creole:8.6 from/to central (http://repo1.maven.org/maven2/): HTTPS Required (501)
 at org.eclipse.aether.connector.basic.ArtifactTransportListener.transferFailed(ArtifactTransportListener.java:52)
 at org.eclipse.aether.connector.basic.BasicRepositoryConnector$TaskRunner.run(BasicRepositoryConnector.java:365)
 at org.eclipse.aether.util.concurrency.RunnableErrorForwarder$1.run(RunnableErrorForwarder.java:75)
 at org.eclipse.aether.connector.basic.BasicRepositoryConnector$DirectExecutor.execute(BasicRepositoryConnector.java:583)
 at org.eclipse.aether.connector.basic.BasicRepositoryConnector.get(BasicRepositoryConnector.java:259)
 at org.eclipse.aether.internal.impl.DefaultArtifactResolver.performDownloads(DefaultArtifactResolver.java:498)
 at org.eclipse.aether.internal.impl.DefaultArtifactResolver.resolve(DefaultArtifactResolver.java:399)
 ... 14 more

until

Caused by: org.apache.http.client.HttpResponseException: HTTPS Required (501)
 at org.eclipse.aether.transport.http.HttpTransporter.handleStatus(HttpTransporter.java:475)
 at org.eclipse.aether.transport.http.HttpTransporter.execute(HttpTransporter.java:300)
 at org.eclipse.aether.transport.http.HttpTransporter.implGet(HttpTransporter.java:252)
 at org.eclipse.aether.spi.connector.transport.AbstractTransporter.get(AbstractTransporter.java:67)
 at org.eclipse.aether.connector.basic.BasicRepositoryConnector$GetTaskRunner.runTask(BasicRepositoryConnector.java:453)
 at org.eclipse.aether.connector.basic.BasicRepositoryConnector$TaskRunner.run(BasicRepositoryConnector.java:360)
 ... 20 more

Lamiece
 

I also got this message on installation today

 

From: gate-users@groups.io <gate-users@groups.io> On Behalf Of John Pashley
Sent: 16 January 2020 11:09
To: gate-users@groups.io
Subject: [gate-users] Installing GATE Developer 8.6 on Windows 10.

 

Hi.
I have installed the Platform-specific installer for Windows.
Everything installed normally but when starting the application the "Message" field filled with the error message below before it finally stopped.
Any ideas?
John
:
used by: org.eclipse.aether.transfer.ArtifactTransferException: Could not transfer artifact uk.ac.gate.plugins:tagger-chemistry:jar:creole:8.6 from/to central (http://repo1.maven.org/maven2/): HTTPS Required (501)
 at org.eclipse.aether.connector.basic.ArtifactTransportListener.transferFailed(ArtifactTransportListener.java:52)
 at org.eclipse.aether.connector.basic.BasicRepositoryConnector$TaskRunner.run(BasicRepositoryConnector.java:365)
 at org.eclipse.aether.util.concurrency.RunnableErrorForwarder$1.run(RunnableErrorForwarder.java:75)
 at org.eclipse.aether.connector.basic.BasicRepositoryConnector$DirectExecutor.execute(BasicRepositoryConnector.java:583)
 at org.eclipse.aether.connector.basic.BasicRepositoryConnector.get(BasicRepositoryConnector.java:259)
 at org.eclipse.aether.internal.impl.DefaultArtifactResolver.performDownloads(DefaultArtifactResolver.java:498)
 at org.eclipse.aether.internal.impl.DefaultArtifactResolver.resolve(DefaultArtifactResolver.java:399)
 ... 14 more

until

Caused by: org.apache.http.client.HttpResponseException: HTTPS Required (501)
 at org.eclipse.aether.transport.http.HttpTransporter.handleStatus(HttpTransporter.java:475)
 at org.eclipse.aether.transport.http.HttpTransporter.execute(HttpTransporter.java:300)
 at org.eclipse.aether.transport.http.HttpTransporter.implGet(HttpTransporter.java:252)
 at org.eclipse.aether.spi.connector.transport.AbstractTransporter.get(AbstractTransporter.java:67)
 at org.eclipse.aether.connector.basic.BasicRepositoryConnector$GetTaskRunner.runTask(BasicRepositoryConnector.java:453)
 at org.eclipse.aether.connector.basic.BasicRepositoryConnector$TaskRunner.run(BasicRepositoryConnector.java:360)
 ... 20 more

Ian Roberts
 

Hi John,

Thanks for flagging this up - it is due to the fact that Sonatype (who run the central Maven repository) have just yesterday disabled access to that repository over un-encrypted http.  The next release of GATE will use https by default for the central repository but for earlier versions of GATE which hard-code the http:// URL you need to add a Maven configuration file to make it use the https URL for the repository.

Create a file called "settings.xml" in your GATE installation folder (alongside gate.exe and gate.l4j.ini) with the following contents:

<settings xmlns="http://maven.apache.org/SETTINGS/1.0.0"
  xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
  xsi:schemaLocation="http://maven.apache.org/SETTINGS/1.0.0
                      http://maven.apache.org/xsd/settings-1.0.0.xsd">

  <mirrors>
    <mirror>
      <id>https-central</id>
      <name>Central Repo (HTTPS)</name>
      <url>https://repo1.maven.org/maven2/</url>
      <mirrorOf>central</mirrorOf>
    </mirror>
  </mirrors>
</settings>

Then add the following line to gate.l4j.ini:

-DM2_SETTINGS_XML=%EXEDIR%\settings.xml

With these changes, GATE should be able to load plugins correctly.

For Linux & Mac users, the "EXEDIR" trick doesn't work, so you will have to enter the full path to settings.xml in your gate.l4j.ini, e.g.

-DM2_SETTINGS_XML=/Applications/GATE_Developer_8.6/settings.xml

Like I say, this will be fixed properly in the next GATE release, which is due in a few weeks time.

Ian

On 16/01/2020 11:09, John Pashley wrote:
Hi.
I have installed the Platform-specific installer for Windows.
Everything installed normally but when starting the application the "Message" field filled with the error message below before it finally stopped.
Any ideas?
John
:
used by: org.eclipse.aether.transfer.ArtifactTransferException: Could not transfer artifact uk.ac.gate.plugins:tagger-chemistry:jar:creole:8.6 from/to central (http://repo1.maven.org/maven2/): HTTPS Required (501)
 at org.eclipse.aether.connector.basic.ArtifactTransportListener.transferFailed(ArtifactTransportListener.java:52)
 at org.eclipse.aether.connector.basic.BasicRepositoryConnector$TaskRunner.run(BasicRepositoryConnector.java:365)
 at org.eclipse.aether.util.concurrency.RunnableErrorForwarder$1.run(RunnableErrorForwarder.java:75)
 at org.eclipse.aether.connector.basic.BasicRepositoryConnector$DirectExecutor.execute(BasicRepositoryConnector.java:583)
 at org.eclipse.aether.connector.basic.BasicRepositoryConnector.get(BasicRepositoryConnector.java:259)
 at org.eclipse.aether.internal.impl.DefaultArtifactResolver.performDownloads(DefaultArtifactResolver.java:498)
 at org.eclipse.aether.internal.impl.DefaultArtifactResolver.resolve(DefaultArtifactResolver.java:399)
 ... 14 more

until

Caused by: org.apache.http.client.HttpResponseException: HTTPS Required (501)
 at org.eclipse.aether.transport.http.HttpTransporter.handleStatus(HttpTransporter.java:475)
 at org.eclipse.aether.transport.http.HttpTransporter.execute(HttpTransporter.java:300)
 at org.eclipse.aether.transport.http.HttpTransporter.implGet(HttpTransporter.java:252)
 at org.eclipse.aether.spi.connector.transport.AbstractTransporter.get(AbstractTransporter.java:67)
 at org.eclipse.aether.connector.basic.BasicRepositoryConnector$GetTaskRunner.runTask(BasicRepositoryConnector.java:453)
 at org.eclipse.aether.connector.basic.BasicRepositoryConnector$TaskRunner.run(BasicRepositoryConnector.java:360)
 ... 20 more


-- 
Ian Roberts               | Department of Computer Science
i.roberts@...  | University of Sheffield, UK

John Pashley
 

Hi Ian.

Thanks for the information.

I followed your instructions to the letter adding the settings.xml and modifying the gate.l4j.ini files.

Unfortunately starting the app results in a brief (<1sec) display of the Gate logo and the program terminates.

Any more ideas?

John

 

From: gate-users@groups.io <gate-users@groups.io> On Behalf Of Ian Roberts
Sent: Thursday, 16 January 2020 13:41
To: gate-users@groups.io
Subject: Re: [gate-users] Installing GATE Developer 8.6 on Windows 10.

 

Hi John,

 

Thanks for flagging this up - it is due to the fact that Sonatype (who run the central Maven repository) have just yesterday disabled access to that repository over un-encrypted http.  The next release of GATE will use https by default for the central repository but for earlier versions of GATE which hard-code the http:// URL you need to add a Maven configuration file to make it use the https URL for the repository.

 

Create a file called "settings.xml" in your GATE installation folder (alongside gate.exe and gate.l4j.ini) with the following contents:

 

<settings xmlns="http://maven.apache.org/SETTINGS/1.0.0"
  xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
  xsi:schemaLocation="http://maven.apache.org/SETTINGS/1.0.0
                      http://maven.apache.org/xsd/settings-1.0.0.xsd">

  <mirrors>
    <mirror>
      <id>https-central</id>
      <name>Central Repo (HTTPS)</name>
      <url>https://repo1.maven.org/maven2/</url>
      <mirrorOf>central</mirrorOf>
    </mirror>
  </mirrors>
</settings>

 

Then add the following line to gate.l4j.ini:

 

-DM2_SETTINGS_XML=%EXEDIR%\settings.xml

 

With these changes, GATE should be able to load plugins correctly.

 

For Linux & Mac users, the "EXEDIR" trick doesn't work, so you will have to enter the full path to settings.xml in your gate.l4j.ini, e.g.

 

-DM2_SETTINGS_XML=/Applications/GATE_Developer_8.6/settings.xml

 

Like I say, this will be fixed properly in the next GATE release, which is due in a few weeks time.

 

Ian

 

On 16/01/2020 11:09, John Pashley wrote:

Hi.
I have installed the Platform-specific installer for Windows.
Everything installed normally but when starting the application the "Message" field filled with the error message below before it finally stopped.
Any ideas?
John
:
used by: org.eclipse.aether.transfer.ArtifactTransferException: Could not transfer artifact uk.ac.gate.plugins:tagger-chemistry:jar:creole:8.6 from/to central (http://repo1.maven.org/maven2/): HTTPS Required (501)
 at org.eclipse.aether.connector.basic.ArtifactTransportListener.transferFailed(ArtifactTransportListener.java:52)
 at org.eclipse.aether.connector.basic.BasicRepositoryConnector$TaskRunner.run(BasicRepositoryConnector.java:365)
 at org.eclipse.aether.util.concurrency.RunnableErrorForwarder$1.run(RunnableErrorForwarder.java:75)
 at org.eclipse.aether.connector.basic.BasicRepositoryConnector$DirectExecutor.execute(BasicRepositoryConnector.java:583)
 at org.eclipse.aether.connector.basic.BasicRepositoryConnector.get(BasicRepositoryConnector.java:259)
 at org.eclipse.aether.internal.impl.DefaultArtifactResolver.performDownloads(DefaultArtifactResolver.java:498)
 at org.eclipse.aether.internal.impl.DefaultArtifactResolver.resolve(DefaultArtifactResolver.java:399)
 ... 14 more

until

Caused by: org.apache.http.client.HttpResponseException: HTTPS Required (501)
 at org.eclipse.aether.transport.http.HttpTransporter.handleStatus(HttpTransporter.java:475)
 at org.eclipse.aether.transport.http.HttpTransporter.execute(HttpTransporter.java:300)
 at org.eclipse.aether.transport.http.HttpTransporter.implGet(HttpTransporter.java:252)
 at org.eclipse.aether.spi.connector.transport.AbstractTransporter.get(AbstractTransporter.java:67)
 at org.eclipse.aether.connector.basic.BasicRepositoryConnector$GetTaskRunner.runTask(BasicRepositoryConnector.java:453)
 at org.eclipse.aether.connector.basic.BasicRepositoryConnector$TaskRunner.run(BasicRepositoryConnector.java:360)
 ... 20 more

 

-- 
Ian Roberts               | Department of Computer Science
i.roberts@...  | University of Sheffield, UK

Ian Roberts
 

First thing I'd suggest trying is to put quotes around the extra line in the l4j.ini file

"-DM2_SETTINGS_XML=%EXEDIR%\settings.xml"

If that still doesn't work then try opening a command prompt, go to the GATE installation directory and run

gate.exe --l4j-debug

and send me the contents of the launch4j.log file (in a private mail off list, if you prefer).

Ian

On 16/01/2020 13:56, John Pashley wrote:

Hi Ian.

Thanks for the information.

I followed your instructions to the letter adding the settings.xml and modifying the gate.l4j.ini files.

Unfortunately starting the app results in a brief (<1sec) display of the Gate logo and the program terminates.

Any more ideas?

John

 

From: gate-users@groups.io <gate-users@groups.io> On Behalf Of Ian Roberts
Sent: Thursday, 16 January 2020 13:41
To: gate-users@groups.io
Subject: Re: [gate-users] Installing GATE Developer 8.6 on Windows 10.

 

Hi John,

 

Thanks for flagging this up - it is due to the fact that Sonatype (who run the central Maven repository) have just yesterday disabled access to that repository over un-encrypted http.  The next release of GATE will use https by default for the central repository but for earlier versions of GATE which hard-code the http:// URL you need to add a Maven configuration file to make it use the https URL for the repository.

 

Create a file called "settings.xml" in your GATE installation folder (alongside gate.exe and gate.l4j.ini) with the following contents:

 

<settings xmlns="http://maven.apache.org/SETTINGS/1.0.0"
  xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
  xsi:schemaLocation="http://maven.apache.org/SETTINGS/1.0.0
                      http://maven.apache.org/xsd/settings-1.0.0.xsd">

  <mirrors>
    <mirror>
      <id>https-central</id>
      <name>Central Repo (HTTPS)</name>
      <url>https://repo1.maven.org/maven2/</url>
      <mirrorOf>central</mirrorOf>
    </mirror>
  </mirrors>
</settings>

 

Then add the following line to gate.l4j.ini:

 

-DM2_SETTINGS_XML=%EXEDIR%\settings.xml

 

With these changes, GATE should be able to load plugins correctly.

 

For Linux & Mac users, the "EXEDIR" trick doesn't work, so you will have to enter the full path to settings.xml in your gate.l4j.ini, e.g.

 

-DM2_SETTINGS_XML=/Applications/GATE_Developer_8.6/settings.xml

 

Like I say, this will be fixed properly in the next GATE release, which is due in a few weeks time.

 

Ian

 

On 16/01/2020 11:09, John Pashley wrote:

Hi.
I have installed the Platform-specific installer for Windows.
Everything installed normally but when starting the application the "Message" field filled with the error message below before it finally stopped.
Any ideas?
John
:
used by: org.eclipse.aether.transfer.ArtifactTransferException: Could not transfer artifact uk.ac.gate.plugins:tagger-chemistry:jar:creole:8.6 from/to central (http://repo1.maven.org/maven2/): HTTPS Required (501)
 at org.eclipse.aether.connector.basic.ArtifactTransportListener.transferFailed(ArtifactTransportListener.java:52)
 at org.eclipse.aether.connector.basic.BasicRepositoryConnector$TaskRunner.run(BasicRepositoryConnector.java:365)
 at org.eclipse.aether.util.concurrency.RunnableErrorForwarder$1.run(RunnableErrorForwarder.java:75)
 at org.eclipse.aether.connector.basic.BasicRepositoryConnector$DirectExecutor.execute(BasicRepositoryConnector.java:583)
 at org.eclipse.aether.connector.basic.BasicRepositoryConnector.get(BasicRepositoryConnector.java:259)
 at org.eclipse.aether.internal.impl.DefaultArtifactResolver.performDownloads(DefaultArtifactResolver.java:498)
 at org.eclipse.aether.internal.impl.DefaultArtifactResolver.resolve(DefaultArtifactResolver.java:399)
 ... 14 more

until

Caused by: org.apache.http.client.HttpResponseException: HTTPS Required (501)
 at org.eclipse.aether.transport.http.HttpTransporter.handleStatus(HttpTransporter.java:475)
 at org.eclipse.aether.transport.http.HttpTransporter.execute(HttpTransporter.java:300)
 at org.eclipse.aether.transport.http.HttpTransporter.implGet(HttpTransporter.java:252)
 at org.eclipse.aether.spi.connector.transport.AbstractTransporter.get(AbstractTransporter.java:67)
 at org.eclipse.aether.connector.basic.BasicRepositoryConnector$GetTaskRunner.runTask(BasicRepositoryConnector.java:453)
 at org.eclipse.aether.connector.basic.BasicRepositoryConnector$TaskRunner.run(BasicRepositoryConnector.java:360)
 ... 20 more

 

-- 
Ian Roberts               | Department of Computer Science
i.roberts@...  | University of Sheffield, UK


-- 
Ian Roberts               | Department of Computer Science
i.roberts@...  | University of Sheffield, UK

John Pashley
 

Hi Ian.

Thanks!

Putting the quotes around the text seems to have fixed the problem.

The system now starts up as expected.

I’ll check out the various functions and advise on progress.

Have a nice day.

John

 

From: gate-users@groups.io <gate-users@groups.io> On Behalf Of Ian Roberts
Sent: Thursday, 16 January 2020 15:07
To: gate-users@groups.io
Subject: Re: [gate-users] Installing GATE Developer 8.6 on Windows 10.

 

First thing I'd suggest trying is to put quotes around the extra line in the l4j.ini file

 

"-DM2_SETTINGS_XML=%EXEDIR%\settings.xml"

 

If that still doesn't work then try opening a command prompt, go to the GATE installation directory and run

 

gate.exe --l4j-debug

 

and send me the contents of the launch4j.log file (in a private mail off list, if you prefer).

 

Ian

 

On 16/01/2020 13:56, John Pashley wrote:

Hi Ian.

Thanks for the information.

I followed your instructions to the letter adding the settings.xml and modifying the gate.l4j.ini files.

Unfortunately starting the app results in a brief (<1sec) display of the Gate logo and the program terminates.

Any more ideas?

John

 

From: gate-users@groups.io <gate-users@groups.io> On Behalf Of Ian Roberts
Sent: Thursday, 16 January 2020 13:41
To: gate-users@groups.io
Subject: Re: [gate-users] Installing GATE Developer 8.6 on Windows 10.

 

Hi John,

 

Thanks for flagging this up - it is due to the fact that Sonatype (who run the central Maven repository) have just yesterday disabled access to that repository over un-encrypted http.  The next release of GATE will use https by default for the central repository but for earlier versions of GATE which hard-code the http:// URL you need to add a Maven configuration file to make it use the https URL for the repository.

 

Create a file called "settings.xml" in your GATE installation folder (alongside gate.exe and gate.l4j.ini) with the following contents:

 

<settings xmlns="http://maven.apache.org/SETTINGS/1.0.0"
  xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
  xsi:schemaLocation="http://maven.apache.org/SETTINGS/1.0.0
                      http://maven.apache.org/xsd/settings-1.0.0.xsd">

  <mirrors>
    <mirror>
      <id>https-central</id>
      <name>Central Repo (HTTPS)</name>
      <url>https://repo1.maven.org/maven2/</url>
      <mirrorOf>central</mirrorOf>
    </mirror>
  </mirrors>
</settings>

 

Then add the following line to gate.l4j.ini:

 

-DM2_SETTINGS_XML=%EXEDIR%\settings.xml

 

With these changes, GATE should be able to load plugins correctly.

 

For Linux & Mac users, the "EXEDIR" trick doesn't work, so you will have to enter the full path to settings.xml in your gate.l4j.ini, e.g.

 

-DM2_SETTINGS_XML=/Applications/GATE_Developer_8.6/settings.xml

 

Like I say, this will be fixed properly in the next GATE release, which is due in a few weeks time.

 

Ian

 

On 16/01/2020 11:09, John Pashley wrote:

Hi.
I have installed the Platform-specific installer for Windows.
Everything installed normally but when starting the application the "Message" field filled with the error message below before it finally stopped.
Any ideas?
John
:
used by: org.eclipse.aether.transfer.ArtifactTransferException: Could not transfer artifact uk.ac.gate.plugins:tagger-chemistry:jar:creole:8.6 from/to central (http://repo1.maven.org/maven2/): HTTPS Required (501)
 at org.eclipse.aether.connector.basic.ArtifactTransportListener.transferFailed(ArtifactTransportListener.java:52)
 at org.eclipse.aether.connector.basic.BasicRepositoryConnector$TaskRunner.run(BasicRepositoryConnector.java:365)
 at org.eclipse.aether.util.concurrency.RunnableErrorForwarder$1.run(RunnableErrorForwarder.java:75)
 at org.eclipse.aether.connector.basic.BasicRepositoryConnector$DirectExecutor.execute(BasicRepositoryConnector.java:583)
 at org.eclipse.aether.connector.basic.BasicRepositoryConnector.get(BasicRepositoryConnector.java:259)
 at org.eclipse.aether.internal.impl.DefaultArtifactResolver.performDownloads(DefaultArtifactResolver.java:498)
 at org.eclipse.aether.internal.impl.DefaultArtifactResolver.resolve(DefaultArtifactResolver.java:399)
 ... 14 more

until

Caused by: org.apache.http.client.HttpResponseException: HTTPS Required (501)
 at org.eclipse.aether.transport.http.HttpTransporter.handleStatus(HttpTransporter.java:475)
 at org.eclipse.aether.transport.http.HttpTransporter.execute(HttpTransporter.java:300)
 at org.eclipse.aether.transport.http.HttpTransporter.implGet(HttpTransporter.java:252)
 at org.eclipse.aether.spi.connector.transport.AbstractTransporter.get(AbstractTransporter.java:67)
 at org.eclipse.aether.connector.basic.BasicRepositoryConnector$GetTaskRunner.runTask(BasicRepositoryConnector.java:453)
 at org.eclipse.aether.connector.basic.BasicRepositoryConnector$TaskRunner.run(BasicRepositoryConnector.java:360)
 ... 20 more

 

-- 
Ian Roberts               | Department of Computer Science
i.roberts@...  | University of Sheffield, UK

 

-- 
Ian Roberts               | Department of Computer Science
i.roberts@...  | University of Sheffield, UK

Ian Roberts
 

For anyone else who is hitting this, I've just released a GATE version 8.6.1, which is the same as 8.6 but now uses the https: URL by default and so does not require this workaround.

Ian

On 16/01/2020 12:40, Ian Roberts via Groups.Io wrote:
Hi John,

Thanks for flagging this up - it is due to the fact that Sonatype (who run the central Maven repository) have just yesterday disabled access to that repository over un-encrypted http.  The next release of GATE will use https by default for the central repository but for earlier versions of GATE which hard-code the http:// URL you need to add a Maven configuration file to make it use the https URL for the repository.

Create a file called "settings.xml" in your GATE installation folder (alongside gate.exe and gate.l4j.ini) with the following contents:

<settings xmlns="http://maven.apache.org/SETTINGS/1.0.0"
  xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
  xsi:schemaLocation="http://maven.apache.org/SETTINGS/1.0.0
                      http://maven.apache.org/xsd/settings-1.0.0.xsd">

  <mirrors>
    <mirror>
      <id>https-central</id>
      <name>Central Repo (HTTPS)</name>
      <url>https://repo1.maven.org/maven2/</url>
      <mirrorOf>central</mirrorOf>
    </mirror>
  </mirrors>
</settings>

Then add the following line to gate.l4j.ini:

-DM2_SETTINGS_XML=%EXEDIR%\settings.xml

With these changes, GATE should be able to load plugins correctly.

For Linux & Mac users, the "EXEDIR" trick doesn't work, so you will have to enter the full path to settings.xml in your gate.l4j.ini, e.g.

-DM2_SETTINGS_XML=/Applications/GATE_Developer_8.6/settings.xml

Like I say, this will be fixed properly in the next GATE release, which is due in a few weeks time.

Ian

On 16/01/2020 11:09, John Pashley wrote:
Hi.
I have installed the Platform-specific installer for Windows.
Everything installed normally but when starting the application the "Message" field filled with the error message below before it finally stopped.
Any ideas?
John
:
used by: org.eclipse.aether.transfer.ArtifactTransferException: Could not transfer artifact uk.ac.gate.plugins:tagger-chemistry:jar:creole:8.6 from/to central (http://repo1.maven.org/maven2/): HTTPS Required (501)
 at org.eclipse.aether.connector.basic.ArtifactTransportListener.transferFailed(ArtifactTransportListener.java:52)
 at org.eclipse.aether.connector.basic.BasicRepositoryConnector$TaskRunner.run(BasicRepositoryConnector.java:365)
 at org.eclipse.aether.util.concurrency.RunnableErrorForwarder$1.run(RunnableErrorForwarder.java:75)
 at org.eclipse.aether.connector.basic.BasicRepositoryConnector$DirectExecutor.execute(BasicRepositoryConnector.java:583)
 at org.eclipse.aether.connector.basic.BasicRepositoryConnector.get(BasicRepositoryConnector.java:259)
 at org.eclipse.aether.internal.impl.DefaultArtifactResolver.performDownloads(DefaultArtifactResolver.java:498)
 at org.eclipse.aether.internal.impl.DefaultArtifactResolver.resolve(DefaultArtifactResolver.java:399)
 ... 14 more

until

Caused by: org.apache.http.client.HttpResponseException: HTTPS Required (501)
 at org.eclipse.aether.transport.http.HttpTransporter.handleStatus(HttpTransporter.java:475)
 at org.eclipse.aether.transport.http.HttpTransporter.execute(HttpTransporter.java:300)
 at org.eclipse.aether.transport.http.HttpTransporter.implGet(HttpTransporter.java:252)
 at org.eclipse.aether.spi.connector.transport.AbstractTransporter.get(AbstractTransporter.java:67)
 at org.eclipse.aether.connector.basic.BasicRepositoryConnector$GetTaskRunner.runTask(BasicRepositoryConnector.java:453)
 at org.eclipse.aether.connector.basic.BasicRepositoryConnector$TaskRunner.run(BasicRepositoryConnector.java:360)
 ... 20 more


-- 
Ian Roberts               | Department of Computer Science
i.roberts@...  | University of Sheffield, UK


-- 
Ian Roberts               | Department of Computer Science
i.roberts@...  | University of Sheffield, UK

John Pashley
 

Thanks Ian.

What would you recommend? Stay with the workaround or uninstall and install 8.6.1?

John

 

From: gate-users@groups.io <gate-users@groups.io> On Behalf Of Ian Roberts
Sent: Friday, 17 January 2020 22:10
To: gate-users@groups.io
Subject: Re: [gate-users] Installing GATE Developer 8.6 on Windows 10.

 

For anyone else who is hitting this, I've just released a GATE version 8.6.1, which is the same as 8.6 but now uses the https: URL by default and so does not require this workaround.

 

Ian

 

On 16/01/2020 12:40, Ian Roberts via Groups.Io wrote:

Hi John,

 

Thanks for flagging this up - it is due to the fact that Sonatype (who run the central Maven repository) have just yesterday disabled access to that repository over un-encrypted http.  The next release of GATE will use https by default for the central repository but for earlier versions of GATE which hard-code the http:// URL you need to add a Maven configuration file to make it use the https URL for the repository.

 

Create a file called "settings.xml" in your GATE installation folder (alongside gate.exe and gate.l4j.ini) with the following contents:

 

<settings xmlns="http://maven.apache.org/SETTINGS/1.0.0"
  xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
  xsi:schemaLocation="http://maven.apache.org/SETTINGS/1.0.0
                      http://maven.apache.org/xsd/settings-1.0.0.xsd">

  <mirrors>
    <mirror>
      <id>https-central</id>
      <name>Central Repo (HTTPS)</name>
      <url>https://repo1.maven.org/maven2/</url>
      <mirrorOf>central</mirrorOf>
    </mirror>
  </mirrors>
</settings>

 

Then add the following line to gate.l4j.ini:

 

-DM2_SETTINGS_XML=%EXEDIR%\settings.xml

 

With these changes, GATE should be able to load plugins correctly.

 

For Linux & Mac users, the "EXEDIR" trick doesn't work, so you will have to enter the full path to settings.xml in your gate.l4j.ini, e.g.

 

-DM2_SETTINGS_XML=/Applications/GATE_Developer_8.6/settings.xml

 

Like I say, this will be fixed properly in the next GATE release, which is due in a few weeks time.

 

Ian

 

On 16/01/2020 11:09, John Pashley wrote:

Hi.
I have installed the Platform-specific installer for Windows.
Everything installed normally but when starting the application the "Message" field filled with the error message below before it finally stopped.
Any ideas?
John
:
used by: org.eclipse.aether.transfer.ArtifactTransferException: Could not transfer artifact uk.ac.gate.plugins:tagger-chemistry:jar:creole:8.6 from/to central (http://repo1.maven.org/maven2/): HTTPS Required (501)
 at org.eclipse.aether.connector.basic.ArtifactTransportListener.transferFailed(ArtifactTransportListener.java:52)
 at org.eclipse.aether.connector.basic.BasicRepositoryConnector$TaskRunner.run(BasicRepositoryConnector.java:365)
 at org.eclipse.aether.util.concurrency.RunnableErrorForwarder$1.run(RunnableErrorForwarder.java:75)
 at org.eclipse.aether.connector.basic.BasicRepositoryConnector$DirectExecutor.execute(BasicRepositoryConnector.java:583)
 at org.eclipse.aether.connector.basic.BasicRepositoryConnector.get(BasicRepositoryConnector.java:259)
 at org.eclipse.aether.internal.impl.DefaultArtifactResolver.performDownloads(DefaultArtifactResolver.java:498)
 at org.eclipse.aether.internal.impl.DefaultArtifactResolver.resolve(DefaultArtifactResolver.java:399)
 ... 14 more

until

Caused by: org.apache.http.client.HttpResponseException: HTTPS Required (501)
 at org.eclipse.aether.transport.http.HttpTransporter.handleStatus(HttpTransporter.java:475)
 at org.eclipse.aether.transport.http.HttpTransporter.execute(HttpTransporter.java:300)
 at org.eclipse.aether.transport.http.HttpTransporter.implGet(HttpTransporter.java:252)
 at org.eclipse.aether.spi.connector.transport.AbstractTransporter.get(AbstractTransporter.java:67)
 at org.eclipse.aether.connector.basic.BasicRepositoryConnector$GetTaskRunner.runTask(BasicRepositoryConnector.java:453)
 at org.eclipse.aether.connector.basic.BasicRepositoryConnector$TaskRunner.run(BasicRepositoryConnector.java:360)
 ... 20 more

 

-- 
Ian Roberts               | Department of Computer Science
i.roberts@...  | University of Sheffield, UK

 

-- 
Ian Roberts               | Department of Computer Science
i.roberts@...  | University of Sheffield, UK

Ian Roberts
 

Either is fine, literally the only difference between 8.6 and 8.6.1 is the switch from http to https for the central repository.  If you're embedding GATE processing in another application then you should depend on 8.6.1 so you don't have to work out how to apply the workaround there, but if you're just using the UI then it's up to you.

Ian

On 18/01/2020 08:57, John Pashley wrote:

Thanks Ian.

What would you recommend? Stay with the workaround or uninstall and install 8.6.1?

John

 

From: gate-users@groups.io <gate-users@groups.io> On Behalf Of Ian Roberts
Sent: Friday, 17 January 2020 22:10
To: gate-users@groups.io
Subject: Re: [gate-users] Installing GATE Developer 8.6 on Windows 10.

 

For anyone else who is hitting this, I've just released a GATE version 8.6.1, which is the same as 8.6 but now uses the https: URL by default and so does not require this workaround.

 

Ian

 

On 16/01/2020 12:40, Ian Roberts via Groups.Io wrote:

Hi John,

 

Thanks for flagging this up - it is due to the fact that Sonatype (who run the central Maven repository) have just yesterday disabled access to that repository over un-encrypted http.  The next release of GATE will use https by default for the central repository but for earlier versions of GATE which hard-code the http:// URL you need to add a Maven configuration file to make it use the https URL for the repository.

 

Create a file called "settings.xml" in your GATE installation folder (alongside gate.exe and gate.l4j.ini) with the following contents:

 

<settings xmlns="http://maven.apache.org/SETTINGS/1.0.0"
  xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
  xsi:schemaLocation="http://maven.apache.org/SETTINGS/1.0.0
                      http://maven.apache.org/xsd/settings-1.0.0.xsd">

  <mirrors>
    <mirror>
      <id>https-central</id>
      <name>Central Repo (HTTPS)</name>
      <url>https://repo1.maven.org/maven2/</url>
      <mirrorOf>central</mirrorOf>
    </mirror>
  </mirrors>
</settings>

 

Then add the following line to gate.l4j.ini:

 

-DM2_SETTINGS_XML=%EXEDIR%\settings.xml

 

With these changes, GATE should be able to load plugins correctly.

 

For Linux & Mac users, the "EXEDIR" trick doesn't work, so you will have to enter the full path to settings.xml in your gate.l4j.ini, e.g.

 

-DM2_SETTINGS_XML=/Applications/GATE_Developer_8.6/settings.xml

 

Like I say, this will be fixed properly in the next GATE release, which is due in a few weeks time.

 

Ian

 

On 16/01/2020 11:09, John Pashley wrote:

Hi.
I have installed the Platform-specific installer for Windows.
Everything installed normally but when starting the application the "Message" field filled with the error message below before it finally stopped.
Any ideas?
John
:
used by: org.eclipse.aether.transfer.ArtifactTransferException: Could not transfer artifact uk.ac.gate.plugins:tagger-chemistry:jar:creole:8.6 from/to central (http://repo1.maven.org/maven2/): HTTPS Required (501)
 at org.eclipse.aether.connector.basic.ArtifactTransportListener.transferFailed(ArtifactTransportListener.java:52)
 at org.eclipse.aether.connector.basic.BasicRepositoryConnector$TaskRunner.run(BasicRepositoryConnector.java:365)
 at org.eclipse.aether.util.concurrency.RunnableErrorForwarder$1.run(RunnableErrorForwarder.java:75)
 at org.eclipse.aether.connector.basic.BasicRepositoryConnector$DirectExecutor.execute(BasicRepositoryConnector.java:583)
 at org.eclipse.aether.connector.basic.BasicRepositoryConnector.get(BasicRepositoryConnector.java:259)
 at org.eclipse.aether.internal.impl.DefaultArtifactResolver.performDownloads(DefaultArtifactResolver.java:498)
 at org.eclipse.aether.internal.impl.DefaultArtifactResolver.resolve(DefaultArtifactResolver.java:399)
 ... 14 more

until

Caused by: org.apache.http.client.HttpResponseException: HTTPS Required (501)
 at org.eclipse.aether.transport.http.HttpTransporter.handleStatus(HttpTransporter.java:475)
 at org.eclipse.aether.transport.http.HttpTransporter.execute(HttpTransporter.java:300)
 at org.eclipse.aether.transport.http.HttpTransporter.implGet(HttpTransporter.java:252)
 at org.eclipse.aether.spi.connector.transport.AbstractTransporter.get(AbstractTransporter.java:67)
 at org.eclipse.aether.connector.basic.BasicRepositoryConnector$GetTaskRunner.runTask(BasicRepositoryConnector.java:453)
 at org.eclipse.aether.connector.basic.BasicRepositoryConnector$TaskRunner.run(BasicRepositoryConnector.java:360)
 ... 20 more

 

-- 
Ian Roberts               | Department of Computer Science
i.roberts@...  | University of Sheffield, UK

 

-- 
Ian Roberts               | Department of Computer Science
i.roberts@...  | University of Sheffield, UK


-- 
Ian Roberts               | Department of Computer Science
i.roberts@...  | University of Sheffield, UK

John Pashley
 

Hi Ian.

I downloaded 8.6.1 and started the install process but got the following message (Windows 10 Home Version 1903 OS build 18362.592).

“Windows protected your PC

Windows Defender SmartScreen prevented an unrecognised app from starting. Running the app might put your PC at risk.

Application: gate-developer-8.6.1-installer.exe

Publisher: Unknown publisher”

What would you recommend?

Thanks.

John

 

From: gate-users@groups.io <gate-users@groups.io> On Behalf Of Ian Roberts
Sent: Sunday, 19 January 2020 12:00
To: gate-users@groups.io
Subject: Re: [gate-users] Installing GATE Developer 8.6 on Windows 10.

 

Either is fine, literally the only difference between 8.6 and 8.6.1 is the switch from http to https for the central repository.  If you're embedding GATE processing in another application then you should depend on 8.6.1 so you don't have to work out how to apply the workaround there, but if you're just using the UI then it's up to you.

 

Ian

 

On 18/01/2020 08:57, John Pashley wrote:

Thanks Ian.

What would you recommend? Stay with the workaround or uninstall and install 8.6.1?

John

 

From: gate-users@groups.io <gate-users@groups.io> On Behalf Of Ian Roberts
Sent: Friday, 17 January 2020 22:10
To: gate-users@groups.io
Subject: Re: [gate-users] Installing GATE Developer 8.6 on Windows 10.

 

For anyone else who is hitting this, I've just released a GATE version 8.6.1, which is the same as 8.6 but now uses the https: URL by default and so does not require this workaround.

 

Ian

 

On 16/01/2020 12:40, Ian Roberts via Groups.Io wrote:

Hi John,

 

Thanks for flagging this up - it is due to the fact that Sonatype (who run the central Maven repository) have just yesterday disabled access to that repository over un-encrypted http.  The next release of GATE will use https by default for the central repository but for earlier versions of GATE which hard-code the http:// URL you need to add a Maven configuration file to make it use the https URL for the repository.

 

Create a file called "settings.xml" in your GATE installation folder (alongside gate.exe and gate.l4j.ini) with the following contents:

 

<settings xmlns="http://maven.apache.org/SETTINGS/1.0.0"
  xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
  xsi:schemaLocation="http://maven.apache.org/SETTINGS/1.0.0
                      http://maven.apache.org/xsd/settings-1.0.0.xsd">

  <mirrors>
    <mirror>
      <id>https-central</id>
      <name>Central Repo (HTTPS)</name>
      <url>https://repo1.maven.org/maven2/</url>
      <mirrorOf>central</mirrorOf>
    </mirror>
  </mirrors>
</settings>

 

Then add the following line to gate.l4j.ini:

 

-DM2_SETTINGS_XML=%EXEDIR%\settings.xml

 

With these changes, GATE should be able to load plugins correctly.

 

For Linux & Mac users, the "EXEDIR" trick doesn't work, so you will have to enter the full path to settings.xml in your gate.l4j.ini, e.g.

 

-DM2_SETTINGS_XML=/Applications/GATE_Developer_8.6/settings.xml

 

Like I say, this will be fixed properly in the next GATE release, which is due in a few weeks time.

 

Ian

 

On 16/01/2020 11:09, John Pashley wrote:

Hi.
I have installed the Platform-specific installer for Windows.
Everything installed normally but when starting the application the "Message" field filled with the error message below before it finally stopped.
Any ideas?
John
:
used by: org.eclipse.aether.transfer.ArtifactTransferException: Could not transfer artifact uk.ac.gate.plugins:tagger-chemistry:jar:creole:8.6 from/to central (http://repo1.maven.org/maven2/): HTTPS Required (501)
 at org.eclipse.aether.connector.basic.ArtifactTransportListener.transferFailed(ArtifactTransportListener.java:52)
 at org.eclipse.aether.connector.basic.BasicRepositoryConnector$TaskRunner.run(BasicRepositoryConnector.java:365)
 at org.eclipse.aether.util.concurrency.RunnableErrorForwarder$1.run(RunnableErrorForwarder.java:75)
 at org.eclipse.aether.connector.basic.BasicRepositoryConnector$DirectExecutor.execute(BasicRepositoryConnector.java:583)
 at org.eclipse.aether.connector.basic.BasicRepositoryConnector.get(BasicRepositoryConnector.java:259)
 at org.eclipse.aether.internal.impl.DefaultArtifactResolver.performDownloads(DefaultArtifactResolver.java:498)
 at org.eclipse.aether.internal.impl.DefaultArtifactResolver.resolve(DefaultArtifactResolver.java:399)
 ... 14 more

until

Caused by: org.apache.http.client.HttpResponseException: HTTPS Required (501)
 at org.eclipse.aether.transport.http.HttpTransporter.handleStatus(HttpTransporter.java:475)
 at org.eclipse.aether.transport.http.HttpTransporter.execute(HttpTransporter.java:300)
 at org.eclipse.aether.transport.http.HttpTransporter.implGet(HttpTransporter.java:252)
 at org.eclipse.aether.spi.connector.transport.AbstractTransporter.get(AbstractTransporter.java:67)
 at org.eclipse.aether.connector.basic.BasicRepositoryConnector$GetTaskRunner.runTask(BasicRepositoryConnector.java:453)
 at org.eclipse.aether.connector.basic.BasicRepositoryConnector$TaskRunner.run(BasicRepositoryConnector.java:360)
 ... 20 more

 

-- 
Ian Roberts               | Department of Computer Science
i.roberts@...  | University of Sheffield, UK

 

-- 
Ian Roberts               | Department of Computer Science
i.roberts@...  | University of Sheffield, UK

 

-- 
Ian Roberts               | Department of Computer Science
i.roberts@...  | University of Sheffield, UK

Ian Roberts
 

Ah, I must have code-signed the 8.6 installer exe.  My code signing certificate has since expired, so I can't do the same right now for the 8.6.1 one, but you may be able to use the JAR installer instead of the .exe one, or just add an "exclusion" to allow this particular .exe to run anyway.


Ian

On 20/01/2020 08:16, John Pashley wrote:

Hi Ian.

I downloaded 8.6.1 and started the install process but got the following message (Windows 10 Home Version 1903 OS build 18362.592).

“Windows protected your PC

Windows Defender SmartScreen prevented an unrecognised app from starting. Running the app might put your PC at risk.

Application: gate-developer-8.6.1-installer.exe

Publisher: Unknown publisher”

What would you recommend?

Thanks.

John

 

From: gate-users@groups.io <gate-users@groups.io> On Behalf Of Ian Roberts
Sent: Sunday, 19 January 2020 12:00
To: gate-users@groups.io
Subject: Re: [gate-users] Installing GATE Developer 8.6 on Windows 10.

 

Either is fine, literally the only difference between 8.6 and 8.6.1 is the switch from http to https for the central repository.  If you're embedding GATE processing in another application then you should depend on 8.6.1 so you don't have to work out how to apply the workaround there, but if you're just using the UI then it's up to you.

 

Ian

 

On 18/01/2020 08:57, John Pashley wrote:

Thanks Ian.

What would you recommend? Stay with the workaround or uninstall and install 8.6.1?

John

 

From: gate-users@groups.io <gate-users@groups.io> On Behalf Of Ian Roberts
Sent: Friday, 17 January 2020 22:10
To: gate-users@groups.io
Subject: Re: [gate-users] Installing GATE Developer 8.6 on Windows 10.

 

For anyone else who is hitting this, I've just released a GATE version 8.6.1, which is the same as 8.6 but now uses the https: URL by default and so does not require this workaround.

 

Ian

 

On 16/01/2020 12:40, Ian Roberts via Groups.Io wrote:

Hi John,

 

Thanks for flagging this up - it is due to the fact that Sonatype (who run the central Maven repository) have just yesterday disabled access to that repository over un-encrypted http.  The next release of GATE will use https by default for the central repository but for earlier versions of GATE which hard-code the http:// URL you need to add a Maven configuration file to make it use the https URL for the repository.

 

Create a file called "settings.xml" in your GATE installation folder (alongside gate.exe and gate.l4j.ini) with the following contents:

 

<settings xmlns="http://maven.apache.org/SETTINGS/1.0.0"
  xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
  xsi:schemaLocation="http://maven.apache.org/SETTINGS/1.0.0
                      http://maven.apache.org/xsd/settings-1.0.0.xsd">

  <mirrors>
    <mirror>
      <id>https-central</id>
      <name>Central Repo (HTTPS)</name>
      <url>https://repo1.maven.org/maven2/</url>
      <mirrorOf>central</mirrorOf>
    </mirror>
  </mirrors>
</settings>

 

Then add the following line to gate.l4j.ini:

 

-DM2_SETTINGS_XML=%EXEDIR%\settings.xml

 

With these changes, GATE should be able to load plugins correctly.

 

For Linux & Mac users, the "EXEDIR" trick doesn't work, so you will have to enter the full path to settings.xml in your gate.l4j.ini, e.g.

 

-DM2_SETTINGS_XML=/Applications/GATE_Developer_8.6/settings.xml

 

Like I say, this will be fixed properly in the next GATE release, which is due in a few weeks time.

 

Ian

 

On 16/01/2020 11:09, John Pashley wrote:

Hi.
I have installed the Platform-specific installer for Windows.
Everything installed normally but when starting the application the "Message" field filled with the error message below before it finally stopped.
Any ideas?
John
:
used by: org.eclipse.aether.transfer.ArtifactTransferException: Could not transfer artifact uk.ac.gate.plugins:tagger-chemistry:jar:creole:8.6 from/to central (http://repo1.maven.org/maven2/): HTTPS Required (501)
 at org.eclipse.aether.connector.basic.ArtifactTransportListener.transferFailed(ArtifactTransportListener.java:52)
 at org.eclipse.aether.connector.basic.BasicRepositoryConnector$TaskRunner.run(BasicRepositoryConnector.java:365)
 at org.eclipse.aether.util.concurrency.RunnableErrorForwarder$1.run(RunnableErrorForwarder.java:75)
 at org.eclipse.aether.connector.basic.BasicRepositoryConnector$DirectExecutor.execute(BasicRepositoryConnector.java:583)
 at org.eclipse.aether.connector.basic.BasicRepositoryConnector.get(BasicRepositoryConnector.java:259)
 at org.eclipse.aether.internal.impl.DefaultArtifactResolver.performDownloads(DefaultArtifactResolver.java:498)
 at org.eclipse.aether.internal.impl.DefaultArtifactResolver.resolve(DefaultArtifactResolver.java:399)
 ... 14 more

until

Caused by: org.apache.http.client.HttpResponseException: HTTPS Required (501)
 at org.eclipse.aether.transport.http.HttpTransporter.handleStatus(HttpTransporter.java:475)
 at org.eclipse.aether.transport.http.HttpTransporter.execute(HttpTransporter.java:300)
 at org.eclipse.aether.transport.http.HttpTransporter.implGet(HttpTransporter.java:252)
 at org.eclipse.aether.spi.connector.transport.AbstractTransporter.get(AbstractTransporter.java:67)
 at org.eclipse.aether.connector.basic.BasicRepositoryConnector$GetTaskRunner.runTask(BasicRepositoryConnector.java:453)
 at org.eclipse.aether.connector.basic.BasicRepositoryConnector$TaskRunner.run(BasicRepositoryConnector.java:360)
 ... 20 more

 

-- 
Ian Roberts               | Department of Computer Science
i.roberts@...  | University of Sheffield, UK

 

-- 
Ian Roberts               | Department of Computer Science
i.roberts@...  | University of Sheffield, UK

 

-- 
Ian Roberts               | Department of Computer Science
i.roberts@...  | University of Sheffield, UK


-- 
Ian Roberts               | Department of Computer Science
i.roberts@...  | University of Sheffield, UK

John Pashley
 

Thanks Ian.

I chose the JAR installer which seems to work fine.

Keep you advised.

Very best regards

John

 

From: gate-users@groups.io <gate-users@groups.io> On Behalf Of Ian Roberts
Sent: Monday, 20 January 2020 12:47
To: gate-users@groups.io
Subject: Re: [gate-users] Installing GATE Developer 8.6 on Windows 10.

 

Ah, I must have code-signed the 8.6 installer exe.  My code signing certificate has since expired, so I can't do the same right now for the 8.6.1 one, but you may be able to use the JAR installer instead of the .exe one, or just add an "exclusion" to allow this particular .exe to run anyway.

 

 

Ian

 

On 20/01/2020 08:16, John Pashley wrote:

Hi Ian.

I downloaded 8.6.1 and started the install process but got the following message (Windows 10 Home Version 1903 OS build 18362.592).

“Windows protected your PC

Windows Defender SmartScreen prevented an unrecognised app from starting. Running the app might put your PC at risk.

Application: gate-developer-8.6.1-installer.exe

Publisher: Unknown publisher”

What would you recommend?

Thanks.

John

 

From: gate-users@groups.io <gate-users@groups.io> On Behalf Of Ian Roberts
Sent: Sunday, 19 January 2020 12:00
To: gate-users@groups.io
Subject: Re: [gate-users] Installing GATE Developer 8.6 on Windows 10.

 

Either is fine, literally the only difference between 8.6 and 8.6.1 is the switch from http to https for the central repository.  If you're embedding GATE processing in another application then you should depend on 8.6.1 so you don't have to work out how to apply the workaround there, but if you're just using the UI then it's up to you.

 

Ian

 

On 18/01/2020 08:57, John Pashley wrote:

Thanks Ian.

What would you recommend? Stay with the workaround or uninstall and install 8.6.1?

John

 

From: gate-users@groups.io <gate-users@groups.io> On Behalf Of Ian Roberts
Sent: Friday, 17 January 2020 22:10
To: gate-users@groups.io
Subject: Re: [gate-users] Installing GATE Developer 8.6 on Windows 10.

 

For anyone else who is hitting this, I've just released a GATE version 8.6.1, which is the same as 8.6 but now uses the https: URL by default and so does not require this workaround.

 

Ian

 

On 16/01/2020 12:40, Ian Roberts via Groups.Io wrote:

Hi John,

 

Thanks for flagging this up - it is due to the fact that Sonatype (who run the central Maven repository) have just yesterday disabled access to that repository over un-encrypted http.  The next release of GATE will use https by default for the central repository but for earlier versions of GATE which hard-code the http:// URL you need to add a Maven configuration file to make it use the https URL for the repository.

 

Create a file called "settings.xml" in your GATE installation folder (alongside gate.exe and gate.l4j.ini) with the following contents:

 

<settings xmlns="http://maven.apache.org/SETTINGS/1.0.0"
  xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
  xsi:schemaLocation="http://maven.apache.org/SETTINGS/1.0.0
                      http://maven.apache.org/xsd/settings-1.0.0.xsd">

  <mirrors>
    <mirror>
      <id>https-central</id>
      <name>Central Repo (HTTPS)</name>
      <url>https://repo1.maven.org/maven2/</url>
      <mirrorOf>central</mirrorOf>
    </mirror>
  </mirrors>
</settings>

 

Then add the following line to gate.l4j.ini:

 

-DM2_SETTINGS_XML=%EXEDIR%\settings.xml

 

With these changes, GATE should be able to load plugins correctly.

 

For Linux & Mac users, the "EXEDIR" trick doesn't work, so you will have to enter the full path to settings.xml in your gate.l4j.ini, e.g.

 

-DM2_SETTINGS_XML=/Applications/GATE_Developer_8.6/settings.xml

 

Like I say, this will be fixed properly in the next GATE release, which is due in a few weeks time.

 

Ian

 

On 16/01/2020 11:09, John Pashley wrote:

Hi.
I have installed the Platform-specific installer for Windows.
Everything installed normally but when starting the application the "Message" field filled with the error message below before it finally stopped.
Any ideas?
John
:
used by: org.eclipse.aether.transfer.ArtifactTransferException: Could not transfer artifact uk.ac.gate.plugins:tagger-chemistry:jar:creole:8.6 from/to central (http://repo1.maven.org/maven2/): HTTPS Required (501)
 at org.eclipse.aether.connector.basic.ArtifactTransportListener.transferFailed(ArtifactTransportListener.java:52)
 at org.eclipse.aether.connector.basic.BasicRepositoryConnector$TaskRunner.run(BasicRepositoryConnector.java:365)
 at org.eclipse.aether.util.concurrency.RunnableErrorForwarder$1.run(RunnableErrorForwarder.java:75)
 at org.eclipse.aether.connector.basic.BasicRepositoryConnector$DirectExecutor.execute(BasicRepositoryConnector.java:583)
 at org.eclipse.aether.connector.basic.BasicRepositoryConnector.get(BasicRepositoryConnector.java:259)
 at org.eclipse.aether.internal.impl.DefaultArtifactResolver.performDownloads(DefaultArtifactResolver.java:498)
 at org.eclipse.aether.internal.impl.DefaultArtifactResolver.resolve(DefaultArtifactResolver.java:399)
 ... 14 more

until

Caused by: org.apache.http.client.HttpResponseException: HTTPS Required (501)
 at org.eclipse.aether.transport.http.HttpTransporter.handleStatus(HttpTransporter.java:475)
 at org.eclipse.aether.transport.http.HttpTransporter.execute(HttpTransporter.java:300)
 at org.eclipse.aether.transport.http.HttpTransporter.implGet(HttpTransporter.java:252)
 at org.eclipse.aether.spi.connector.transport.AbstractTransporter.get(AbstractTransporter.java:67)
 at org.eclipse.aether.connector.basic.BasicRepositoryConnector$GetTaskRunner.runTask(BasicRepositoryConnector.java:453)
 at org.eclipse.aether.connector.basic.BasicRepositoryConnector$TaskRunner.run(BasicRepositoryConnector.java:360)
 ... 20 more

 

-- 
Ian Roberts               | Department of Computer Science
i.roberts@...  | University of Sheffield, UK

 

-- 
Ian Roberts               | Department of Computer Science
i.roberts@...  | University of Sheffield, UK

 

-- 
Ian Roberts               | Department of Computer Science
i.roberts@...  | University of Sheffield, UK

 

-- 
Ian Roberts               | Department of Computer Science
i.roberts@...  | University of Sheffield, UK