Translating charts


jerebinho@...
 

Hi,
I was trying to translate charts/diagrams from English to Slovene, but the list of words under option Tools - Language packs - xy language pack (Slovene in my case) - Edit, does not offer words "Born", "Married", "Died" for translation. How can I translate the chart so I can share it to people, who are not familiar with English?

Thank you and best regards,

Miha


Mike Tate
 

Hi Miha,

I am no expert, but since nobody else has replied, I will try.

 

I experimented with the German language pack and displayed a Diagram chart.

It translated Born, Marr & Died correctly even though there are no translations for those explicit words in the language pack.

So it looks like the translation for Birth also handles Born, and likewise for Marriage/Marr and Death/Died.

So try Tools > Preferences > International with Default Output Language: Slovene and produced a Diagram chart.

It may already handle those translations.

 

Alternatively, in the ‘Edit Translation Tables for …’ dialogue have you tried the New… button to Create New translations?

That seems to be the way to add missing word translations.

I suggest you use the Help buttons in these dialogues to obtain pages of advice.

 


jerebinho@...
 

Solved it, thank you. FH can't differentiate between masculine and feminine version of the word though, but I have managed to solve this issue using brackets (born in Slovene for male is "rojen", for female it's "rojena", solved using "rojen(a)").
I still have an issue changing the date format used in diagrams. Can I change that, so it would not say "on 24 February 1711" but only "24.2.1711"?


Mike Tate
 

So you now have a Language Pack with Birth translated to rojen(a).

Use Tools > Language Pack… and Edit… your Slovenian Language Pack.

Select the word Birth and Edit… to open the Edit Translation window.

Select the Special Case option Female with Translate to Rojena then click Save to Update Existing entry.

Select the Special Case option (none) with Translate to Rojen then select Create New and click Create.

 

Now you have two separate translations for Female and the default (none) for Male.

 

You don’t need the Language Pack to set a Date format of 24.2.1711.

Use Tools > Preferences > General and set Preferred Short Date Format to dd.mm.yyy

In the Diagram > Options > Text tab, use Edit Text Scheme… and Set Date Format to Abbrev(3)

 


Mike Tate
 

Sorry, but I was wrong about how to set up Diagrams to have different male and female translations for Born.

You need to edit the Diagram Text Scheme that was initially created when the Language Pack was created.

 

Display any Diagram and open the Diagram > Options > Language tab to choose the Diagram Language: Slovenian (SLV)

Then open the Text tab, choose the Text Scheme and click Edit Language Variant… button.

Select the Birth item under Used Items and click the Edit button at the bottom.

In the Template replace the text "E_Rojen(a): _, _" with Sex(%INDI%,"E_Rojen: _, _","E_Rojena: _, _","E_Rojen: _, _") so the whole Template is:

=FactText(%INDI.BIRT%,"CT",Sex(%INDI%,"E_Rojen: _, _","E_Rojena: _, _","E_Rojen: _, _"))

Finally, click OK several times to see the effect of the change.

 

That uses the Sex() function to test the Individual (%INDI%) Sex field and for Male use "E_Rojen: _, _", for Female use "E_Rojena: _, _", otherwise use "E_Rojen: _, _"

 

I realise that is an advanced technique and perhaps should be documented in the FH Help pages.

 

It is in that Text Scheme for Slovenian that you should change the Date Format: to Abbrev(3) so that the dd.mm.yyyy format is used in Slovenian Diagrams.

 


jerebinho@...
 

Thanks for the instructions. Worked great. I've managed to use the same analogy for marriage and death.
I still have issues with the date format. For some reason the format remains unchanged irregardless what I pick. It is always in the format "on 26 August 1733" for instance, except if I use format "year", which then displays "1733".
Where/how can I translate words "between" and "and" in case birth date is displayed as "between 1748 and 1750"?


Mike Tate
 

I am learning about Language Packs as fast as you.

 

Changing the Date Format works in the default English version of Text Schemes but has no effect (except for Year) when a different Output Language is chosen.

The explanation is that the Date formatting is performed by the Language Pack Plugin and the default plugin ignores the Date Format qualifiers.

I will ask CP if that can be improved.

 

It is also the Language Pack Plugin that determines the translation of words such as ‘between’, ‘and’, ‘from’ & ‘to’ in Dates.

 

Use Tools > Language Packs… select Slovenian and click Plugin… to edit the plugin script where every << TODO marker appears.

e.g.

sHusband = '(no name)';            -- << TODO       Replace (no name) with the Slovenian equivalent words.

sText = "between " .. GetDatePtText(date:GetDatePt1(), "", "") .. " and " .. GetDatePtText(date:GetDatePt2(), "", "");            -- << TODO       Replace "between " and " and " with the Slovenian equivalent words.

 

You can also force the dd.mm.yyyy format in this plugin.

Near line number 630 you will find: function GetDatePtText(datept, sPrefix1, sPrefix2)

That needs these subsequent two lines to be replaced at about line numbers 642 and 646:

sDay = iDay .. ' ';                                   becomes          sDay = iDay .. '.';

sMonth = g_months[iMonth] .. ' ';            becomes          sMonth = iMonth .. '.';

 

Be very careful not to change the layout of the script, especially the symbols, otherwise it won’t work.

As the Help advises, save a plain text copy of the plugin script file as a backup just in case.

 


jerebinho@...
 

Thanks for all the instructions. I've managed to modify everything I needed in the plugin. Works like a charm!
Thanks again.