Punctuation in fact anmes

Mike Tate

I have just experimented by importing a GEDCOM into FH with a custom fact Name: John's/.?(In!)
2 TYPE John's/.?(In!)
That imported unchanged initially but without a Tools > Fact Types... definition as confirmed by ticking Show Hidden.
When I used the Edit... button to create a definition the Name and Label were automatically reduced to Johns(In) by removing the invalid characters.
Thereafter the Label can be restored to the original name John's/.?(In!)

I suspect direct import from Legacy will result in a similar effect but have not tested that.

Mike Tate

Mike Tate

Hi Teresa,
I sympathise with your points.
There is no fundamental reason for the restrictions except that custom facts must be represented using valid GEDCOM tags in Data References.
Those tags can only use a limited subset of characters A - Z, 0 - 9, hyphen, and underscore, which is what the error message says.
I suspect over the years FH has relaxed the rules for the Name you enter, and converts any other characters to underscore in Data Refs.
So the more characters that are allowed the greater the risk that Data References will not be unique.

Standard fact Names do not have the above problem because their Data References are predefined rather than derived from the Name.

I suggest you report the inconsistencies to CP and suggest the rules are relaxed and the error message corrected.

Mike Tate

Teresa Goatham

I've just tried to enter an attribute name with a slash and been surprised to find how restricted I am. I find I am not allowed to enter a slash, full-stop, question mark or apostrophe.

The slash and full-stop are most surprising, since they are both used in the standard events that FamilyHistorian already has. Given I am mostly happy with a slightly different event name, and can include them in labels in FH and can set different words within TNG it's not a big issue, but I guess I will have to change ones I have in Legacy before moving a tree there to FH.

The one I'm not happy with alternate words: 'Coroner's Inquest'. 'Inquest by a Coroner' is just too long and non-standard.
(Non-standard: an exact search of newspapers on FMP for 'Coroner's Inquest' finds 271,759, for 'Inquest by a Coroner' just 1681.)

There also seems to be an error in the error message I get when I try to include one of the forbidden items:
'Invalid name. Fact names may only contain simple alphabetic characters [no accents], digits, hyphens and underscores.'

I find that round brackets (I haven't tried any others) ARE allowed.

I guess there's a good reason for this restriction but it would be nice if it were changed.