Date   

Re: Strange Project has appeared?

johnfirr@...
 

Hi Mike,
apologies just saw your reply. I will follow your instructions and see where it gets me,
thanks
John


Re: Strange Project has appeared?

johnfirr@...
 

Hi Helena,
looks like you are right.it seems to have picked up a standalone GEDCOM that I created in March of this year. I dont understand why it should randomly appear in my FH startup project listing some two months later, I use FH pretty much every day and its never appeared before. I also dont understand why it got a 1971 date on. But at least I now know what it is and how to get rid of it!
Thanks
John


Re: Strange Project has appeared?

Mike Tate
 

John,

Those symptoms indicate a corruption of a file in your master Project. It is NOT an extra Project.

The clues are:

The default Last Updated date-time of 01/01/1971 00:00 is what FH displays when it cannot find a date.

The multiple filename suffix (1) for a file in your standard FIRR Database Master folder.

 

Use Windows File Explorer and check the contents of your …\Family Historian Projects\FIRR Database Master\ folder.

 

Is there a rogue FIRR Database Master (1).fh_proj Family Historian Project File?

 

Check the …\FIRR Database Master.fh_data\ subfolder for a rogue FIRR Database Master (1).ged Gedcom File.

 

Can you think of any explanation of where those rogue files might have come from?

 

Move them to somewhere like your Desktop or rename them and check to see if your master Project is all well and good and fully up-to-date.

If so then they can be deleted.

 

Mike Tate

 

From: family-historian@groups.io <family-historian@groups.io> On Behalf Of johnfirr via groups.io
Sent: 08 May 2021 13:19
To: family-historian@groups.io
Subject: [family-historian] Strange Project has appeared?

 

Something odd happened to my installation of FH when I opened it today.
I noticed an extra project had appeared with a date of 1971!

My default project is called FIRR Database Master last backed up this morning 08/05/20201 at 07.39.

Now when I open FH this afternoon a project has appeared that I know nothing about:

FIRR Database Master (1) (Folder: FIRR Database Master) last updated 01/01/1971 at 00.00

If to open it it says "file not found" but if I go to delete it it warns me it has 1950 records in it.

Any ideas what is going on and can I safely hit delete without affecting my main file?
regards
John


Re: Strange Project has appeared?

Helena Coney
 

I had that happen to me in the past, (V6) and was part of the reason I moved to another programme as it was always happening (although I am now back to V7 and not had the problem since).  I think it is something to do with anti virus software?

 

I think I opened the file up as a Gedcom from where its stored on your computer

 

 

Helena

 

The bladon family history study

Registered with the Guild of One-Name Studies

 
bladonfamilyhistory.wordpress.com
 

 

 

From: johnfirr via groups.io
Sent: 08 May 2021 13:18
To: family-historian@groups.io
Subject: [family-historian] Strange Project has appeared?

 

Something odd happened to my installation of FH when I opened it today.
I noticed an extra project had appeared with a date of 1971!

My default project is called FIRR Database Master last backed up this morning 08/05/20201 at 07.39.

Now when I open FH this afternoon a project has appeared that I know nothing about:

FIRR Database Master (1) (Folder: FIRR Database Master) last updated 01/01/1971 at 00.00

If to open it it says "file not found" but if I go to delete it it warns me it has 1950 records in it.

Any ideas what is going on and can I safely hit delete without affecting my main file?
regards
John

 


Strange Project has appeared?

johnfirr@...
 

Something odd happened to my installation of FH when I opened it today.
I noticed an extra project had appeared with a date of 1971!

My default project is called FIRR Database Master last backed up this morning 08/05/20201 at 07.39.

Now when I open FH this afternoon a project has appeared that I know nothing about:

FIRR Database Master (1) (Folder: FIRR Database Master) last updated 01/01/1971 at 00.00

If to open it it says "file not found" but if I go to delete it it warns me it has 1950 records in it.

Any ideas what is going on and can I safely hit delete without affecting my main file?
regards
John


Re: Media Window Problem

Mike Tate
 

This is a scenario where screenshots would be invaluable, but attaching them to these Emails requires manual admin review which can delay things.

The FHUG Forum has no such problems with screenshots.

 

I cannot follow your descriptions and cannot find anything that fails.

 

The Media Window workspace is opened by clicking the View Media camera icon in the main FH toolbar.

But that does not have a ‘Show Media’ icon.

Do you mean the ‘Open Editor/Player’ ‘Play’ icon of green circle & black triangle?

That is greyed out until an image is selected. It then always displays the selected Media file for me.

 

In the Property Box, you are talking about the yellow Source Citation List Pane and its ‘Show Media’ toolbar icon.

That opens the floating yellow Citation Window and the ‘Open Editor/Player’ icon of green circle & black triangle always displays my selected Media file.

For me it works regardless of whether a Source Record or Citation-specific Media file.

 

All I can suggest is to re-install FH v7.0.5 and see if that fixes it. Otherwise, I am baffled.

 

I presume you have a standard up-to-date Windows PC and have not changed any Media playing tools.

 

Mike Tate

 


Re: Media Window Problem

Andrew Braid
 

Mike

In the media window workspace the show media icon is greyed out.

When I click on the show media icon in the property box the citation widow appears and it is there where the show media arrow produces the error message.

I can't remember the record I was using yesterday but in a random sample today all have the same result.

I have no broken links.

Andrew


On 08/05/2021 10:12, Mike Tate wrote:

Andrew,

It is of course possible that v7.0.5 has introduced a bug, although unlikely.

 

Do you mean the Media Window workspace or the Media Tab of another record? I suspect the latter.

I think the image shown in the lower pane may be a thumbnail retrieved from the ThumbCache.dat file.

That may still get shown even when the file itself is unavailable.

 

Was it exactly the same Media file that opened via the Open in Editor/Player button successfully yesterday?

 

Use the Tools > External File Links… command and tick Show Broken Links Only.

What does that reveal?

 

Mike Tate

 

From: family-historian@groups.io <family-historian@groups.io> On Behalf Of Andrew Braid
Sent: 08 May 2021 08:30
To: family-historian@groups.io
Subject: [family-historian] Media Window Problem

 

I have just upgraded to 7.0.5 When I click on the play icon in the media window I get the error message "The specified file was not found" The file is dislalying in the lower part of the media window so it has been found. I used this function yesterday with 7.0.3 and it worked fine. To the best of my knowledge nothing else has changed. What has happened?

Andrew Braid


Re: Media Window Problem

Mike Tate
 

Andrew,

It is of course possible that v7.0.5 has introduced a bug, although unlikely.

 

Do you mean the Media Window workspace or the Media Tab of another record? I suspect the latter.

I think the image shown in the lower pane may be a thumbnail retrieved from the ThumbCache.dat file.

That may still get shown even when the file itself is unavailable.

 

Was it exactly the same Media file that opened via the Open in Editor/Player button successfully yesterday?

 

Use the Tools > External File Links… command and tick Show Broken Links Only.

What does that reveal?

 

Mike Tate

 

From: family-historian@groups.io <family-historian@groups.io> On Behalf Of Andrew Braid
Sent: 08 May 2021 08:30
To: family-historian@groups.io
Subject: [family-historian] Media Window Problem

 

I have just upgraded to 7.0.5 When I click on the play icon in the media window I get the error message "The specified file was not found" The file is dislalying in the lower part of the media window so it has been found. I used this function yesterday with 7.0.3 and it worked fine. To the best of my knowledge nothing else has changed. What has happened?

Andrew Braid


Media Window Problem

Andrew Braid
 

I have just upgraded to 7.0.5 When I click on the play icon in the media window I get the error message "The specified file was not found" The file is dislalying in the lower part of the media window so it has been found. I used this function yesterday with 7.0.3 and it worked fine. To the best of my knowledge nothing else has changed. What has happened?

Andrew Braid


Re: Backup & Restore Family Historian Settings

Mike Tate
 

In addition to the FH Help pages, there is a growing body of advice in the FHUG Knowledge Base:

https://fhug.org.uk/kb/

Also, you can ask questions on the FHUG Forums that have some advantages over this Email Forum.

https://www.fhug.org.uk/forum/

 

Mike

 


Re: Backup & Restore Family Historian Settings

Anne Algar
 

Thanks Mike

I've got the property box fields/tabs back. 

Now I need to start understanding some of the other changes in the system (parts of it looks strange to me at first glance), so I need to understand what goes where before​ I start adding loads more data.


Anne


From: family-historian@groups.io <family-historian@groups.io> on behalf of Mike Tate <post@...>
Sent: 07 May 2021 18:51
To: family-historian@groups.io <family-historian@groups.io>
Subject: Re: [family-historian] Backup & Restore Family Historian Settings
 

Sorry, but that advice is misdirected.

The problem is nothing to do with migrating Projects.

It is all to do with following the Help page Notes on Upgrading to Version 7.

Mike Tate

 

From: family-historian@groups.io <family-historian@groups.io> On Behalf Of dpb.genealogy@...
Sent: 07 May 2021 18:44
To: family-historian@groups.io
Subject: Re: [family-historian] Backup & Restore Family Historian Settings

 

Hi Anne. 

when I went from FH 6 to FH7 Igor a message to upgrade my v6 to v7. All my settings were transferred over. Maybe the plug-in when you received that message/warning glitched. Anyway, did you receive the upgrade message I referred to?

I would delete the project from v7 and reload your v6 directly into 7. It should load/convert normally. At least it did for me. 

regards Dennis 


Re: Backup & Restore Family Historian Settings

Mike Tate
 

Sorry, but that advice is misdirected.

The problem is nothing to do with migrating Projects.

It is all to do with following the Help page Notes on Upgrading to Version 7.

Mike Tate

 

From: family-historian@groups.io <family-historian@groups.io> On Behalf Of dpb.genealogy@...
Sent: 07 May 2021 18:44
To: family-historian@groups.io
Subject: Re: [family-historian] Backup & Restore Family Historian Settings

 

Hi Anne. 

when I went from FH 6 to FH7 Igor a message to upgrade my v6 to v7. All my settings were transferred over. Maybe the plug-in when you received that message/warning glitched. Anyway, did you receive the upgrade message I referred to?

I would delete the project from v7 and reload your v6 directly into 7. It should load/convert normally. At least it did for me. 

regards Dennis 


Re: Backup & Restore Family Historian Settings

Mike Tate
 

It is nothing to do with installing the latest version of the Plugin.

See the Help page: Notes on Upgrading to Version 7 that explains about re-enabling Plugins.

 

From: family-historian@groups.io <family-historian@groups.io> On Behalf Of Trevor Rix
Sent: 07 May 2021 18:38
To: family-historian@groups.io
Subject: Re: [family-historian] Backup & Restore Family Historian Settings

 

You need to download and install the latest version of that plugin, which is now compatible with both FH v6 and FH v7.


Re: Backup & Restore Family Historian Settings

Dennis
 

Hi Anne. 

when I went from FH 6 to FH7 Igor a message to upgrade my v6 to v7. All my settings were transferred over. Maybe the plug-in when you received that message/warning glitched. Anyway, did you receive the upgrade message I referred to?

I would delete the project from v7 and reload your v6 directly into 7. It should load/convert normally. At least it did for me. 

regards Dennis 


Re: Backup & Restore Family Historian Settings

Mike Tate
 

You cannot use backups of FH v6 settings to restore into FH v7 as they are different.

They are only useful if you wanted to return to using FH v6.

 

When FH v7 is installed over FH v6 it automatically inherits most of your settings.

There is a Help page in FH v7 that explains how to recover Property Box tabs.

See Help > Family Historian Help > Notes on Upgrading to Version 7:

https://www.family-historian.co.uk/help/fh7/hh_start.htm#notesforupgradingusers.html

Important Notes on Restoring Property Box Customizations

 

Mike Tate

 


Re: Backup & Restore Family Historian Settings

Trevor Rix
 

You need to download and install the latest version of that plugin, which is now compatible with both FH v6 and FH v7.


Backup & Restore Family Historian Settings

Anne Algar
 

I downloaded the above plugin at the end of April and ran it this week before upgrading from FH6 to FH7 and applying the 7.0.5. upgrade.  Today I've opened FH7 for the first time and went to run the plugin again to restore my settings but am getting a message that starts "The selected plugin has been disabled as the technology it uses .... ". 

​Some of my settings are still displayed, e.g. columns added to Individual Records list, but others aren't e.g. fields / tabs added to the Property Box. Does this mean I've lost all other settings, and will need to try and remember what I had set, or what?


Anne


Re: Duplicate Citations

Jane Taubman
 

It's probably some anomaly in the citation format I have not allowed for.

If you can send me a small gedcom which causes the plugin to fail I can take a look or you could try using the debug tools in the plugin editor to track the problem, by adding a breakpoint on line 57 


Re: Duplicate Citations

Mike Tate
 

That will need to be investigated and fixed by the Plugin Author who is Jane Taubman.

You can contact her via the FHUG Forums or Leave a Reply against that Plugin in the Plugin Store.

Mike Tate

 

From: family-historian@groups.io <family-historian@groups.io> On Behalf Of David Hodgson-Brown
Sent: 07 May 2021 13:47
To: family-historian@groups.io
Subject: [family-historian] Duplicate Citations

 

Hi All

 

I know I have lots of duplicate citations in my tree that I imported from RootsMagic. When I run the ‘Duplicate Citations’ plugin I get the following message

 

[string ‘c;\ProgramData\Calico Pie\Family Historian\Pl…]’:57: attempt to index a nil value (field ‘?’). No changes have been made to the data records.

 

Is there a way of tweaking the code to get around this problem? Can anyone suggest where to look in the GEDCOM for the offending data?  

 

Thanks

 

David Hodgson-Brown

 


Duplicate Citations

David Hodgson-Brown
 

Hi All

 

I know I have lots of duplicate citations in my tree that I imported from RootsMagic. When I run the ‘Duplicate Citations’ plugin I get the following message

 

[string ‘c;\ProgramData\Calico Pie\Family Historian\Pl…]’:57: attempt to index a nil value (field ‘?’). No changes have been made to the data records.

 

Is there a way of tweaking the code to get around this problem? Can anyone suggest where to look in the GEDCOM for the offending data?  

 

Thanks

 

David Hodgson-Brown

 

701 - 720 of 4343