Topics

Updates to Github #github


espeak-ng@groups.io Integration <espeak-ng@...>
 

[espeak-ng:master] New Comment on Issue #826 Problem with Android
By rhdunn:

You need to run the make espeakdata target in the makefile in the top-level project directory (not the android directory) which generates those files. There are apk-release and apk-debug helper targets in that makefile that build the jni library, espeak-ng, the espeak data, and the apk.


[espeak-ng:master] Label added to issue #826 Problem with Android by Rati2019.


[espeak-ng:master] Label added to issue #826 Problem with Android by Rati2019.


[espeak-ng:master] Issue #826 Problem with Android closed by Rati2019.


espeak-ng@groups.io Integration <espeak-ng@...>
 

[espeak-ng:master] New Issue Created by gelodefaultbrain:
#827 What is the CORRECT Identifier?

Hello! I am trying to get the IPA of certain words and sentences of arabic. Then I do this

	letter_ipa = phonemize(lower_case_letter,language="ar",backend="espeak")
	word_ipa = phonemize(word,language="ar",backend="espeak")

However it says this

    raise RuntimeError(
RuntimeError: language "ar" is not supported by the espeak backend

I don't understand cause base on the documentation. It clearly says that it is ar as the identifier

image

Can the developers please ### UPDATE the identifiers cause srsly it's kinda confusion or maybe I just don't know the right identifier and at least it can be provided there. Thank you!


[espeak-ng:master] New Issue Created by gelodefaultbrain:
#827 What is the CORRECT Identifier?

Hello! I am trying to get the IPA of certain words and sentences of arabic. Then I do this

	letter_ipa = phonemize(lower_case_letter,language="ar",backend="espeak")
	word_ipa = phonemize(word,language="ar",backend="espeak")

However it says this

    raise RuntimeError(
RuntimeError: language "ar" is not supported by the espeak backend

I don't understand cause base on the documentation. It clearly says that it is ar as the identifier

image

Can the developers please UPDATE the identifiers cause srsly it's kinda confusion or maybe I just don't know the right identifier and at least it can be provided there. Thank you!


[espeak-ng:master] New Issue Created by gelodefaultbrain:
#827 What is the CORRECT Identifier?

Hello! I am trying to get the IPA of certain words and sentences of arabic. Then I do this

	letter_ipa = phonemize(lower_case_letter,language="ar",backend="espeak")
	word_ipa = phonemize(word,language="ar",backend="espeak")

However it says this

    raise RuntimeError(
RuntimeError: language "ar" is not supported by the espeak backend

I don't understand cause base on the documentation. It clearly says that it is ar as the identifier

image

Can the developers please UPDATE the identifiers cause srsly it's kinda confusing or maybe I just don't know the right identifier and at least it can be provided there. Thank you!


[espeak-ng:master] New Issue Created by gelodefaultbrain:
#827 What is the CORRECT Identifier?

Hello! I am trying to get the IPA of certain words and sentences of arabic. Then I do this

	letter_ipa = phonemize(lower_case_letter,language="ar",backend="espeak")
	word_ipa = phonemize(word,language="ar",backend="espeak")

However it says this

    raise RuntimeError(
RuntimeError: language "ar" is not supported by the espeak backend

I don't understand cause base on the documentation. It clearly says that it is ar as the identifier

image

Can the developers please UPDATE the identifiers cause srsly it's kinda confusing or maybe I just don't know the right identifier and at least it can be provided there. Thank you!

PS: I am doing this in the python programming language


espeak-ng@groups.io Integration <espeak-ng@...>
 

[espeak-ng:master] New Comment on Issue #827 What is the CORRECT Identifier?
By valdisvi:

You should learn to use espeak properly. From command line documentation:

-l Line length. If not zero (which is the default), consider lines less than this length as end-of-clause.

What espeak --voices shows to you?


[espeak-ng:master] New Comment on Issue #827 What is the CORRECT Identifier?
By valdisvi:

You should learn to use espeak properly. From command line documentation:

-l Line length. If not zero (which is the default), consider lines less than this length as end-of-clause.

What espeak --voices shows to you?


[espeak-ng:master] New Comment on Issue #827 What is the CORRECT Identifier?
By valdisvi:

What command espeak --voices shows to you? Does it contains Arabic in list?