[espeak-ng:master] reported: Shan Language tone number doesn't show up correctly. #github


espeak-ng@groups.io Integration <espeak-ng@...>
 

[espeak-ng:master] New Comment on Issue #953 Shan Language tone number doesn't show up correctly.
By valdisvi:

I'm not experienced with tonal languages. Maybe you can compare Shan with e.g. Chinese settings and try tr->langopts.tone_numbers = 1; or some other settings. Maybe @michael-conrad may help you, because he made tones from scratch for Cherokee language.


espeak-ng@groups.io Integration <espeak-ng@...>
 

[espeak-ng:master] New Comment on Issue #953 Shan Language tone number doesn't show up correctly.
By jaacoppi:

Here's some more ideas for debugging:

  1. You are getting "m'a1" because the code sets primary stress. This shouldn't happen with tone languages, it should be "ma1". See stress related options in tr_languages.c and compare them to chinese.

  2. Debug with only one word at a time so the tone sandhi in CalcPitches_Tone() isn't affecting the words.

Check dictsource/cmn_rules. The tones there are 55, 35, 214 and so on. Check CalcPitches_Tone() in intonation.c. There's code that handles those tones.

  1. use -X parameter instead of -x to see which rules are selected.