[espeak-ng:master] reported: Procedure not clear on how to remove/disable a language #github


espeak-ng@groups.io Integration <espeak-ng@...>
 

[espeak-ng:master] New Comment on Issue #922 Procedure not clear on how to remove/disable a language
By jaacoppi:

Duplicate of #918.

The language files are not included in the espeak-ng binary or library. They are stored separately in the espeak-ng-data directory. You can simply choose not to install the the unneeded _dict files.

You should also disable all configure options like sonic, speechplayer, klatt and mbrola. See ./configure --help.

Other than that I think your only option is to edit the source code. What I would do: 1. remove unnecessary language code in tr_languages.c 2. remove ssml support in ssml.c if you don't need it 3. remove klatt and mbrola related code in klatt.c and mbrola.c and mbrowrap.c 5. remove all unneeded language specific checks in readclause.c, translate.c and numbers.c 6. Remove LoadConfig() and soundicon.c if you don't need it 7. remove unnecessary code related to language compiling. See compiledata.c and compiledict.c Be careful with this one. Once this is done you can't produce new language files. If you've already done everything in parts 1-5, the original data files might not match your binary anymore.


espeak-ng@groups.io Integration <espeak-ng@...>
 

[espeak-ng:master] New Comment on Issue #922 Procedure not clear on how to remove/disable a language
By Nafihahmd:

Thank you for the quick reply. You gave a reply more detailed than I expected, thanks. I was editing the espeak-ng-data directory in the project folder (cloned folder). That is why it wasn't working. Reading your comment I remembered that there is another espeak-ng-data in usr/share directory and edited it. And yes it worked.

That means that to reduce size I have to think of other methods that you have mentioned. I had already disabled all configure options. I will try the remaining procedures and report here before closing the issue.

Thanks