Topics

[espeak-ng:master] reported: Setting buffer size to 50ms leads to truncated mbrola-fr4 output #github


espeak-ng@groups.io Integration <espeak-ng@...>
 

[espeak-ng:master] New Comment on Issue #772 Setting buffer size to 50ms leads to truncated mbrola-fr4 output
By valdisvi:

@sthibaul, why you need such short buffer? Most of phoneme sounds are around 100ms length (and long vowels are 300ms), therefore with such short buffer even one phoneme will not fit into it. here it shows, that default (probably sane minimum) is 60ms. If you deal with some latency issue, probably it is longer than 50ms and source of it is somewhere else.


espeak-ng@groups.io Integration <espeak-ng@...>
 

[espeak-ng:master] New Comment on Issue #772 Setting buffer size to 50ms leads to truncated mbrola-fr4 output
By sthibaul:

why you need such short buffer?

I don't really, it's just that espeakup happened to be passing over 50 there, and that was breaking mbrola voices. espeak-ng should be defensive about this, you never know what value a program would want to try to pass.

default (probably sane minimum) is 60ms.

Then the passed value should be clamped to this minimum, if smaller values won't work.


espeak-ng@groups.io Integration <espeak-ng@...>
 

[espeak-ng:master] New Comment on Issue #772 Setting buffer size to 50ms leads to truncated mbrola-fr4 output
By valdisvi:

@rhdunn, then maybe code should be changed to:

if (buffer_length <= 60)
		buffer_length = 60;

with some comments about settings?


espeak-ng@groups.io Integration <espeak-ng@...>
 

[espeak-ng:master] New Comment on Issue #772 Setting buffer size to 50ms leads to truncated mbrola-fr4 output
By rhdunn:

That makes sense.