Topics

[espeak-ng:master] new issue: Arch Linux aarch64 on Android and speak char delay issue #github


espeak-ng@groups.io Integration <espeak-ng@...>
 

[espeak-ng:master] New Issue Created by JanuszChmiel:
#789 Arch Linux aarch64 on Android and speak char delay issue

Dear specialists, I Am using latest stable ArchLinux aarch64 which run on A top of Android Termux and Proot. I Am using Orca screen reader with Speech-dispatcher 0.9.1. I use Espeak-ng without pulseaudio-alsa module. Espeak-ng work perfectly except The situation, when Orca uses char by char movement by using arrow keys for example. In this case, Espeak-ng skip The char and speak second one or speak some characters twice. Termux uses patched Pulseaudio which uses Opensless protocol to communicate with other Android subsystems which are responsible for sound output. As A result, Pulseaudio is stable. But to be able to use this sound server from running ArchLinux aarch64 I muse use echo "export PULSE_SERVER=\"127.0.0.1\"" >> ~/.bashrc I Am running Pulseaudio from Termux /etc/profile by using those commands.

pulseaudio --start --exit-idle-time=-1 pacmd load-module module-native-protocol-tcp auth-ip-acl=127.0.0.1:4712 auth-anonymous=1 Sure, i must also have pulseaudio installed on my Arch Linux, because some libraryes are needed to transfer sound data to Pulseaudio sound server which run in Termux.

By other words. When I press arrow keys at The time, when previously spoken character is still being pronounced by Espeak-ng response is good and no skipping occurs. But when I press arrow key in The moment, when Espeak-ng do not pronounce previous character, there is skipping problem.

In some cases, when I type characters on The keyboard, some characters are also skipped.

My working solution have been to combina pulseaudio-alsa ArchLinux package in combination with old Espeak. In this case, there is newer a character skipping. But unfortunately, Speech-dispatcher even latest development Github code simply refuses to cooperate with pulseaudio-alsa when Espeak-ng is being used. 0.9.1 version support pulseaudio-alsa and old Espeak for reliable speech support. But pulseaudio-alsa can not be used in conjunction with Espeak-ng. In Speech-dispatcher 0.9.1 and also in The newest Speech-dispatcher development code.

I Am sad, because using still old espea which will not be developed is also not A solution. Some ArchLinux repository manager can remove pulseaudio-alsa sometimes and what could I do in this case.

How to precisely help you to debug Espeak-ng skipping?

Running Pulseaudio by using simple protocol from Arc Linux and having Pulseaudio for Termux disabled is not good idea. Because two available Simple protocol players for ANdroid do not implement special feature of Speech-dispatcher, which makes sound chip online ready. Transistors are producing soft sound and as A result, The delay between key press and getting The feetback rom Espeak-ng is fast but only if Pulseaudio for Termux is being used. Not if I configure Pulseaudio directly in Arch Linux and if Pulseaudio will only stream The sound by using Simple protocol. The next problem is memory allocation based. It is necessary to softly tune The buffer lenght in The speech-dispatcher coniguration file and also in Simple protocol player. In other case, Pulseaudio sound server will crash randomly thanks to memory allocation issues.

Thank you very much for yours help.