[espeak-ng:master] new issue: mbrola not working #github Integration <espeak-ng@...>

[espeak-ng:master] New Issue Created by metal3d:
#621 mbrola not working

Hi, First of all: => you says "Linux installation" but it's not - it's "Debian" installation. For Linux installation, we need something more "global" and universal.

So, now :)

On Fedora. I decided to compile espeak-ng myself (it seems that the provided package in repository is not compiled with mbrola support)

I did:

./configure --with-mbrola
sudo make install

Pcaudiolib is installed, everything is ok.

I now compiled MBROLA myself from

sudo cp Bin/mbrola /usr/local/bin/mbrola


I now tried to download and install voices from Tried: - sudo cp -r data/* /usr/local/share/espeak-ng-data/mbrola (with directory created) - in /usr/share/mbrola - with something that worked weeks ago:

sudo mkdir -p /usr/share/mbrola/voices
for voice in data/*; do
    voice=$(basename $voice)
    sudo cp data/$voice/$voice /usr/share/mbrola/voices

Wherever I put voices, espeak-ng doesn't see voices, and cannot speak with mbrola voice:

 espeak-ng -v mb-fr1 "Coucou"
mbrola: Fatal error in line:
mbrowrap error: mbrola exited with status 253

So, maybe it's mbrola, maybe not...

To be sure, I tried from MBROLA voices dir:

espeak-ng -v mb-fr4 "Une phrase pour tester" --pho -s 110 | mbrola fr4/fr4 - out.wav
paplay out.wav 

And it works.

So, the problem is to find mbrola voices - any help ?