Topics

Installation through Conda

Mahdi Kooshkbaghi
 

Hi All,
I have tried to install the dionysus2 through the pip and I have got attached error in compilation procedure.
Best,
Mahdi

Dmitriy Morozov
 

Hi Mahdi,

It looks like you are using Boost 1.53, which is very old at this point. The minimum version that would work is Boost 1.55, as determined in this issue [1]. Ideally, you'd use something even more recent.


Best,
Dmitriy

On Mon, Aug 21, 2017 at 9:39 AM, <mahdik@...> wrote:
Hi All,
I have tried to install the dionysus2 through the pip and I have got attached error in compilation procedure.
Best,
Mahdi


Mahdi Kooshkbaghi
 

Well, I think I need a new version for compiler now. I saw the closed issue on github :)

Mahdi Kooshkbaghi
 

Thanks, Dmitriy!
I didn't have root access but I finally managed to install new Boost version (1.61.0). Now it complains somewhere else.
Best,
Mahdi

Dmitriy Morozov
 

Yeah, GCC 4.8.5 is too old. Dionysus 2 seems to need at least GCC 5.4.0.

On Mon, Aug 21, 2017 at 12:48 PM, <mahdik@...> wrote:
Thanks, Dmitriy!
I didn't have root access but I finally managed to install new Boost version (1.61.0). Now it complains somewhere else.
Best,
Mahdi