Re: Bias current problems

JOHN CRONHELM
 

Hi Bob,
Should be soon checking this myself.  As a point of interest where do you check the current amps. From which point to ground?  Sorry can't help you with your problem.
John, vo1jcc.


On Jul 22, 2017, at 8:26 AM, vk2aor@... [CHINA_QRP] <CHINA_QRP@...> wrote:

 

Hi

Working on 40m Txcr with Ver 2.2 board.

A little confused about the Bias Current setting.    The procedure says with the bias setting pot turned fully anti-clockwise start turning it clockwise slowly until the current increases 60mA to about 0.54A (that is 540mA).

This seems like a high current.   I have worked on another Tx where the idle current was 60mA only.

 

What current should be drawn with the pot in the anti-clock position?   Is my understanding out  or is it a typing error?


I managed to destroy the final FET and have replaced it, also removed the bias pot to check it, appears ok .

I have made up a test mic plug with a switch as PTT and have a 2 tone board for checking peak envelope power.    The Rx draws 44mA and when the the switch (PTT) is operated the current goes to 1200mA and am unable to adjust it with the bias pot.


 The board was built by a friend and trying to help him out.     

The  Low Pass Filter coils have the correct number of turns (15) but seem loosely wound,  check the circuits with an ohm meter and all appear ok.  Check the toroid transformers and the same applies loose windings but correct turns and continuity with an ohmmeter.   The receiver seems to be working fine.   Just Stuck on the bias current.   Any help would be appreciated.


Bob VK2AOR

Join crkits@groups.io to automatically receive all group messages.