Topics

Airspy HF + Discovery with Gqrx on Raspberry Pi 4 b 4 G

reiin0zn@...
 

Hi All,

Other effort.

Can anybody here informing me on this approach?  If so, is it on PI 4 or 3? I have a 3 A power supply on the 4 is that sufficient
to handle the radio also?

Looking forward to answers please.

73 Rein W6SZ

Kelly Jack
 

I have my discovery running on pi4b with 4gb ram, power supply is the official 3.5amp though. I have not tried with lower amperage power supply.

I did have to run gqrx as root user to get it to recognise the discovery using the command line to initiate the program.

At this stage I have no decode on HF but was able to decode commercial FM.

Simon

rein0zn@...
 

Hello Simon,

Thanks info re Raspberry Pi 4.

I installed it and decided to try with a RTL-SDR dongle first. As soon as I had selected the type device,  I had sound and it was working fine.

Using the Airspy + Discovery,  I could not locate the device ( Airsy etc ) So how did you get it to connect to GQRX?

It might be having to do with the version of GQRX?    was using 2,11,  I think. 

The latest version is 2.15 or so. Is that the secret?

I have the radio now for 4 weeks and still not having able to to connect. Never experienced that kind of problems with basics.

Airspy .com  mentions Gqrx as software working with the H F + Discovery.

73 Rein W6SZ

Kelly Jack
 

Rein,

I am using gqrx 2.11.5.

I didn't do anything special other than run gqrx as root user and gqrx recognised the airspy automatically.

And HF is working fine too, previous issue I was having was due to poor antenna for hf.

Regards 


Simon

reiin0zn@...
 

Hello Simon,

‘’Thanks again . Does your radio show up as a device to be selected?

In my case only rtlsdr dongles show up as such.

Thanks for the help with this, You seem to be the only user with Raspi/Airspy—Discovery .

have had my device here for 4 weeks and still no working , Linrad] - SDRSharp - Gqrx .

73 Rein W6SZ

reiin0zn@...
 

Hello Simon and others again,

Using the same version as you, no HF + .  found , many RTL-SDR dongles listed as choice, dongle inserted dongle working

May I conclude from this:

  1. All important requirements met,
  2. working device,
  3. version Ok

Driver plays no roll  Is this really In this case,  True ?    ///////
.

Only Airspy HF + . ,       unknown likely. Defective ?     ///////

‘’How does one run as root Gqrx (  GUI ) What roll plays StartX ?  Sudo StartX ,
 With StartX , I get blocked locked up Raspi.

Does the HF + shows  up  In Gqrx as the  RTL-SDR  dongles do?

73 Rein W6SZ





 

Kelly Jack
 

Rein,

Gqrx recognised my rtlsdr dongle when running gqrx as a normal user and it worked fine.

To run gqrx as root user open a command line window from the desktop and type:

sudo gqrx

That is all I did differently to get my discovery to show up and work. It showed in the normal list of input options and was selected by default ahen it started up up. I have the Discovery plugged into the pi at bootup of the pi. No additional drivers were required.

I am not an experienced pi user but I think Startx starts the desktop from the command line.

Good luck

Simon

reiin0zn@...
 

Hello Jack,

Have the same  with the rtl-sdr dongles as you.

With the HF + Discovery, I did not do the root approach , will try that later. `Hope it is not the radio. But afraid it is.

I do not think running as root should be necessary.

Thank you much for the info.

Regards Rein Smit