Topics

Unable to run SpyServer on Raspberry Pi #spyserver


Olgierd Pilarczyk
 

Hi,

I try to run the latest version of SpyServer on Raspberry Pi 3 with Raspbian, but get the following error:

pi@raspberrypi:~/spyserver $ ./spyserver 
SPY Server v2.0.1629 - http://airspy.com
Reading the configuration file: spyserver.config
Unable to load user mode driver for 'AirspyOne'
Closed all connections and released the device
*** Error in `./spyserver': free(): invalid pointer: 0x7ed6e35c ***
Aborted
Raspi runs quite fresh raspbian (Linux raspberrypi 4.9.41-v7+ #1023 SMP Tue Aug 8 16:00:15 BST 2017 armv7l GNU/Linux), installed airspy and libairspy0 packages.

Any ideas? :-)

Regards,
Olgierd SQ3SWF


prog
 
Edited

On Sat, Jan 20, 2018 at 04:49 am, <opilarczyk@...> wrote:
Unable to load user mode driver for 'AirspyOne'
Install the user mode driver for Airspy One?

https://github.com/airspy/airspyone_host#how-to-build-the-host-software-on-linux


Olgierd Pilarczyk
 

Hi,

Apparently airspy package from the raspbian repository is not enough / too old (??).

Thank you for the solution!

Regards,
O.


Ernst Schrama
 

Running into the same problem, in my case the device is busy, so can I build the spyserver from scratch on a raspberry pi 3?


WB5NHL
 

Same problem with unable to load user mode driver for Airspy HF+ on a fresh Raspberry Pi 2 with Raspbian Stretch. Completed the Github instructions successfully, still no joy.

Dave,  WB5NHL


prog
 

On Mon, Jan 22, 2018 at 08:24 am, WB5NHL wrote:
Same problem with unable to load user mode driver for Airspy HF+ on a fresh Raspberry Pi 2 with Raspbian Stretch. Completed the Github instructions successfully, still no joy.

Dave,  WB5NHL
Sorry, it's not the same problem. You are using the HF+, not the R2 or the Mini. This means you need the driver for the HF+, not the driver for the R2 or the Mini.
https://github.com/airspy/airspyhf#how-to-build-the-host-software-on-linux


Blogger <blogger@...>
 

Hello ejo60,


A screencap.

Monday, January 22, 2018, 12:51:13 AM, you wrote:


e> Running into the same problem, in my case the device is busy, so can I build

e> the spyserver from scratch on a raspberry pi 3?


Best regards,

Blogger


Blogger <blogger@...>
 

Hello ejo60,


After tearing my hair out for 3 days, found a solution.

Try it now,        PI-3 with SDR-RTL dongle,               sdr://p.uio.pw:5555

Monday, January 22, 2018, 12:51:13 AM, you wrote:


> Running into the same problem, in my case the device is busy, so can I build

> the spyserver from scratch on a raspberry pi 3?


Best regards,

Blogger



Ernst Schrama
 

Guys,

I got it to work, you need indeed to install the airspyone_host-master (or the airspyhf_host-master) software from github, and replace the device_type = AirspyOne and follow the rest of the settings in sdrsharp. I connected the raspberry pi 3 to a fixed ethernet port rather than wifi to get any bandwidth, it works, great job airspy!

Ernst PA1EJO


Ernst Schrama
 

Can I have the software for the hf+ and the R2 on the same /usr/local on the r2p? The R2 is correctly installed, runs like a king over a wired network, the BW limitation comes from the r2p which has no gigabit eth0 interface.