Audio input setting on SDR# rev 1781


Lyndxer
 

I just installed version 1781 and it detects my Airspy R2 with no problem. When I go to the audio setting panel, it will not let me set the sample rate or the input source. It does permit me to change the output.  Is there some other setting I missed?
--
Linda Brodsky
Location" Malverne, NY ( 40.674652, -73.673324)
Receivers: SDRPlay RSPdx, Airspy R2, Funcube Pro+, Chaparral CR-10, Pansat R9500 FTA receiver
Antennas: PAR EF-SWL, You Loop, Radio Shack Discone, rotatable VHF-UHF FM-TV antenna, 10ft BUD with C & Ku band LNBs
,


prog
 

On Mon, Nov 16, 2020 at 04:20 PM, Lyndxer wrote:
I just installed version 1781 and it detects my Airspy R2 with no problem. When I go to the audio setting panel, it will not let me set the sample rate or the input source. It does permit me to change the output.  Is there some other setting I missed?
Since you are using an Airspy R2 as input, the audio input is not used, and that's why it's grayed. The output sample rate is dictated by the output device you select.
In general, if you try to use something that is grayed, there must be some logic/understanding problem.


Lyndxer
 

I'm fully aware that things that are grayed out indicate they are inaccessible, but since the input in the last version I used (1762) was set at 192,000 as opposed to 48000 in the new version, I was wondering it the setting and the inability to change it was an error.

--
Linda Brodsky
Location" Malverne, NY ( 40.674652, -73.673324)
Receivers: SDRPlay RSPdx, Airspy R2, Funcube Pro+, Chaparral CR-10, Pansat R9500 FTA receiver
Antennas: PAR EF-SWL, You Loop, Radio Shack Discone, rotatable VHF-UHF FM-TV antenna, 10ft BUD with C & Ku band LNBs
,


Ken Sejkora
 

Hi Linda,

 

You can’t set/change the audio sample rate when the source/radio is turned on.  The best way I’ve found to do it is to set the source to soundcard baseband (probably the last on the list), but don’t turn it on.  You should then be able to go to audio settings and select the sample rate of your choice.  Then you can go back and set your source to the SDR dongle of choice.

 

The alternative is to use a text editor like Notepad.exe to edit the SDRSharp.exe.config file and find the entry:

 

  <add key="sampleRate" value="48000 sample/sec" />

 

and set it to the desired sample rate.  Make sure that SDRSharp is not open when editing the config file, and to save the changes before reopening SDRSharp.

 

I hope this helps.

 

Ken Sejkora

 

 

From: Lyndxer
Sent: Monday, November 16, 2020 15:35
To: airspy@groups.io
Subject: Re: [airspy] Audio input setting on SDR# rev 1781

 

I'm fully aware that things that are grayed out indicate they are inaccessible, but since the input in the last version I used (1762) was set at 192,000 as opposed to 48000 in the new version, I was wondering it the setting and the inability to change it was an error.

--
Linda Brodsky
Location" Malverne, NY ( 40.674652, -73.673324)
Receivers: SDRPlay RSPdx, Airspy R2, Funcube Pro+, Chaparral CR-10, Pansat R9500 FTA receiver
Antennas: PAR EF-SWL, You Loop, Radio Shack Discone, rotatable VHF-UHF FM-TV antenna, 10ft BUD with C & Ku band LNBs
,

 


--

Ken, WBØOCV East Falmouth, MA USA
41.5997N, 70.5614W  FN41ro


prog
 

On Mon, Nov 16, 2020 at 10:42 PM, Ken Sejkora wrote:

You can’t set/change the audio sample rate when the source/radio is turned on.  The best way I’ve found to do it is to set the source to soundcard baseband (probably the last on the list), but don’t turn it on.  You should then be able to go to audio settings and select the sample rate of your choice.  Then you can go back and set your source to the SDR dongle of choice.

 

The alternative is to use a text editor like Notepad.exe to edit the SDRSharp.exe.config file and find the entry:

 

  <add key="sampleRate" value="48000 sample/sec" />

 

and set it to the desired sample rate.  Make sure that SDRSharp is not open when editing the config file, and to save the changes before reopening SDRSharp.

 

I hope this helps.

Not only this doesn't help, but it is also misleading.


prog
 

On Mon, Nov 16, 2020 at 09:35 PM, Lyndxer wrote:
I was wondering it the setting and the inability to change it was an error.
No, this is the correct behavior. When you are not using a sound card input, these settings are not used at all.
As always, you will spare a lot of time if you explain what you are trying to do rather than if this or that works.


jdow
 

In general no matter how many audio cards and plugins you have the only one that really exist are ones that have cables plugged in. Some might specifically require microphones plugged in. For sample rate you might need to change that in the VB cable. It may only be offering 48ksps sample rate for connections.

{^_^}

On 20201116 07:24:45, prog wrote:
On Mon, Nov 16, 2020 at 04:20 PM, Lyndxer wrote:
I just installed version 1781 and it detects my Airspy R2 with no problem. When I go to the audio setting panel, it will not let me set the sample rate or the input source. It does permit me to change the output.  Is there some other setting I missed?
Since you are using an Airspy R2 as input, the audio input is not used, and that's why it's grayed. The output sample rate is dictated by the output device you select.
In general, if you try to use something that is grayed, there must be some logic/understanding problem.