Topics

#spyserver #win10 #spyserver #win10


bdcinside
 

Hi Everybody!
 
google says "Setting up a spyserver is very simple..." It is, but unfortuantely it doesn't work for me.
 
Some facts what I have and what I tried:
 
* Windows 10 PC
* NooElec DVB-T Dongle
* Flightaware Dongle
* newest Version of Sharp#
 
I was successful to tune both dongles (just using one at a time). Both are working well with SharpSDR.
 
I've changed the config file regarding:
 
* IP address
* port
* device type
 
spyserver_ping is working on the same and another remote machine when spyserver is started. But here comes what I don't understand:
 
Spyserver cmd windows shows me: "Listening for connections on 192.x.x.x:4444"
But it never says that some client is connecting.
 
I have no clue what this is about. Can someone maybe give me hint what to check or configure?
 
Best
bdc
 


prog
 

Don't change anything in the server config unless you actually understand what it means.
The defaults work out of the box for all the supported radios.

=> Fix your networking


bdcinside
 

Thank you for your advice. My network is working fine. Several devices and services that are working fine. I just changed what I understood. The parameters are working otherwise I would have got an error message. That's why I am asking for a hint. It's like the spyserver doesn't start/block the dongle. I still can start SharpSDR and use the Rtlsdr via USB. That shouldn't be the case... 


prog
 

The server is listening on port 5555 (by default), just open that port in the firewall and your router.


bdcinside
 

As mentioned before I can access the spyserver within my local network but without getting any signal/stream. Firewalls are deactivated. Tried different ports and the default. If I am on a wrong port I get a connection error. So I guess it's not about the port. Tried the setup on a second Win10 machine. Same behavior. 


Mike Jackson
 

What was the reasoning behind setting the port to 4444?  Perhaps you now have a conflict with that port, as @prog says, set it back to 5555 and use that port.  If you have changed the default settings in the config file this is clearly your issue.  Sorry to be blunt but that is the consensus so far, reset and give it a try.


jdow
 

Again, get it working with the default condition AND ONLY ONE DONGLE PLUGGED IN. Then build out from a known working configuration to something different one step at a time. Then when something breaks you can step back easily and figure out why.

{o.o} But, if you want to do it your way, fine. You broke it you get to go home with all the pieces. (One dongle MAY be your problem if you really are a networking geek.)

On 20200516 08:51:48, bdcinside via groups.io wrote:
As mentioned before I can access the spyserver within my local network but without getting any signal/stream. Firewalls are deactivated. Tried different ports and the default. If I am on a wrong port I get a connection error. So I guess it's not about the port. Tried the setup on a second Win10 machine. Same behavior.