New Firmware for Airspy R2?


Ruben Navarro Huedo (EA5BZ)
 

Hello:
I have the problem with 2.5MSPS described under Quick Start Guide.: http://airspy.com/quickstart/
>> In some PCs, the experimental 2.5MSPS mode is vulnerable to USB noise. This will be improved with further firmware updates.

Will we have a new firmware solving it?

Thank's a lot.


prog
 

Nothing planned yet. Use the recommended sample rate with the decimation.


Ruben Navarro Huedo (EA5BZ)
 

I don't understand the cause, but I have problems with 10MSPS and WXTOIMG.... i must use 2.5.
Using 10MSPS i have synchronization problems, not using 2.5.


EB4APL
 

Hi,

The author will know better, but I think that you can use decimation to lower the effective sample rate instead of this experimental mode.

73 de Ignacio, EB4APL


El 09/10/2017 a las 18:55, Ruben Navarro Huedo (EA5BZ) escribió:
Hello:
I have the problem with 2.5MSPS described under Quick Start Guide.: http://airspy.com/quickstart/
>> In some PCs, the experimental 2.5MSPS mode is vulnerable to USB noise. This will be improved with further firmware updates.

Will we have a new firmware solving it?

Thank's a lot.


EB4APL
 

Hi Ruben,

I always use 10 MSPS with the same programs without any problem and my PC is a mere I5. I think that your USB is losing some data at 10 MSPS hence the sync problem. Are you using data packaging? It does not work very well in my computer.

73 de Ignacio, EB4APL


El 09/10/2017 a las 19:27, Ruben Navarro Huedo (EA5BZ) escribió:
I don't understand the cause, but I have problems with 10MSPS and WXTOIMG.... i must use 2.5.
Using 10MSPS i have synchronization problems, not using 2.5.

_


Ruben Navarro Huedo (EA5BZ)
 

Hello Ignacio.

Yes...i was using 10MSPS with 32 decimation, and i don't have audio problems but i have sync problems with WXTOIMG (I don't know the cause).

Ignacio: He estado usando mucho tiempo 10MSPS con 32 de decimation, pero por un motivo que desconozco tengo problemas de sincronia entre SDRSHARP y WXTOIMG.
WXTOIMG no consigue mantener las imagenes "rectas" y esto no ocurre a 2.5 MSPS.


Ruben Navarro Huedo (EA5BZ)
 

Ignacio: How do i activate data packing under SDRSHARP?


PMM
 

Not had issues with weather Sat's, certainly use decimation but also ensure things like agc are off and anything that would have knock on effect to signal e.g. noise blanking as you will end up passing that on to wxtoimg also probably the audio filter off so it not potentially effect your tick tock lol 

On 9 Oct 2017 18:27, "Ruben Navarro Huedo (EA5BZ)" <runahue@...> wrote:
I don't understand the cause, but I have problems with 10MSPS and WXTOIMG.... i must use 2.5.
Using 10MSPS i have synchronization problems, not using 2.5.


Ruben Navarro Huedo (EA5BZ)
 

All is ok at 2.5 MSPS and not at 10MSPS (using decimation)


PMM
 

Could be running into usb issues / usb noise causing dropped samples not all usb made equal I run mine off a port 4 hub as can supply cleaner power but have run into issues like that in past with my bladerf on usb3 one port better than the other different chipset. 

Some usb can be quite noisy can also be quite a difference between back of PC motherboard ports verse panel mount.

I highly suggest trying out different ports to see if any work better.

On 9 Oct 2017 18:48, "Ruben Navarro Huedo (EA5BZ)" <runahue@...> wrote:
All is ok at 2.5 MSPS and not at 10MSPS (using decimation)


prog
 

Did you run the diagnostic tools as described in the quick start?


Ruben Navarro Huedo (EA5BZ)
 

Yes..average is 10.005


prog
 

So the streaming and the IQ conversion are all fine. You should check if your system has enough processing power left for the WX app.


pd0rtl
 

Silly question.
Are u using a USB hub with the spy?
if yes, ditch it.
does your rig has a USB3 port
if yes, USE that !, also lesser usb noise.
usb2 ports intent to set more noise.

On 9-10-2017 19:48, Ruben Navarro Huedo (EA5BZ) wrote:
All is ok at 2.5 MSPS and not at 10MSPS (using decimation)


Ruben Navarro Huedo (EA5BZ)
 

hello:
No...i don't use USB hub.
And i don't have USB3 in my computer, but tested on my laptop with USB3 and i have the same USB Noise at 2.5 MSPS.