Topics

SDR# Input lag #sdrsharp #RTL

Annunaki
 

Ok so accidentally I seem to have found the issue.

It seems to be with the standard RTL-SDR .dll that comes from the included install.bat, When its selected in the source selection section of SDR# the problems occur.

 

However when selecting the RTL-SDR .dll which produces the below config UI all the mentioned problems go away.

 

Annunaki
 

haha no way I remember that day well :) That is really strange this has happened as yesterday I also came back to SDR, Yeah I'm still around but have not been for about 4 years due to some big life events, Did have Airspy but had to sell on due to some life problems but I plan to get another in the near future :) Glad you remember me and also glad to see how far SDR# and Airspy have come! really really cool m8 congratulations I know how hard you have worked for this :) I hope life is treating you well.

 

I've reduced the process priority to 32 (normal) and also combined it with AntiAliasedDisplay False but sadly still having issues and I'm also on 1711 now.

Driving me insane it is but as always appreciate your help :)

Actually I think the Freezing is less to be honest but still not right.

 

Thanks again :)

prog
 

On Mon, Aug 26, 2019 at 03:35 PM, Stuart Sinderbury wrote:

Thanks again, I changed true to false and gave it a shot, Sadly no difference.

More on the issue: (no front ends running)

1, When expanding and collapsing plugins on the left pane there will be miss clicks. e.g click to collapse nothing happens click again and it collapses but sometimes can take 3 clicks to work and vica versa.

2, Moving the mouse cursor around with SDR# open (no with or without a Front end active) randomly results in a 1 sec mouse freeze then it unfreezes inside SDR# and throughout the whole OS environment like now compiling this reply.

3, Manually changing frequency clicking the numbers will some times keep on changing the frequency until the mouse is moved off the number.

3, Clicking around in the spectrum will have similar effects as trying to expand and collapse plugins, The click will not happen.

 

Only does this with SDR# version 1.5 and above and I've even tried a fresh OS install on a spare SSD to see if my main environment was bugged somehow.

Thanks for helping me.

 

Annunaki/Zenocide from IRC years ago.

Hey! I just thought where you were hiding. I used your IQ file "Annunaki_20140426_120532Z_446031kHz_IQ.wav" for testing the Noise Reduction just yesterday. Glad to see you around.

Try this next: <add key="processPriority" value="32" />

Annunaki
 

Thanks again, I changed true to false and gave it a shot, Sadly no difference.

More on the issue: (no front ends running)

1, When expanding and collapsing plugins on the left pane there will be miss clicks. e.g click to collapse nothing happens click again and it collapses but sometimes can take 3 clicks to work and vica versa.

2, Moving the mouse cursor around with SDR# open (no with or without a Front end active) randomly results in a 1 sec mouse freeze then it unfreezes inside SDR# and throughout the whole OS environment like now compiling this reply.

3, Manually changing frequency clicking the numbers will some times keep on changing the frequency until the mouse is moved off the number.

3, Clicking around in the spectrum will have similar effects as trying to expand and collapse plugins, The click will not happen.

 

Only does this with SDR# version 1.5 and above and I've even tried a fresh OS install on a spare SSD to see if my main environment was bugged somehow.

Thanks for helping me.

 

Annunaki/Zenocide from IRC years ago.

prog
 

On Mon, Aug 26, 2019 at 03:08 PM, Stuart Sinderbury wrote:
Just tried this and installer says 4.6 already installed so tried 4.6.1 and 4.6.2 and those are already installed too.

Pulling my hair out here...
Let's get more aggressive. Try this in the config.
<add key="useAntiAliasedDisplay" value="false" />

Annunaki
 

Just tried this and installer says 4.6 already installed so tried 4.6.1 and 4.6.2 and those are already installed too.

Pulling my hair out here...

prog
 

On Mon, Aug 26, 2019 at 02:52 PM, Stuart Sinderbury wrote:
Windows is fully updated and it is only happening on SDR# with versions above 1.500, All SDR# version 1.500 and below work fine.
This means the .NET Framework 4.6 might be missing. Normally it comes with the updates in Windows 10.
Try installing (then updating) it manually.

Annunaki
 

Hey thanks for the reply.

Windows is fully updated and it is only happening on SDR# with versions above 1.500, All SDR# version 1.500 and below work fine.

Regards

prog
 

On Mon, Aug 26, 2019 at 12:07 PM, Stuart Sinderbury wrote:

When I load SDR# 1709 (without starting any Frontends) there is a very notably lag with the program and mouse input to the various plugins on the left pane and also a recurring momentarily freezing of the cursor throughout the whole of the OS, When staring a Frontend the lag/freezing continues no worse no less but makes using SDR# unbearable.

This is a stock 1709 install with no extra plugins loaded.

This doesn't look related to SDR# itself. Try running Windows update.

Annunaki
 
Edited

Hey guys I've been a SDR# user for a long time although I have been out out the light for a few years due to life events.

The last version I used and have saved is 1416 which runs perfectly well however I have downloaded the most recent version 1709 and I am having issues with it.

When I load SDR# 1709 (without starting any Frontends) there is a very notably lag with the program and mouse input to the various plugins on the left pane and also a recurring momentarily freezing of the cursor throughout the whole of the OS, When staring a Frontend the lag/freezing continues no worse no less but makes using SDR# unbearable.

This is a stock 1709 install with no extra plugins loaded.

My system specs are as follows:

AMD FX 9590 4.7ghz x8
SSD nvme
16gb 1886mhz ram
GTX 1660 gfx
Windows 10 Prof 64bit

I'm at a loss of what this could be and would welcome some help.

Kind Regards

Stuart