locked Update to HF+ 2.0 Caution with Virtual COM ports #firmware #HF+ #firmware #update


andrew.beckett@...
 

Just a word of caution - just downloaded and attempted to do the 1.7 to 2.0 firmware update on my HF+.  The update failed at first.  Then I remembered the last time I updated I had to remove all the virtual COM ports.

So I've just taken off all the virtual com ports (com0com) and then reattempted the update which then ran smoothly.

Also a word of caution - the link to the update is on the bottom of the page, but the zipped file is only behind the URL on the left of the link, just the numbers.  The bit which says changelog doesn't link to the file and this is where I went wrong last time because I believed the URL was one link, its not, there are two links hiding there.  Look at the link in the menu bar - when you have the right bit of the URL on the left end it ends with ".zip"

It's not terribly clear which bit you click on - I only discovered it by accident.

All being said the clarity of the received audio from this first 20 minutes of use appears to be even better again - well done clever people that keep tweaking it!


Mitch
 

Confirmed the same here when running multiple com0com/hub4com virtual serials on a Win10 Home box.  The flash.bat fails at the point of searching for the bin file and just reports "Press any key to continue."  Some judicious error reporting would be in order (if possible in a DOS batch file).

Like Andrew, once all virtuals were removed from the system, the firmware load went perfectly.

On 5/7/2019 18:46, andrew.beckett via Groups.Io wrote:

Just a word of caution - just downloaded and attempted to do the 1.7 to 2.0 firmware update on my HF+.  The update failed at first.  Then I remembered the last time I updated I had to remove all the virtual COM ports.