Date   

Re: Beginner Questions: spyserver.config

jdow
 

If all you see are 192.168.x.x numbers you cannot be reached from outside. Those are among the three sets of unroutable internet addresses. 172.16.x.x through 172.31.255.255 and 10.x.x.x are also unroutable. The self-assigned addresses, 169.254.0.0 to 169.254.255.255, also do not route to the Internet.

{^_^}

On 20190219 23:50:15, Ken Alexander wrote:
Thank you!
So those numbers work then?  I thought maybe they were just placeholders. Usually I see things like 192.168.xx.xx.  Port numbers, I know nothing.  Maybe less than nothing!  😜
I'll give those numbers a try, right after I read that article!
Thanks again!
Ken Alexander
So Phisai, Thailand
Blog: bueng-ken.com <http://bueng-ken.com>
On Wed, Feb 20, 2019 at 7:43 AM prog <info@... <mailto:info@...>> wrote:
On Wed, Feb 20, 2019 at 08:40 AM, Ken Alexander wrote:
I know they have something to do with networks but beyond that I'm
completely lost.
Nobody is expecting you to be expert in everything involved in the SpyServer.
The golden rule is: If you don't understand something, then leave it to the
default.
But learning is always good:
https://www.eetimes.com/document.asp?doc_id=1275967


Beginner Questions: spyserver config

Ken Alexander
 

OK,

I left the bind_host and bind_port settings as I found them in the spyserver.config file.  Double clicked the spyserver icon in the folder.

1.  It's running from inside the Downloads folder.  Is that OK?  Isn't there a Program Files folder somewhere, just to keep things orderly?

2.  There's no visible indication that spyserver is running.  You double click the icon and, nothing happens.  How do you know it's running?  How do you turn it off?

Anyway, I started spyserver and connected my Pi to a notebook via a LAN cable and ran SDR#.  I selected spyserver as the source.  bind_host was set to 127.0.0.5 and port was set to 5555.  I changed bind_host to 0.0.0.0 to match what was in the spyserver.config file.  See attachment Setting.jpg

I clicked Connect and got the error in attachment Error.jpg, which I don't understand.

I went back into spyserver.config and changed bind_host back to 127.0.0.5 and changed bind_port to 555 instead of 5555-6666 as I originally found it.

I killed spyserver in Task Manager and re-started it so it would take the new settings (attachment Setting2.jpg), double checked the settings in SDR# and clicked Connect and got a new error message (attachment Error2.jpg)

Somebody help please.  This seems relatively simple but it's not working out that way.

Thanks again,

Ken Alexander
So Phisai, Thailand
Blog:  bueng-ken.com


Re: Beginner Questions: spyserver.config

Ken Alexander
 

Thank you!

So those numbers work then?  I thought maybe they were just placeholders.  Usually I see things like 192.168.xx.xx.  Port numbers, I know nothing.  Maybe less than nothing!  😜
I'll give those numbers a try, right after I read that article!

Thanks again!

Ken Alexander
So Phisai, Thailand
Blog:  bueng-ken.com


On Wed, Feb 20, 2019 at 7:43 AM prog <info@...> wrote:
On Wed, Feb 20, 2019 at 08:40 AM, Ken Alexander wrote:
I know they have something to do with networks but beyond that I'm completely lost.
Nobody is expecting you to be expert in everything involved in the SpyServer.
The golden rule is: If you don't understand something, then leave it to the default.
But learning is always good: https://www.eetimes.com/document.asp?doc_id=1275967


Re: Beginner Questions: spyserver.config

prog
 

On Wed, Feb 20, 2019 at 08:40 AM, Ken Alexander wrote:
I know they have something to do with networks but beyond that I'm completely lost.
Nobody is expecting you to be expert in everything involved in the SpyServer.
The golden rule is: If you don't understand something, then leave it to the default.
But learning is always good: https://www.eetimes.com/document.asp?doc_id=1275967


Beginner Questions: spyserver.config

Ken Alexander
 

Today, I'm trying to set up a Spyserver for the first time.  There are no instruction, but much of the settings in the config file look straightforward except for:

bind_host = 0.0.0.0
bind_port = 5555-6666

I know they have something to do with networks but beyond that I'm completely lost.  I'm planning to run this on a Raspberry Pi 3 and access it from across my house with SDR# running on a Windows laptop.  I assume I can do this.

Are there standard/default entries for these two settings?

Many thanks in advance.

Ken Alexander
So Phisai, Thailand
Blog:  bueng-ken.com

P.S.  I did Google both terms, but the definitions are just as obscure as the terms themselves.


Re: Spyserver Online/Unreachable Issue

Bill Thompson
 

Hmarais,
That makes sense, the 8.x.x.x WAN address I had *is* public but my host shares it with many users so it can't send incoming connections to me. Now I understand, thanks!
--Bill


Re: Spyserver Online/Unreachable Issue

hmarais@...
 

In the case of carrier grade NAT, which is what Bill's situation is, your router's WAN address is a private, non-routable address. The ISP then NATs a bunch of people behind one public IP. So the IP address your dynamic DNS service picks up is shared by many connections and, unless you have control of your ISP's networking equipment, means you can't port forward to devices on your LAN.


Re: Spyserver Online/Unreachable Issue

Tom Snyder
 

That is what port forwarding is for in your router, that gets you to the specific address in your network.  I use it for my video security camera, each has there own 168.192.xxx.xxx address, several different PCs, and an ftp server.  Each device is associated with a specific port number that I assigned in the router so it knows what address to send the packets to.

tom


From: main@airspy.groups.io <main@airspy.groups.io> on behalf of Bill Thompson via Groups.Io <flicker177@...>
Sent: Monday, February 18, 2019 06:53
To: main@airspy.groups.io
Subject: Re: [airspy] Spyserver Online/Unreachable Issue
 
Tom,
If you do an nslookup on the "associate ip name" you'll find it does not map to the 192.168.xxx.xxx address. Name or not, that can't show up on the internet.
--Bill


Re: Spyverter R2 with USRP B210 #shortwave

jdow
 

Youssef tried to explain item 2 to you. If you get to this message without understanding then just consider it to be a side effect of the sufficiently advanced technology aka magic.
{^_^}

On 20190217 20:05:15, erik@... wrote:
Hi, and thanks for the response.
I do understand somewhat, but I tried to describe what I thought was unexpected activity:
1. DC to about 22MHz has lots of stations tunable.
2. And since the Airspy site for the Spyverter described only a positive image, I didn't expect any signals below 120MHz, i.e. I expected filtering of some sort, which you allude to, but I still have lots of stations.
3. Nothing is aligned to expected frequencies. Its nigh on impossible to tell what frequency I am tuned to, even if I were to configure an offset (120MHz?)
As an aside, I read about Ettus trying to charge you money to support their products - I'd have bailed on that idea too. I think they up to their necks in government money, and need little support from the hobbyist community, it would seem. But thanks for trying..
Erik.


Re: Spyverter R2 with USRP B210 #shortwave

jdow
 

For what it is worth DC->60 MHz is shifted to BOTH 120-180 MHz and 120-60 MHz. It's called imaging. 1MHs appears at both 121 MHz and 119 MHz on the output of a mixer. Filtering on the mixer output can remove the image if it becomes bothersome. Done wrong it will also remove the spectrum near DC, probably up to over 2MHz with reasonable circuit element Qs. This is clearly shown in the second picture. The first picture may be not showing the broadcast band due to filters and possibly a very small antenna.

{^_^}

On 20190217 09:10:44, erik@... wrote:
Hi,
I purchased a Spyverter R2, and connected it to my USRP B210.
I note from Airspy, "that moves the entire HF spectrum to the VHF band between 120 MHz and 180 MHz".
I am connected to a 30m 'long-wire', via a balun to FM bandstop, and then to the usrp.
Now, I'm not expecting any signals <120MHz... but I have LOTS of stations to listen to, and clearly right from the start of the band, you need only expand the screen to see them individually:
Then, where I'm expecting signals from 120MHz through 160MHz, I find discernible stations below 100MHz:
Not what I was expecting at all.
Furthermore, if DC to 60MHz, is shifted to 120 through 180MHz, then do I assume 121.350MHz should equal 1350kHz? and 140MHz should equal 20MHz in reality? *Nothing* is aligned with the global list of stations I have.
Spyverter is powered from USB port on laptop.
Would anybody be so kind as to offer some thoughts here?
Thanks and regards,
Erik.


Re: Spyserver Online/Unreachable Issue

Bill Thompson
 

Tom,
If you do an nslookup on the "associate ip name" you'll find it does not map to the 192.168.xxx.xxx address. Name or not, that can't show up on the internet.
--Bill


Re: Spyserver Online/Unreachable Issue

Bill Thompson
 

Eric,
I'm fortunate to have a rather new, lean, mean, and hungry provider "Greenlight Networks." Little by little they've been running fiber in the Rochester, NY area. I have their entry-level plan which until recently was 100mbbs, then Spectrum Cable started advertising 100mbps so Greenlight stuck it to them by upgrading everyone to 500 for free...the way competition is supposed to work. For most things I find it really doesn't make much difference becaust the former 100mbps was rarely the bottleneck.
--Bill
KC2RLQ


Re: Spyverter R2 with USRP B210 #shortwave

erik@...
 

Ahh, I looked again at the picture I posted, and I DO see the symmetry either side of 120MHz.... I'll set that as the offset, but as I said earlier, it didn't match to expected stations freqs.

I'll give it another go.

Thanks again.


Re: Spyverter R2 with USRP B210 #shortwave

erik@...
 

Hi, and thanks for the response.

I do understand somewhat, but I tried to describe what I thought was unexpected activity:

1. DC to about 22MHz has lots of stations tunable.
2. And since the Airspy site for the Spyverter described only a positive image, I didn't expect any signals below 120MHz, i.e. I expected filtering of some sort, which you allude to, but I still have lots of stations.
3. Nothing is aligned to expected frequencies. Its nigh on impossible to tell what frequency I am tuned to, even if I were to configure an offset (120MHz?)

As an aside, I read about Ettus trying to charge you money to support their products - I'd have bailed on that idea too. I think they up to their necks in government money, and need little support from the hobbyist community, it would seem. But thanks for trying..

Erik.


Re: Contour Shuttle Pro V2 plugin for SDR# #sdrsharp

Edward MacDonald
 

I just released version 3.1 of the shuttle plugin as a minor update. The problem with the shuttle knob on Express devices staying continually on Filter Bandwidth has been fixed.

Thanks,

Eddie


Re: Spyverter R2 with USRP B210 #shortwave

prog
 
Edited

On Sun, Feb 17, 2019 at 08:00 PM, <erik@...> wrote:
Now, I'm not expecting any signals <120MHz.
Not sure if you fully understand how converters (or any RF mixers) work, but that's perfectly expected. The signals are mixed with a 120 MHz LO. The positive image falls between 120 and 180 MHz, and the negative (inverted) image falls between 60 and 120 MHz. OTOH, the BPF at the output is optimized to attenuate the harmonics, not the negative image.


Spyverter R2 with USRP B210 #shortwave

erik@...
 

Hi,

I purchased a Spyverter R2, and connected it to my USRP B210.

I note from Airspy, "that moves the entire HF spectrum to the VHF band between 120 MHz and 180 MHz".

I am connected to a 30m 'long-wire', via a balun to FM bandstop, and then to the usrp.

Now, I'm not expecting any signals <120MHz... but I have LOTS of stations to listen to, and clearly right from the start of the band, you need only expand the screen to see them individually:



Then, where I'm expecting signals from 120MHz through 160MHz, I find discernible stations below 100MHz:



Not what I was expecting at all.

Furthermore, if DC to 60MHz, is shifted to 120 through 180MHz, then do I assume 121.350MHz should equal 1350kHz? and 140MHz should equal 20MHz in reality? Nothing is aligned with the global list of stations I have.

Spyverter is powered from USB port on laptop.

Would anybody be so kind as to offer some thoughts here?

Thanks and regards,

Erik.




Re: Spyserver Online/Unreachable Issue

Tom Snyder
 

Yes the 192.168.xxx.xxx is not reachable but the associate ip name (not sure of the correct term) is.  So use the name instead of the actual address.


From: main@airspy.groups.io <main@airspy.groups.io> on behalf of Bill Thompson via Groups.Io <flicker177@...>
Sent: Saturday, February 16, 2019 12:56
To: main@airspy.groups.io
Subject: Re: [airspy] Spyserver Online/Unreachable Issue
 
No-IP won't help at all if your WAN internet address isn't routable. If your WAN address is 10.x.x.x, 192.168,x,x or 172.(16-32).x.x nothing will make it appear on the internet. All No-IP does is regularly check your DHCP assigned address in case it changes and provide that via DNS using a name like "yourname.noip.com.

When I discovered this issue I had been assigned a WAN address like 8.x.x.x which by the internet RFC's should have been routable. I believe my ISP found an unused block and decided themselves not to route it. Not a good plan and it could bite them!. Other than this issue I really like my provider, they have fiber right into my house and give 500mbps down and 50mbps up for $50/month; the reliability has been good. For an extra $10/month they now give me a static IPV4 address and spyserver works like a charm with it. And since the IP address never changes I don't need something like No-IP.

--Bill


Re: Spyserver Online/Unreachable Issue

Eric Oyen
 

How did you manage to score a 500MB connection for that low a price? Here in Phoenix, if I want fiber, it will run me north of $200 monthly. Btw, I still need to get one of these devices and setup a spy server here. Right now, though, my income being severely limited by disability makes that rather hard to do.

Btw, I have a couple of the RTL/SDR USB devices using the more common RT series decoders in them. Any way to set this up to work with spy server on OS X? And yes, I do have a static/routable IP here, so all I would need to do is forward the correct ports.

DE n7zzt Eric


On Feb 16, 2019, at 1:56 PM, Bill Thompson via Groups.Io <flicker177@...> wrote:

No-IP won't help at all if your WAN internet address isn't routable. If your WAN address is 10.x.x.x, 192.168,x,x or 172.(16-32).x.x nothing will make it appear on the internet. All No-IP does is regularly check your DHCP assigned address in case it changes and provide that via DNS using a name like "yourname.noip.com.

When I discovered this issue I had been assigned a WAN address like 8.x.x.x which by the internet RFC's should have been routable. I believe my ISP found an unused block and decided themselves not to route it. Not a good plan and it could bite them!. Other than this issue I really like my provider, they have fiber right into my house and give 500mbps down and 50mbps up for $50/month; the reliability has been good. For an extra $10/month they now give me a static IPV4 address and spyserver works like a charm with it. And since the IP address never changes I don't need something like No-IP.

--Bill


Re: Spyserver Online/Unreachable Issue

Bill Thompson
 

No-IP won't help at all if your WAN internet address isn't routable. If your WAN address is 10.x.x.x, 192.168,x,x or 172.(16-32).x.x nothing will make it appear on the internet. All No-IP does is regularly check your DHCP assigned address in case it changes and provide that via DNS using a name like "yourname.noip.com.

When I discovered this issue I had been assigned a WAN address like 8.x.x.x which by the internet RFC's should have been routable. I believe my ISP found an unused block and decided themselves not to route it. Not a good plan and it could bite them!. Other than this issue I really like my provider, they have fiber right into my house and give 500mbps down and 50mbps up for $50/month; the reliability has been good. For an extra $10/month they now give me a static IPV4 address and spyserver works like a charm with it. And since the IP address never changes I don't need something like No-IP.

--Bill

13041 - 13060 of 43367